[hardy] [fglrx] desktop-effects-kde4 won't run: Unresolved symbol

Asked by Swâmi Petaramesh on 2008-05-17

Hi there,

I have several Kubuntu machines running compiz-fusion, but on one which has a fglrx driver (doesn't know if this is relevant or not), I cannot "activate" Desktop effects using "K / System / desktop effects" : Nothing happens.

I've found out that this menu entry runs "desktop-effects-kde4", and if I try to run it manually from a term window I get :

$desktop-effects-kde4
Traceback (most recent call last):
  File "/usr/bin/desktop-effects-kde4", line 30, in <module>
    from DesktopEffects.DesktopEffectsKDE4 import DesktopEffectsKDE4 as DesktopEffects
  File "/usr/lib/python2.5/site-packages/DesktopEffects/DesktopEffectsKDE4.py", line 25, in <module>
    from PyQt4.QtSvg import *
ImportError: /usr/lib/libQtSvg.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

I'm completely clueless with this one. I checked if I had all needed libraries installed, and I think so...

Moreover, if I run "compiz --replace", then compiz-fusion starts and I get a perfectly working 3D Compiz desktop, so I know this is not a graphics driver or X11 config issue... as now Compiz works on the machine.

But still I can't run desktop-effects-kde4.

Any idea ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Swâmi Petaramesh
Solved:
2008-05-18
Last query:
2008-05-18
Last reply:

I just fell on the exact same issue with a 2nd machine freshly upgraded from Gutsy to Hardy. This one has a nvidia graphics card, so the proble doesn't seem to relate to fglrx on the other machine...

I finally found out the solution : After upgrade, I had a non-existing path left in my /etc/ld.so.conf, a previous non-Ubuntu .deb package having been removed during the upgrade to Hardy.
After removing the non-existing path from ld.so.conf, removing ld.so.cache and then running "ldconfig", the problem was solved and now desktop-effects-kde4 works.