No more printing in Hardy ?

Asked by Fred Saunier on 2008-05-17

Hi,

I have a network printer (Espson AL-11CXNF) to which I can no longer print since the last Hardy update (I believe May 16, cupsys update). Prior to that update, everything was just fine. Now, when sending test pages from localhost:631, the job is declared as being sent, then finished; but there is no printer activity (no data is actually sent to the printer). Another computer on the network, running Gutsy, can print to the printer.

I've had a similar issue in the past, and sudo aa-complain cupsd had solved it. But in the present case, it doesn't.

My problem seems similar to the one in question #33007, which is referring to question #33200. I cannot find question #33200.

TIA,
Fred

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Fred Saunier
Solved:
2008-06-24
Last query:
2008-06-24
Last reply:
2008-05-23

Sounds like a bug...
Aside from making sure you're running a generic kernel- that bit me once pretty good...
I'd just set up an SSH server (on the 7.10 box) and share the printer through that until the issue gets resloved.
Not the answer you may wish to hear, but some things in Hardy are not as spic and span as we may have expected.

Fred Saunier (fsaunier) said : #2

Additionally, I did the following testing.

1. Plugged in the printer through usb port : printing unsuccessful.
2. Printing to PDF file (cups-pdf:/) : printing successful.
3. Printing to a second network printer (HP 7310) : printing successful.

So *apparently*, cupsys is working, and the data is stopped at some point when trying to print to EPSON. How can I determine where the data is actually being stopped and who is the culprit?

Thanks,
Fred

adonet (jeroen-adolfse) said : #3

Add yourself to the USB users might help. I dont remember how to do that, but if you google for it you'll find it

Fred Saunier (fsaunier) said : #4

I have compared 2 [i]strace[/i] outputs of an lpr command : one from my Gutsy system, which prints ok, and one from Hardy, which doesn't print at all. Differences between the two outputs I have noticed is the following :

1. [u]futex[/u]

Gutsy (prints):
[code]futex(0xb7f53a6c, FUTEX_WAKE, 2147483647) = 0[/code]

Hardy (does not print):
[code]futex(0xb7f40a6c, 0x81 /* FUTEX_??? */, 2147483647) = 0[/code]

2. [u]/etc/services[/u]

Gutsy (prints):
[code]open("/etc/services", O_RDONLY) = 3[/code]

Hardy (does not print):
[code]open("/etc/services", O_RDONLY|0x80000 /* O_??? */) = 3[/code]

3. [u]fcntl64[/u]

Gutsy (prints):
[code]fcntl64(3, F_GETFD) = 0
fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
fstat64(3, {st_mode=S_IFREG|0644, st_size=18274, ...}) = 0[/code]

Hardy (does not print):
[code]fcntl64(3, F_GETFD) = 0x1 (flags FD_CLOEXEC)
fstat64(3, {st_mode=S_IFREG|0644, st_size=18274, ...}) = 0[/code]

Can somebody interpret this?

Fred Saunier (fsaunier) said : #5

The issue was fixed installing the following package :

sudo apt-get install libstdc++5

Cheers,
Fred