kill switch on with intel wifi 4965

Asked by Fernando Miguel on 2008-05-12

HI there.
I've bough a new laptop (an ASmobile S37S, asus barebone) that has an Intel 4965 ABGN.
I've search ubuntu foruns, lp, and googled all I could, but am unable to make the kill switch off, in order to turn the wifi on.
The card is well identified by the kernel, but there is no way to make it seen to NetworkManager, or even turning on the led.

Also when I tried to use ndiswrapper, it cause a back trace during the boot, and I was forced to use the LiveCD to uninstall it.

Any help is appreciated.

Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Fernando Miguel
Solved:
2008-08-21
Last query:
2008-08-21
Last reply:
2008-05-15

Hi,

Did you install latest version of Ubuntu ? (8.04) . It usually works well with i3945 (may require a kernel upgrade after fresh install).

I sure have.
I have also the have latest kernell available on proposed repository, because some LP tickets said it fixed the problem with some ppl.
But in my case the original hardy kernel already detected the wifi card... I just cant make it On!

Please help.

I've installed boot chart to see if I could track down the problem. You can see the result here:
http://fileland.bugabundo.net/Linux/hardy-20080513-1.png

It seems that the Led turns of when X starts, so my guess is that some RC script is turning off the led and/or on the kill switch.

$ uname -a
Linux BluBUG 2.6.24-17-generic #1 SMP Thu May 1 13:57:17 UTC 2008 x86_64 GNU/Linux

It could be related, but it doesnt say a word about the kill switch (if that is really your problem here)

it actually does:

[quote]
 ------- Comment #44 From Jack Malmostoso 2008-01-22 03:00:28 -------

I have installed 2.6.24-rc8 from the Debian trunk tree (http://wiki.debian.org/DebianKernel) and while leds do not work, the kill switch is now set to "0". It is still not possible
to toggle it but at least now
wireless works.
[/quote]

if only i could get my kill switch to 0 .....

$ sudo rmmod iwl4965
ERROR: Module iwl4965 does not exist in /proc/modules
$ sudo modprobe iwl4965
$ sudo lspci | grep 4965
04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)

https://bugzilla.redhat.com/show_bug.cgi?id=240116#c4

Comment #4 From John W. Linville on 2007-05-15 14:58 EST
[quote]
Looks like iwl3945 is not polling SW-based RF kill switch. Please try this:
   echo 0 > /sys/class/net/wlan0/device/rf_kill
[/quote]

before this I need to remove and re-add the iwl4965 module

after the echo NetworkManager sees the wifi, but ifconfig doesn't.

do you think I should make this "answer ticket" a bug report?

Yes, you should close this question and report the bug ....

Regards

I'm closing this answer, as with the bug ticket associated.

it was hardware related, and after i replaced it, everything is fix.