Can't get audigy 1 sound card working on hardy

Asked by Caroline Ford on 2008-05-09

I think this is support rather than a bug, but as it doesn't Just Work it may be a bug. I have no audio at all, _except_ that if I go to System/Preferences/Sound and select Sound playback as multichannel playback _only_ then I get a tone through my speakers. This doesn't seem to work for any audio applications.

My machine has inbuilt audio as well as an audigy 1 platinum card. The inbuilt audio has been disabled in the BIOS but is still visible.

secret@colossus:~$ cat /proc/asound/cards
 0 [Audigy ]: Audigy - Audigy 1 [SB0090]
                      Audigy 1 [SB0090] (rev.3, serial:0x511102) at 0xd800, irq 21
 1 [V8237 ]: VIA8237 - VIA 8237
                      VIA 8237 with AD1888 at 0xe000, irq 20
secret@colossus:~$

alsa-info.txt: http://pastebin.com/m2c69ec3a

I want to use my audigy as my audio device. What do I need to do?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-05-16
Last reply:
2009-03-07
Caroline Ford (secretlondon) said : #1

I've added the via driver to /etc/modprobe.d/blacklist which gives me:

secret@colossus:~$ cat /proc/asound/cards
 0 [Audigy ]: Audigy - Audigy 1 [SB0090]
                      Audigy 1 [SB0090] (rev.3, serial:0x511102) at 0xd800, irq 21

But still no sound! (apart from the multichannel playback tone)

Caroline Ford (secretlondon) said : #2

In ~.xsession-errors I see some alsa errors:

ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib setup.c:96:(snd_sctl_install) Cannot lock ctl elem
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0

peter b (b1pete) said : #3

hello Caroline Ford,

pls take a look at

http://ubuntuforums.org/showthread.php?t=205449

I hope this will get you going/ solve your problems.

regards,
peter b

Caroline Ford (secretlondon) said : #4

The link you gave is pre-hardy and not much use.

By fiddling with alsamixer I have some sound in rhythmbox. I don't have sound in many applications, which I think is pulse audio related.

Setting sound playback in the sound applet as pulseaudio results in silence. This means that many applications (eg Second Life) have no sound whatsoever.

peter b (b1pete) said : #5

yes indeed, it is pre-hardy written.

pulseaudio is the 'new kid on the block' in hardy and at this time is v much under development/refinement. I knew about it for quite some time and because of this I preferred to stay with the old NO pulseaudio enabled setup; I experimented with it and ended up with 'choppy' kind of output so I disabled/uninstalled it (I'm using audigy2 devices); the app that I care and is v important to me is the voip skype - it works v well without pulseaudio.

there is no doubt that it is a v fast moving project and sooner or later it'll be the norm --> offers many benefits. below there are some url's that may be of help and also show the latest stages this effort is at

https://wiki.ubuntu.com/PulseAudio

http://www.pulseaudio.org/

http://0pointer.de/blog/projects/pulse-glitch-free.html

now, re hardy pulseaudio, I certainly hope you noticed that pulseaudio in order to function (it appears that's also valid with hardy), has quite a few packages that are NOT installed by the default installation--> the first url identifies them; also synaptic will show whether they are installed or not. If pulseaudio is a must in your situation then probably this will be of help and see for yourself the results.

about audigy1 that you mentioned, the card is recognized ok but it appears that is not capable of supporting everything it is asked. and, I'm not sure if pulseaudio will work with it.

peter b

I have the same configuration (Audigy + Via 8237 on hardy) ... and the same problem.

So the only thing I can add is "you're not alone" because I don't have any solution.

Olivier.

Disabling the on-board card through the BIOS solved my problems.

Note that once disabled, it not visible anymore with:

      cat /proc/asound/cards

So, if you still sees it, it might be that the BIOS disable did not work (or was not saved correctly).

Olivier.

Can you help with this problem?

Provide an answer of your own, or ask Caroline Ford for more information if necessary.

To post a message you must log in.