Cannot unshare directories in nfs or samba

Asked by Warren on 2007-01-17

I have a fresh install of Ubuntu 6.10. Everything looked good. I turned on file sharing via system_menu->administration->services. Then I shared my home directory to both samba and nfs using system_menu->administration->shared_folders. So far so good.

I tried to connect from a windows computer, but couldn't connect - but this is not my main problem. I decided to un-share the directory in order to troubleshoot samba. I went in through the gui tool again and clicked delete share. A couple minutes later I started the tool again to turn the share back on. But it was still being shared. Again I tried to unshare the folder. No luck. I don't receive any errors. The share disappears on the screen. But when I exit the tool and go back in, its there again. I also tried using the command line tool and using the nautilus tool. They all give more-or-less the same result.

After getting frustrated, I directly edited /etc/samba/smb.conf and deleted the text about the shared directory, then restarted. Now I sometimes only see the nfs share, and sometimes see both the nfs share and the samba share.

I am very confused. Does anyone know what might be going on here?

Thanks in advance,
Warren

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-01-17
Last reply:
2007-02-12
Warren (warrenbaltz) said : #1

This appears to be only an nfs issue now. Newly created samba shares can be unshared, but nfs shares still stick.

Ralph Janke (txwikinger) said : #2

try

   umount -lf

in the command line

Ralph Janke (txwikinger) said : #3

that should be

    umount -lf <share>

Can you help with this problem?

Provide an answer of your own, or ask Warren for more information if necessary.

To post a message you must log in.