zd1211 based wireless not working on hardy

Asked by Carlos Barros on 2008-05-01

I have a ZD1211 based usb wireless stick. it was working just fine on Feisty. 4 days ago i decided to upgrade my system with hardy. it works fine except for the wireless network card.

I was looking for a solution before came here, but i couldn't get one.

i have an AMD 64bit hardy installation and this is my dmesg output:

[ 25.368780] usb 2-2: reset high speed USB device using ehci_hcd and address 3
[ 25.501664] zd1211rw 2-2:1.0: eth2
[ 25.501673] usbcore: registered new interface driver zd1211rw
[ 30.301333] zd1211rw 2-2:1.0: firmware version 4605
[ 30.341295] zd1211rw 2-2:1.0: zd1211 chip 0ace:1211 v4330 high 00-02-e3 RF2959_RF pa0 g----
[ 31.342636] zd1211rw 2-2:1.0: error ioread32(CR_REG1): -110
[ 44.306726] ADDRCONF(NETDEV_UP): eth2: link is not ready

i would appreciate some help.

thanks a lot

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
peter b
Solved:
2008-05-10
Last query:
2008-05-10
Last reply:
2008-05-10
Olivier (olivier-lacroix) said : #1

Hi Carlos !

This looks like a bug to me. I think you should report it in launchpad.

peter b (b1pete) said : #2

hello Carlos Barros,

I have the same wireless hardware on two PC's; on one, the i386 hardy was installed (fresh install) and on the second one amd64 hardy also fresh install. Below is my experience with ZyDas usb wireless dongles and drivers in hardy -

I always install the os WITHOUT the usb wireless dongle attached; if available, use the WIRED internet connection ONLY, if not available OR there are problems in configuring it just skip internet configuration at install time by choosing the option DO NOT CONFIGURE NOW - the install will continue without it.

After the first boot into the installed os WITHOUT the usb dongle attached - which should be successful - power down the PC --> CONNECT to an usb port the dongle --> then power up and boot.

Now, here's the interesting part

- on the first -i386 install - the new usb attached wireless interface was AUTOMATICALLY recognized and configured --> when network manager was opened it displayed the access points in range, the only thing I had to do was to check the radio button that I want to connect. in this case the zd1211rw driver in the distro worked OK1 without any additional tweaking. however

- on the second -amd64 install- the zydas wireless dongle WAS NOT automatically recognized --> I used ndiswrapper package to get the win drivers installed AND, V IMPORTANT --> BLACKLIST THE zd1211rw DRIVER --> WITHOUT BLACKLISTING zd1211rw THINGS DO NOT WORK. everything works great since.

If you have windows xxxxxx.inf and xxxxxx.sys drivers available for the ZyDas usb dongle just use ndiswrapper to install them and blacklist zd1211rw --> it should work for me. for sure you know how to use ndiswrapper.

regards,

peter b

Carlos Barros (cbarros-sixca) said : #3

Hi guys.

I'm writing this from Hardy.

I did what peter said. I don't like it, but it works.

I think it is not the ideal status. Don't you find it rare? why Gutsy works fine with my Wireless Stick and Hardy don't?
isn't supposed Hardy it's an UPGRADE version of Gutsy? it is not supposed Hardy will be backward compatible?

well, at this time (4 hours after get wireless working) it is working fine.

using my Gutsy partition, i did this:

1- I got the Zydas USB Driver from here:

http://drivers.softpedia.com/progDownload/ZyDAS-ZDB-Driver-Download-16176.html

and unpacking "using uniextractor and wine", after that, i put the .inf , .cat and .sys files in my hardy partition on a temp folder

2- i got this 3 packages from packages ubuntu website

- ndiswrapper-common_1.50-1ubuntu1_all

- ndiswrapper-utils-1.9_1.50-1ubuntu1_amd64

- ndisgtk_0.8.3-1_amd64

 i put them in my hardy partition on a temp folder

NOTE: "I HAVE AN AMD 64BIT CPU", If you have an i386 Hardy, find the wright ones.

3- I boot Hardy and edit and blacklisted the 2zd1211rw" driver in "/etc/modprobe.d/blackist" file by adding this:

blacklist zd1211rw

at the end of the file.

4- I just double click on the 3 packages in the same order listed before (Step 2).

5- find the Ndisgtk installed utility on System - Management - Windows Wireless Drivers Menu. Add the windows driver and restart the computer.

That is all. at this point, you should be able to see the wireless networks around you.

if any body knows how to get this working with the linux native driver, let me know it please.

Olivier (olivier-lacroix) said : #4

As I said, this looks to be a bug. If I were you, I would report it. You may get attention from developers, and the issue will certainly be resolved in a kernel update.

Olivier (olivier-lacroix) said : #5

Report the bug against the package linux-source-2.6.24

Best peter b (b1pete) said : #6

hello Carlos,

I could see that your ZyDas works ok after using ndiswrapper as I suggested; it addressed the topic of this question and got you going.

please close this ticket as solved and if you wish, by all means, feel free to file a bug report if you're not happy that the distro driver is not working.

best regards.

peter b

Carlos Barros (cbarros-sixca) said : #7

Thanks peter b, that solved my question.