no suspend or hibernate on toshiba satellite u305 with ubuntu 8.04

Asked by dwinstonm on 2008-04-30

When first installed hardy, suspend worked fine, but wifi card did not. Got wifi working (atheros madwifi driver, headache to get going), now computer will not suspend or hibernate, but it shuts down and starts up fine. Cannot copy script from suspend action, it locks up. Once it stops up, i can end the display manager and restart the computer (ctrl-alt-del) without a hard shutdown, but it never hits suspend completely and will not return to the desktop. I've just switched to Ubuntu from Vista just a few days ago, and this is the last of my major issues that I haven't been able to work through.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier
Solved:
Last query:
Last reply:
Revision history for this message
subliminalfix (na1tr2lp-deactivatedaccount) said :
#1

hi sorry your having trouble

this may sound bizarre but is ther a way you can remove your hard drive or specifically your memory card??

there is a bug written into vista that carries into other modulations

if this womt work for you ewill tryng to reload your system withtout your {11}

log into an altenitevive root

for example xubunt alternative c.d.

opnce again sorry your having diffeculty

dwinstonm <email address hidden> wrote: New question #31541 on Ubuntu:
https://answers.launchpad.net/ubuntu/+question/31541

When first installed hardy, suspend worked fine, but wifi card did not. Got wifi working (atheros madwifi driver, headache to get going), now computer will not suspend or hibernate, but it shuts down and starts up fine. Cannot copy script from suspend action, it locks up. Once it stops up, i can end the display manager and restart the computer (ctrl-alt-del) without a hard shutdown, but it never hits suspend completely and will not return to the desktop. I've just switched to Ubuntu from Vista just a few days ago, and this is the last of my major issues that I haven't been able to work through.

--
You received this question notification because you are an answer
contact for Ubuntu.

---------------------------------
Be a better friend, newshound, and know-it-all with Yahoo! Mobile. Try it now.

Revision history for this message
dwinstonm (dwinstonm) said :
#2

Interesting idea. I booted up with the 8.04 live CD, and it seemed to suspend just fine. Ideally i'd like to figure out how to fix this without taking out the hard drive, if it seems that's only solution then I'll be fine with it. I'm suspecting that it may be some driver conflicts in the registry, I'm really not sure how to go about finding out where it is or what to edit.

Revision history for this message
dwinstonm (dwinstonm) said :
#3

Thank you very much for your help so far.

Revision history for this message
Best Olivier (olivier-lacroix) said :
#4

dwinstonm, if suspend was working before you installed the wifi, the wifi is certainly the culprit. Try to unload the wifi module, entering in a terminal :

sudo modprobe -r madwifi

If madwifi is the module name. Sorry but I don't know the exact name. You can get the list of your loaded modules entering in a terminal

lsmod

then try to suspend. Tell me if that helps.

You may also have a look a that page, and try several quirks given there http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html

@Stafford : you are only saying nonsense. As usual.

Revision history for this message
dwinstonm (dwinstonm) said :
#5

I could not disable the wireless modules through the terminal. There are 2 running, ath_pci and ath_hal. Attempting to disable ath_pci responds "Segmentation Fault", and ath_hal responds "FATAL: module ath_hal is in use".
I hand-copied the readout of the display when suspend freezes. It looks something like this:

- ==========
- code: ** ** ** ** ** (hexidecimal code)
- EIP: [<f8df0e7e>] ieee80211_virtfs_vdetatch +0x8e/0xf0 [wlan] SS:ES P 0068:f295le64
- --[Endtrace 02840c45b4a9336e]--

then it stops. It doesn't respond to any keystrokes, but hitting crl-alt-del shuts down GNOME display manager, and then after it shuts down ctrl-alt-del needs hit again to actually restart. On the shutdown readout, i saw the message:

- Stopping wireless access point roaming daemon: (no such file or directory)

i don't know if this may have something to do with the problem.

Running the quirk-checker.sh script responds "Suspend should work!"

That's where I'm at so far. Still etching away at it.
Thanks.

Revision history for this message
dwinstonm (dwinstonm) said :
#6

I disabled the 2 atheros wifi drivers using the GUI proprietary driver manager, (hardware settings?), and rebooted system. Computer still does not completely suspend, but there is no text displayed this time, just a blinking cursor in the corner of the screen.

Revision history for this message
Olivier (olivier-lacroix) said :
#7

OK. Are you sure those two modules are not loaded ? you can check using the "lsmod" command.

I don't really know what the quirk checker does, but on my computer, it said that suspend should work, but still, I needed to add a quirk to get it working properly. I strongly advise you to try some quirks. The first thing to do is to try to suspend without X.org running. To do that, switch to a console (ctrl+alt+F1) , log in, and kill gdm (or kdm if you are running kubuntu), by

sudo killall -9 gdm

then try to suspend by

sudo pm-suspend

Tell me if that works

Revision history for this message
dwinstonm (dwinstonm) said :
#8

I double checked the loaded modules, and then tried to suspend again, and it worked!!
I installed the windows wireless driver for the card with ndiswrapper, and now it works just fine.
Thanks a bunch.

Revision history for this message
dwinstonm (dwinstonm) said :
#9

Thanks Olivier, that solved my question.