Not your average brightness problem

Asked by Iago on 2008-04-30

I've been trying to get this problem fixed for about 3 days and nobody knows how to fix this. Hopefully you can help me. My brightness won't do anything but be REALLY REALLY dark, and be averagely dim, and I can toggle this by hitting fn+f7. Normally, like on Vista (if you can call that normal) fn+f6 or fn+f5 would toggle my brightness. ALL of my other function keys (volume, media, toggle scr lk, etc.) are working. So it's weird. I know someone else has this problem but aren't being as annoying about it as I am.

What I have already tried:
-gamma control with "displaycalibrator"

-the tutorial "howto" here: http://ubuntuforums.org/showthread.php?t=767374 which is the same as the ubuntu geek method, when I hit fn+up, my music player stops playing, fn down, it pauses/plays. That's how it normally works in Windows, so it probably isn't mapping the brightness over the normal function.

-The "ugly hack" described in http://ubuntuforums.org/showthread.p...ght=brightness
^ Im not sure why that doesn't work, it just doesn't...

-One thing I'd like to try (it seemed bright, but I was in a bright room) was I entered the gnome power management config(I forgot the command! It's something like gkconfig?) So I need to be reminded of that enter-gnomeconfig-command...

-The brightness applet on the panel does nothing.

- I was suggested on ubuntuforums to do the following:
CODE
iago@NISUS:~$ echo 'for i in /sys/class/backlight/*/brightness; do echo 10 > $i; done' > brightness
iago@NISUS:~$
iago@NISUS:~$ chmod +x brightness
iago@NISUS:~$
iago@NISUS:~$ sudo ./brightness
iago@NISUS:~$ brightness
/usr/local/bin/brightness: line 1: /sys/class/backlight/acpi_video0/brightness: Permission denied
/usr/local/bin/brightness: line 1: /sys/class/backlight/asus-laptop/brightness: Permission denied
Brightness set to
iago@NISUS:~$ sudo brightness
Brightness set to
iago@NISUS:~$ sudo brightness 10
Brightness set to 10
iago@NISUS:~$ sudo brightness 1
Brightness set to 1
iago@NISUS:~$ sudo brightness 1000
Brightness set to 1000
iago@NISUS:~$
iago@NISUS:~$

CODE

And it doesn't change my brightness. Secondly, one problem with what the previous guy gave me is there is no /sys/class/backlight/brightness, on my laptop it goes /sys/class/backlight/asus-laptop/brightness, there's also /max-brightness, and other tings in asus-laptop. I cant even open it in gedit, though. The little documents in my asus-laptop brightness do change with his commands, but it doesn't effect my brightness

-I found an application called "monitor settings" but it doesnt work. It gives me the following error: "No monitor supporting DDC/CI available. If your graphics card need it, please check all the required kernel modules are loaded (12c-dev, and your framebuffer driver).

-I am getting nauseous, I have to strain to read the screen because it's so dark

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Iago (dasquirrel715) said :
#1

I am on an ASUS M50sv with a NVIDIA 9500M GS

Revision history for this message
Olivier (olivier-lacroix) said :
#2

Hi !

what does the following command give you ?

cat /sys/class/backlight/asus-laptop/max_brightness

Revision history for this message
Olivier (olivier-lacroix) said :
#3

Maybe also have a look at smartdimmer. See http://ubuntuforums.org/showthread.php?p=2702790#post2702790

Revision history for this message
Iago (dasquirrel715) said :
#4

root@NISUS:~# cat /sys/class/backlight/asus-laptop/max_brightness
15
root@NISUS:~#

Revision history for this message
Iago (dasquirrel715) said :
#5

root@NISUS:~# apt-get install smartdimmer
Reading package lists... Done
Building dependency tree
Reading state information... Done
smartdimmer is already the newest version.
The following packages were automatically installed and are no longer required:
  kdebase-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@NISUS:~# smartdimmer -g
init_nvclock() failed!
root@NISUS:~# smartdimmer -s
smartdimmer: option requires an argument -- s

Try `smartdimmer --help' for help.
root@NISUS:~# smartdimmer -s 10
init_nvclock() failed!
root@NISUS:~#

Revision history for this message
Iago (dasquirrel715) said :
#6

I used the NVIDIA SErver Control Manager and changed the brightness there. You download it from the add/remove application, find it in administration, and .you can adjust all the things like brightness and contrast!

Revision history for this message
Iago (dasquirrel715) said :
#7

nevermind, this not fixed

Revision history for this message
watercries (wirth13boom) said :
#8

yep, im having the same issue on the same notebook, is it bright at startup than dimms as the O.S. loads

Revision history for this message
Pavel Belyaev (o4kareg) said :
#9

same trouble with Asus X80L. I tried to fix it with this instruction: http://seethisnowreadthis.com/2008/05/19/how-to-install-ubuntu-804-hardy-heron-on-the-asus-m50sv-a1/
but it was no use.
By the way, does anyone knows, if the user can change the value of /sys/class/backlight/asus-laptop/max_brightness? I think this value is the core of the problem. How can I change it to higher value?

Revision history for this message
Pavel Belyaev (o4kareg) said :
#10

By the way, this instruction was useless, too: https://lists.ubuntu.com/archives/kernel-bugs/2008-June/037726.html

Revision history for this message
Syarif (psychicmind9) said :
#11

i got a simple and better solution.
its working like a charm for my computer using Ubuntu 9.04.
You dont need to change any file manually and
i make the tutorial as simple as i can.

You can seek for my post here:
https://bugs.launchpad.net/ubuntu/+s...8?comments=all

Revision history for this message
00oo00 (austinloveit) said :
#12

Can you help with this problem?

Provide an answer of your own, or ask Iago for more information if necessary.

To post a message you must log in.