Cannot connect to official NZ server from some networks

Asked by Dean Sas

"I get the following errors when running apt-get update.....the mirror is not 'down' from everywhere."

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Karl Tilbury
Last query:
Last reply:
Revision history for this message
Dean Sas (dsas) said :

see linked bug for more details.

Revision history for this message
dub (dub-dub) said :

Some background

Note that the rejection of HTTP requests is a recent (last 3-4 weeks) development.

Revision history for this message
Matt Brown (mattbrown) said :
#3 is an Anycast instance maintained by Citylink NZ, who operate the two major peering exchanges in New Zealand.

There are three instances of the archive one in Wellington, one in Auckland and one in the US. The Wellington and Auckland instances are only available to ISPs who peer at the exchanges. Citylink provides the US instance to pick up any stragglers who are unfortunate enough to be on ISPs which do not peer at the national peering exchanges.

The reported problem seems to stem from the fact that the US instance is currently not listening on port 80. So this problem is only affecting a portion of the users of the service.

I have emailed the CityLink administrators to make them aware of this problem. I will update this ticket when I hear back from them.


Matt Brown

Revision history for this message
Best Karl Tilbury (karl-tilbury) said :

I have pointed at another mirror until the issue is resolved.

Revision history for this message
Dean Sas (dsas) said :

User confirmed that the request is solved.