Cannot exit X Server into terminal on Kubuntu Edgy

Asked by Matthew Flaschen on 2007-01-10

I can't exit Kubuntu Edgy into the X Server. All attempts, including openvt, Ctrl-Alt-Backspace, killall -9 kdm XOrg, result in the X Server restarting, my computer freezing, or nothing at all.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Matthew Flaschen
Last query:
Last reply:

Sorry, I said "I can't exit Kubuntu Edgy into the X Server." but meant "I can't exit Kubuntu Edgy's X Server into the terminal".

Alan Pope  (popey) said : #2

What happens if you press CTRL+ALT+F1 to get to the console, and CRTL+ALT+F7 to get back to xorg?

Also, what video card and driver are you using?

Some Nvidia cards with the binary driver give you a blank screen instead of a console when you exit xorg.

Ctrl+Alt+F1 (or Ctrl+Alt+F#) gives me only a black screen. I never exits to the terminal, and I have to restart.

I'm using an ATI Mobility Radeon X1300, but I didn't install the proprietary driver. I think I'm just using vesa.

I've also tried to get help at

Vadim Abramchuck (abramzzz) said : #4

Try installing ATI's driver. As I remember, you have to install some packages... but I don't remeber which :). Try searching ATI in package descriptions.

Alan Pope  (popey) said : #5

The following page details how to install the binary ATI driver and the impact of doing so.

Sorry, I'm not installing a proprietary driver for this. I'm willing to accept that that means I can't access the terminal; however, that doesn't make sense to me from a technical perspective...

Bill Pollifrone (waylandbill) said : #7

if you pass a '1' to the kernel from grub to get to single user mode, does it give you the terminal? Perhaps it is a VGA mode that is unsupported.

I forgot to try that, then for some reason the X server wouldn't load (uh-oh) and I chose the recovery mode option in grub. I got to terminal (as root)!

I didn't know this before, but I just checked and found that this passes the "single" option. So, I think you were right after all. Thanks.