Troubles with NVIDIA drivers on 8.04

Asked by Bartek on 2008-04-27

Well, it seems that my graphic drivers doesn't work. It was okay before my ubuntu update to 8.04. I've tried to install drivers by repository, from the nvidia site, by EnvyNG and nothing work at all.

In Xorg.0.log:
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

I was trying to remove all drivers and install again and still nothing.

# lshw -C video
  *-display
       description: VGA compatible controller
       product: NV43 [GeForce 6600]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: driver=nvidia latency=0 module=nvidia

Could anyone help me please?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-04-27
Last reply:
2008-05-01
Bhavani Shankar (bhavi) said : #1

Hello Bartek

1. Purge the nvidia restricted package if installed by doing a "sudo dpkg --purge nvidia-glx-new"
2. Kill the gdm server, "sudo /etc/init.d/gdm stop"
3. Install the driver.

sudo aptitude install nvidia-glx linux-restricted-modules-`uname -r`

4. start gdm server "sudo /etc/init.d/gdm start"

Have a try

Bhavani Shankar.

Bartek (dungaar) said : #2

Still doesn't work :(

Bhavani Shankar (bhavi) said : #3

Hmm OK

This is a known bug in hardy please refer:

https://bugs.edge.launchpad.net/ubuntu/+source/xorg/+bug/173418

Hope it helps

Regards

Bhavani Shankar.

Bartek (dungaar) said : #4

It helps, thank you.
There is said to install 173.08 driver but its not for my platform.

ERROR: this .run file is intended for the
Linux-x86_64 platform, but you appear to be
running on Linux-x86. Aborting installation.

Problem still occurs :(

Bhavani Shankar (bhavi) said : #5

Did you try downloading from the PPA there? If not please include the ppa in your sources.list and try...

And the driver for 32 bit systems can be downloaded from:

http://www.nvidia.com/object/linux_display_ia32_173.08.html

Regards

Bhavani Shankar.

Bartek (dungaar) said : #6

Instalation has failed:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Apr 27 16:14:58 2008

option status:
  license pre-accepted : false
  update : false
  force update : false
  expert : false
  uninstall : false
  driver info : false
  precompiled interfaces : true
  no ncurses color : false
  query latest version : false
  OpenGL header files : true
  no questions : false
  silent : false
  no recursion : false
  no backup : false
  kernel module only : false
  sanity : false
  add this kernel : false
  no runlevel check : false
  no network : false
  no ABI note : false
  no RPMs : false
  no kernel module : false
  force SELinux : default
  no X server check : false
  no cc version check : false
  force tls : (not specified)
  X install prefix : (not specified)
  X library install path : (not specified)
  X module install path : (not specified)
  OpenGL install prefix : (not specified)
  OpenGL install libdir : (not specified)
  utility install prefix : (not specified)
  utility install libdir : (not specified)
  doc install prefix : (not specified)
  kernel name : (not specified)
  kernel include path : (not specified)
  kernel source path : (not specified)
  kernel output path : (not specified)
  kernel install path : (not specified)
  proc mount point : /proc
  ui : (not specified)
  tmpdir : /tmp
  ftp mirror : ftp://download.nvidia.com
  RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
   ke the installer to attempt to download a kernel interface for your kernel f
   rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
   this means that the installer will need to compile a kernel interface for
   your kernel.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> The CC version check failed:

   The compiler used to compile the kernel (gcc 4.1) does not exactly match the
   current compiler (gcc 4.2). The Linux 2.6 kernel module loader rejects kern
   el modules built with a version of gcc that does not exactly match that of t
   he compiler used to build the running kernel.

   If you know what you are doing and want to ignore the gcc version check, sel
   ect "No" to continue installation. Otherwise, select "Yes" to abort install
   ation, set the CC environment variable to the name of the compiler used to c
   ompile your kernel, and restart installation. Abort now? (Answer: No)
ERROR: The kernel header file '/usr/src/linux/include/linux/version.h' does not
       exist. The most likely reason for this is that the kernel source files
       in '/usr/src/linux' have not been configured.
ERROR: Installation has failed. Please see the file
       '/var/log/nvidia-installer.log' for details. You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

Bhavani Shankar (bhavi) said : #7

Hmm ok...

Try the PPA one.. (read timo's comments)

and post back again

Regards

Bhavani Shankar.

Bartek (dungaar) said : #8

I tried. Synaptic updated my drivers and... guess what.
Still nothing :(

Are you able to install gcc 4.1 using:-
sudo apt-get install gcc-4.1
?

georgaeie (georg-gac) said : #10

Hello everyone,

I had the exact same problem when upgrading from gutsy 7.10 to hardy 8.04.

I have a nvidia geforce 6100 card.

The solution on my system was simple; the old /boot/grub/menu.lst was still in place, causing the old kernel to be loaded in stead of the new one. I spent 4 hours figuring this out. Clever me... The 'kernel is compiled using gcc-4.1 should have set off the alarm'..

Anyway, I did the following:

sudo -i
vi /boot/grub/menu.lst (changed everything from 2.6.22-14-generic to 2.6.24-16-generic - make sure you refer to the correct kernel in /boot !!)
reboot
apt-get install nvidia-glx-new linux-restricted-modules nvidia-settings
rm /etc/X11/xorg.conf
nvidia-xconfig
/etc/init.d/gdm restart (may need to stop gdm, kill all remaining X processes and start gdm again)

..and now everything works!

Can you help with this problem?

Provide an answer of your own, or ask Bartek for more information if necessary.

To post a message you must log in.