Partition numbering changed after every major upgrade - is that a bug?

Asked by tomZZZ on 2008-04-26

Hi all,

after every major version upgrade with Ubuntu (from 5 -> 6, 6 -> 7, 7 -> 8) my menu.lst is "messed up" in that the System which is autostarted has been changed and that all the partition numbers for Ubuntu have been changed (from the correct (hd0,2) to the incorrect (hd0,1) so that nothing boots (except Windows :-( ) and I have to change everything manually in menu.lst

I have 2 different Windows XP versions in the first 2 partitions of the first hard disk and after that Ubuntu in the 3. partition of the first hard disk.

As I said, that problem re-occurs with every major upgrade and I have it on at least two machines (all configured the way described above).

This kind of behaviour repeatedly keeps me from recommending Ubuntu to friends and colleagues, cause I know how completely stuck they'd be faced with a non-booting system with only some "error xyz" message in their face.

However, maybe this isn't a bug, but only some kind of misconfiguration on my part which makes Ubuntu change my menu.lst the wrong way every time I upgrade?

I'd be very glad for any hint or help!

Thanks and greetings,

tom

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-04-26
Last reply:
2008-04-26

Can you help with this problem?

Provide an answer of your own, or ask tomZZZ for more information if necessary.

To post a message you must log in.