How to DOWNGRADE from Openoffice 2.4 to 2.3.1

Asked by John Toliver on 2008-04-25

I installed Hardy Heron this morning and along with it openoffice 2.4. I tested a database I had been working on in version 2.3.1 and found that my reports were not running properly. I get an error:

"The query with the statement '' could not be run. Check your data source."

to duplicate this take a database with a report pointing to a query, that is looking at a table. Do all of this in 2.3.1. Then try to run the report in 2.4 and you should get this error.

I have no idea when this problem will get fixed but I need to downgrade to 2.3.1 or whichever was the last version of Openoffice before Hardy was released.

How can I do this safely? (ie without screwing up my synaptic databases etc). Hardy must have a simple way of downgrading to an earlier package?!

Thanks in advance for any help provided.

Please email me if you require any more detail than this.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-04-26
Last reply:
2008-05-01
John Toliver (john-toliver) said : #1

For further reading and confirmation of this error, have a look at these links of others experiencing this problem here:

http://www.oooforum.org/forum/viewtopic.phtml?t=69966

and here:

http://www.oooforum.org/forum/viewtopic.phtml?t=70475&highlight=query+statement+run+check+cheque+data+source

John Toliver (john-toliver) said : #2

While it's a bit unorthodox, I solved it partially by searching for a generic "sources.list file from a vanilla Gutsy install. I then painfully installed as many packages which seemed like they belonged to the 2.3.1 group. By trial and error I was able to fire up Openoffice 2.3 and finally get the database program to read and process my reports. Once I got 2.3 up and running, I then restored my Hardy repository list. I say it's partially fixed because I'm still not 100% sure I've installed everything. The report builder package still chokes when I try installing it through synaptic. I'm waiting to see what else breaks over the course of the next few days.

If anyone can provide some insight on how best to verify the integrity of my installation and make sure all the packages are where they are supposed to be, I'd appreciate it. I don't plan on updating openoffice again for a long time. I've since discovered the "lock" command for packages.

Bhavani Shankar (bhavi) said : #3

Hello

I think you can pin a version and downgrade.

can install a specific version and then 'pin' it so that the
update-manager ignores it. For example, I recently 'downgraded' openoffice
like this:

   $ sudo aptitude openoffice.org=1:2.3.0-1ubuntu5

Next I added the following entries to /etc/apt/preferences:

   Package: openoffice.org
   Pin: version 1:2.3.0-1ubuntu5*
   Pin-Priority: 1001

Now the update manager ignores updates for those packages.

See the APT HOWTO here:
http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.en.html#s-pin

https://help.ubuntu.com/community/PinningHowto

Regards

Bhavani Shankar.

Can you help with this problem?

Provide an answer of your own, or ask John Toliver for more information if necessary.

To post a message you must log in.