Ubuntu 8.04 Final release - Audio not working on Sony Vaio TR2MP

Asked by thestonefox on 2008-04-25

The audio speaker in the menu bar shows up and it allows me to put the volumn up and down, so it is finding a driver. It just doesnt play any sounds.

It's an intel sound chip (i think the AC 97 based one)

Works fine in my Win XP partition, so theres nothing wrong with the hardware.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
thestonefox
Solved:
2008-04-27
Last query:
2008-04-27
Last reply:
2008-04-26

This question was reopened

Rafik Ouerchefani (rafik) said : #1

Hello,
Please try with :

sudo /etc/init.d/alsa-utils reset

-Rafik

thestonefox (thestonefox) said : #2

Tried this, hasnt changed anything, still no sound.

Just a bit more info: My device is set to

Intel 82801DB-ICH4 (Alsa Mixer)

jasulliv (jasulliv) said : #3

I upgraded from kubuntu 7.10 to 8.04 LTS last night and sound doesn't work. Now there is no welcome sound at boot up and no sound in any application after that.

My machine is an old toshiba Laptop SP4600.

Can anyone suggest something to try?

thanks,

thestonefox (thestonefox) said : #4

Can we keep this thread to solutions only. I don't want a thread of people saying "it doesnt work for me either", We all know it doesnt work, lets just see if someone has an answer or something constructive to say.

Firall (dhimanidr) said : #5

If uname -r ends with 386... Go ahead and try

sudo apt-get install linux-386

and

sudo apt-get install linux-ubuntu-modules-$(uname -r)

After a restart, I got sound again.

thestonefox (thestonefox) said : #6

I tried this, however it didnt work. I still have no sound but I do now have 2 new entries in GRUB to load Ubuntu up in 386 as well now.... :(

It feel like Vista all over again :( Roll on Fedora 9 :p

thestonefox (thestonefox) said : #7

this isnt solved

thestonefox (thestonefox) said : #8

Ok now it's solved.

From using the solution here: http://ubuntuforums.org/showthread.php?t=730142

What I did was this

1: Double click the speaker icon in the menu bar
2. When Volume Control opens, I went to File -> Change Device and ensured my Intel 82801DB-ICH4 (Alsa Mixer) was selected
3. Then went to Edit -> Preferences and in the pop up window ticked every box found. Then clicked close on the popup.
4. Back in the Volume Control window, I now had 4 tabs (Playback, Recording, Switches, Options)
5. I Clicked the "Switches" tab, in here I only had 1 option "Headphone Jack Sense" when i clicked the tick box on it a load more options appeared (this may be a bug, you may see all options straight away)
6. I Scrolled down the options and ticked "Mix" and unticked "External Amplifier"
7. Sound now works fine :)

(P.S. is there anyway of rolling back your ubuntu install like you can in Windows? I'd like to roll back before the linux-386 apt-get install as i dont think it is needed plus it is taking up space)

Firall (dhimanidr) said : #9

Apt-get remove

Firall (dhimanidr) said : #10

Second thought, take caution, didn't realize you had two identical entries (My fault for not paying full attention)... Thats a bit strange, : / I'd still give it a go, just backup quick if it bothers you that much, however, I don't know if there is a better solution.

Jason Galyon (jtgalyon) said : #11

I am using KDE4 (Kubuntu 8.04), anyone have an idea how to get the audio icon so I can edit my settings similar to what thestonefox reported?

Joshua Ryan Smith (jrsmith3) said : #12

I had a similar problem on my new Dell Inspiron 530S. The sound wasn't working with Kubuntu release 8.04. The solution in the following thread worked for me:

http://ubuntuforums.org/archive/index.php/t-765443.html

Essentially you just need to turn all the levels up in the mixer. Once I did that, I futzed around with the various levels until I didn't get static any more.

Good luck.

Vinnie2Paul (vin326) said : #13

Working on Sony Vaio PCR-TR2A, had no sound, just followed 'thestonefox's suggestions, works perfectly. Thank you so much.
Continued good luck.

swadeg8tor (swadeg8tor) said : #14

Thanks stonefox, worked like a charm on my vgn-b100b.

msk (smsalika-yahoo) said : #15

I have the same problem and i have tried most of the fixes available online. My sound works fine when I'm using headphones but it's dead on the internal speakers. If anyone has found a fix to it can you please let me know

Thanks

PS: I hope the Admin won't take this as spam but I need help from anyone around the world who is willing to sign my online petition. I fear for my life if I am deported back to Zimbabwe. Please Please let the spirit of Ubuntu live on and sign my petition on this link.

http://www.gopetition.com/petitions/22858.html

Vook (kitsune-vook) said : #16

I don't know why.. but this worked XD thanks a lot!