ibm 600 e ubuntu no sound

Asked by scouse on 2008-04-21

I have installed Ubuntu on a ibm 600e laptop but I cannot get any sound. Can any one help?
scouse

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Bhavani Shankar
Solved:
2008-04-22
Last query:
2008-04-22
Last reply:
2008-04-21
Best Bhavani Shankar (bhavi) said : #1

Hello

This link might help you out:

http://www.substantis.com/blog/?p=38

This is a known problem with the Think Pad 600E. The soundcard is incorrectly identified as
CS462x.

There are plenty of web pages out there describing solutions to this. But
here is the Reader's Digest version:

1. Blacklist the incorrect sound card in /etc/modprobe.dblacklist. Add lines
for

blacklist snd-cs46xx
blacklist cs46xx

as written above - with the xx's

2. Add the following lines into /etc/modprobe.d/alsa-base

alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-cs4236
options snd-cs4236 isapnp=0 cport=0x538 port=0x530 sb_port=0x220
fm_port=0x388 irq=5 dma1=1 dma2=0
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

options snd cards_limit=1

NOTE: When copying and pasting the above, make sure that the line starting
with 'options...' is *one* line ending with '...dma2=0'.

3. Add the line

snd-cs4236

to the file /etc/modules

Reboot.

Also important: During power up, if you press F2 (I think), you get into
change the config. In this you need to make sure that the Fastboot option is
*disabled*.

If you are still having no success: try adding 'acpi=off pnpbois=off' at the
end of the kernel boot parameters. Press 'esc' during Grub countdown and select
'e' to edit the boot command and add these to the end.

The default starting volume is very low, so make sure that you set the volume to high using the keyboard Fn+PgUp key combination.

Hope it helps

Bhavani Shankar.

scouse (dbvoss) said : #2

Thank you Bhavani,
                             I did what you said and it worked ! Thank you very much.

    scouse.

scouse (dbvoss) said : #3

Thanks Bhavani Shankar, that solved my question.