6.10: unmounting usb discs with "Safely Remove" (kde desktop icon) doesn't work for devices mounted via udev

Asked by Cictani


I created this udev rule for mounting my usb disc:

BUS=="usb", KERNEL=="sd?1", SYSFS{idProduct}=="82b7", SYMLINK+="organix", RUN+="
/bin/mount /media/organix"

It works really fine and after plugging in the desktop icon also appears in KDE. The problem is that I can not unmount the device via the desktop Icon.

Manually with umount it works fine but not with "Safely Remove". I click on that menu point but nothing happens.

I hope someone can help me.

Best Regards


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Frode M. Døving
Last query:
Last reply:
Revision history for this message
Best Frode M. Døving (frode) said :

Hi Andy.

First out of curiosity;
Why don't you do this the pmount-way ?

I figure since you run /bin/mount /media/organix, that you have a /etc/fstab entry for this device. If you want to be able to umount it properly, you must have the 'users' option in there somewhere.

Something like this:
/dev/sda1 /media/usbdisk ext3 noauto,defaults,users 0 0

The important part is that 'users' is in the options (comma separated) list.

Then try to Safely Remove the disk.
(Note: you have to remount it first, for the new mount options to be activated).

Hope this helps.

- Frode

Revision history for this message
Cictani (bla-bla-deactivatedaccount) said :

User confirmed that the request is solved.

Revision history for this message
Cictani (bla-bla-deactivatedaccount) said :


the users solved my problem I just forget to add it. Maybe some more User Feedback like "Permission Denied" would make error finding easier but Safly remove just did nothing.

I don't know what pmount does. But I just wanted that the device is automounted and always at the same mount point. It was also very annoying that the device only got mounted if I clicked on "Open in Konqueror" otherwise it wasn't mounted.