Can't change screen resolution

Asked by Dan Surmiak on 2008-04-15

Binary package hint: gnome-terminal

Flailing around, I enabled assistive technology, and now I'm stuck in 640x480 without a clue how to get out of this. I just wanted 1040x768 instead of the higher resolution that appeared when I first installed. I'm using Ubuntu 7.10.

ProblemType: Bug
Architecture: i386
Date: Tue Apr 15 07:11:00 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gnome-terminal
NonfreeKernelModules: nvidia
Package: gnome-terminal 2.18.2-0ubuntu1
PackageArchitecture: i386
ProcCmdline: gnome-terminal -x /usr/bin/orca
ProcCwd: /home/dan
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/ccs/bin:/usr/bin:/usr/sbin:/bin:/usr/sfw/bin:/usr/openwin/bin:/usr/X11R6/bin
 LANG=en_US.UTF-8
SourcePackage: gnome-terminal
Uname: Linux dan 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Dan Surmiak
Solved:
Last query:
Last reply:

This question was originally filed as bug #217680.

Dan Surmiak (dsurmiak) said : #1
Pedro Villavicencio (pedro) said : #2

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. https://answers.launchpad.net/ubuntu

I agree with Pedro. I dont think its a bug either.
It may be just a hardware problem nvidia graphic cards aren't that compatible with Ubuntu.
Did the resolution work before?
What version of Ubuntu are you using (eg gutsy 7.10 etc)

Bhavani Shankar (bhavi) said : #4

Which graphics card are you using?

Bhavani Shankar (bhavi) said : #5

Output of

lspci

please.....

Dan Surmiak (dsurmiak) said : #6

Thanks for the reply. I'm an absolute newbie & still learning my way around
even the most elementary aspects of Ubuntu, including the support structure.
Sorry if I queried the wrong people by posting "bug". You're probably right
that it's related to nvidia--I was having problems with Vista too in that
regard, strangely enough when I played Freecell. Still, I wish I didn't feel
so clueless--I was liking Ubuntu until this latest snafu. As for resolution
working before, yes, but I couldn't change it in any obvious way. Then,
after enabling Assistive Tech, the next boot was into 640x480, &
Preferences>Screen resolution now offers that option as the only one
available--not acceptable. I'll now try returning to Vista & googling for
some documentation & support elsewhere.

On Tue, Apr 15, 2008 at 8:49 AM, shane fagan <
<email address hidden>> wrote:

> Your question #29842 on gnome-terminal in ubuntu changed:
>
> https://answers.edge.launchpad.net/ubuntu/+source/gnome-terminal/+question/29842
>
> Status: Open => Needs information
>
> shane fagan requested for more information:
> I agree with Pedro. I dont think its a bug either.
> It may be just a hardware problem nvidia graphic cards aren't that
> compatible with Ubuntu.
> Did the resolution work before?
> What version of Ubuntu are you using (eg gutsy 7.10 etc)
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
>
> https://answers.edge.launchpad.net/ubuntu/+source/gnome-terminal/+question/29842
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Bhavani Shankar (bhavi) said : #7

Hello:

First please make sure that the nvdia drivers with the restricted drivers manager (System -> Administration -> Restricted Drivers Manager)

Then..

Please try to press CTRL+ALT+"+" and/or CTRL+ALT+"-" to dynamically change video frequency
or press CTRL+ALT+BKSPACE to restart graphics layer.

Reconfiguring your xserver-xorg may help you.

A) If you can view graphics Gnome desktop

Please open a Terminal from the menu Applications->Accessories->Terminal
and jump to step C

B) If you cannot view graphics Gnome desktop

Please press CTRL+ALT+F2 and make login with your user and password
and go on to step C

C)

To make a backup copy of your actual /etc/X11/xorg.conf type:

cd /etc/X11
sudo cp xorg.conf xorg.conf.bak

give your user password when requested, you don't see nothing when you type it, then press enter.

Then try to reconfigure your xserver-xorg

sudo dpkg-reconfigure xserver-xorg

answer to the simple questions, then restart the pc.

If something goes wrong you can restore the saved copy of your old configuration, open a terminal or login to a virtual terminal by pressing ctrl+alt+F2 and type:

cd /etc/X11
sudo cp xorg.conf.bak xorg.conf

and restart the pc, type:

sudo reboot

Hope it helps

Bhavani Shankar.

Dan Surmiak (dsurmiak) said : #8

Just disabling the nVidia driver let me successfully change the resolution
to 1040x768. Now I can read the screen. Thanks so much. I will try out the
additional info you sent just to familiarize myself with the backup
procedure.

On Tue, Apr 15, 2008 at 9:17 AM, Bhavani Shankar <
<email address hidden>> wrote:

> Your question #29842 on gnome-terminal in ubuntu changed:
>
> https://answers.edge.launchpad.net/ubuntu/+source/gnome-terminal/+question/29842
>
> Status: Open => Answered
>
> Bhavani Shankar proposed the following answer:
> Hello:
>
> First please make sure that the nvdia drivers with the restricted
> drivers manager (System -> Administration -> Restricted Drivers Manager)
>
> Then..
>
> Please try to press CTRL+ALT+"+" and/or CTRL+ALT+"-" to dynamically change
> video frequency
> or press CTRL+ALT+BKSPACE to restart graphics layer.
>
> Reconfiguring your xserver-xorg may help you.
>
> A) If you can view graphics Gnome desktop
>
> Please open a Terminal from the menu Applications->Accessories->Terminal
> and jump to step C
>
> B) If you cannot view graphics Gnome desktop
>
> Please press CTRL+ALT+F2 and make login with your user and password
> and go on to step C
>
> C)
>
> To make a backup copy of your actual /etc/X11/xorg.conf type:
>
> cd /etc/X11
> sudo cp xorg.conf xorg.conf.bak
>
> give your user password when requested, you don't see nothing when you
> type it, then press enter.
>
> Then try to reconfigure your xserver-xorg
>
> sudo dpkg-reconfigure xserver-xorg
>
> answer to the simple questions, then restart the pc.
>
> If something goes wrong you can restore the saved copy of your old
> configuration, open a terminal or login to a virtual terminal by
> pressing ctrl+alt+F2 and type:
>
> cd /etc/X11
> sudo cp xorg.conf.bak xorg.conf
>
> and restart the pc, type:
>
> sudo reboot
>
> Hope it helps
>
> Bhavani Shankar.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.edge.launchpad.net/ubuntu/+source/gnome-terminal/+question/29842/+confirm?answer_id=6
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
>
> https://answers.edge.launchpad.net/ubuntu/+source/gnome-terminal/+question/29842
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Bhavani Shankar (bhavi) said : #9

Hello again mate:

If any of the post here answers your question here please click " This solved my problem " Button on the RHS bottom of the answer post mate.. Or if you are using an email interface please click the link below ' If this anwers your question " or something similar in the post of the answer which solved your problem

Regards

Bhavani Shankar.

Dan Surmiak (dsurmiak) said : #10

Hey,
   Just to fill you in, I thought the problem was solved--I got the resolution to where I wanted it, but then I tried to change from "no effects" to "normal", & immediately got a display I couldn't read. I couldn't even find Shutdown, & didn't know how to get to the CLI. I decided to reinstall Ubuntu, so I freed up the partition in Vista--bad move. GRUB was still in control, but no longer offered any options, just "Error 22". I'd lost Vista too. Luckily, when I reinstalled Ubuntu from the CD GRUB worked. Now I have the restricted drivers enabled, effects "normal", and changing the resolution works. BTW, I have nVidia GeForce 6150SE nForce 430 on a Dell 531s. I intend to be more careful in the future & know better what I'm doing. Thanks again. You guys are gentlemen and scholars.