Cannot install kde in ubuntu(error)

Asked by MCBTunes on 2006-12-30

I recently wiped windows off my computer and installed Ubuntu, I lived it I added KDE with

sudo apt-get install kde

it was great. But I decided I wanted window's back.. so I wiped my computer again and installed(XP Pro) then I let Ubuntu make its own partitions. Now it wont allow me to install KDE.

Here is a little sample from my terminal:

michael@Michael-Linux:~$ sudo apt-get install kde
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package kde is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package kde has no installation candidate
michael@Michael-Linux:~$

I'm not sure what the deal is, my Ubuntu is up to great and as far as I know everything is the same as the way I had it before with the exception of dual booting windows. Anyway, any input will be appreciated :).

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
MCBTunes
Solved:
2007-01-01
Last query:
2007-01-01
Last reply:
2007-01-01

This question was reopened

MCBTunes (liquidchill) said : #1

Sorry I noticed a few spelling errors. lived = loved and instead of 'wanting windows back' I just need it to run a few specific things... But KDE is more important.

I'd also like to say I havnt tried installing the kubuntu-desktop or kde-core, because I liked how kde worked before. So I would like to use it again.

The "right" way to install KDE on an Ubuntu install is as you know to install kubuntu-desktop. That way you will get all the necessary dependancies. You could alternatively just install kdebase instead of kde. This should install just the necessary bits to run KDE.

MCBTunes (liquidchill) said : #3

I got much further trying to install kubuntu-desktop. Yet it still failed... I downloaded the entire ~450MB and I got to a blue window that said they were both installed but I'd need to choose a desktop... however on startup in sessions KDE isnt an option, nor is Kubuntu an option when choosing an OS.

I'm getting really frustrated with this and perhaps it is because ubuntu is installed on my E drive... I really have no idea wither way... but I bet it is fair to blame windows.

The blue screen you saw was probably asking you which default desktop manager you wanted, gdm or kdm as both were installed, gdm gets installed with ubuntu, kdm installed with kde/kubuntu-desktop.

The display manager is the screen you see when you boot up that asks for your user id and password.

You can choose either but then when you have finished installing kubuntu-desktop / kde you can choose which window manager (gnome / kde) using the session option in the display manager.

There is no concept of "e drive" in ubuntu, and I don't see that this is an issue for ubuntu. I don't think windows is to blame for what you have described so far.

MCBTunes (liquidchill) said : #5

yep, that is exactly what the blue screen was. Although, it never gave me any options to make a choice, it just said I could. I've already installed the kubuntu-desktop I ran it like:

sudo apt-get install kubuntu-desktop

It ran and everything seemed dandy. However. In the display manager when I go to clikc the session type KDE or Kubuntu isnt an option like it was last time I installed it. There is just the default, Gnome, last session.

Also, last time I did the KDE installations it immidiatly placed many of the KDE applications inside GNOME so I had a lot to choose from, inside that session.

What should I be doing here? I know for sure it ran when I tried to install it.

Could this link help?
http://jucato.org/kde/kde-core.html
Jucato has a very useful guide, I believe this is what you want to do.

I apoligize, I marked this as answered when it should not have been marked as such.

MCBTunes (liquidchill) said : #8

Thanks for the link Mr. Martinez I gave it a read and thought it was worth trying out. Eventhough I think I would rather have more app's than less. But what happened was similar to when I tried to install kde alone.

michael@Michael-Linux:~$ sudo apt-get install x-window-system-core kde-core kdm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package x-window-system-core is a virtual package provided by:
  xorg 1:7.1.1ubuntu6.2
You should explicitly select one to install.
E: Package x-window-system-core has no installation candidate
michael@Michael-Linux:~$

And this is after following his steps of update etc.

MCBTunes (liquidchill) said : #9

Seeing as kubuntu-desktop did run properly. It has to be located in my computer somewhere. Where would I find an application that never finished the install and what would I type in the terminal to get it to finish? There is only ~2GB of disk usage on linux right now so I'm not sure if it is there or not... but I know I waited 4 hours (high speed light) for it to finish until I hit the dead end of the blue screen.

Juan Carlos Torres (jucato) said : #10

I'm not really sure what's wrong here, but let me try some suggestions.

1. Not being able to install the "kde" metapackage - I can only think of 2 possible causes of this: (a) you don't have the universe repository enabled (which should be enabled by default in Edgy), or (b) there might be something wrong with the Ubuntu repository servers that you are using. This usually happens (or happened) to the us.archive.ubuntu.com servers. Try to check if either reasons apply to you.

2. No KDE session available - that "blue screen" would have given you a choice. Do you remember what you did to make that screen go away? The only reason I could think of is that the installation didn't finish correctly. Most probably the packages that were downloaded are still in your hard drive, so you won't have to download them again. Try running "sudo apt-get install kubuntu-desktop" again. It might continue where it left off.

Other than that, I'm pretty clueless. Hope things work this time. Good luck!

MCBTunes (liquidchill) said : #11

Hi Juan, thanks for your input. Happy new year to you guys first of all.

1) I just completely reformatted and reinstalled my linux partition. All of the same problems are there. kubuntu-desktop offers to install, but kde and kde-core do not. I 'think' I would like the kde metapackage the most I really liked it when I installed it before.

As far as the universe repositories I'm not really sure what those are, I did a quick google and I got a lot of "use this at your own risk" stuff so I think I should read up on it or something a bit tomorrow morning before I mess around with anything. Last time I added the updates that come prepared when linux is installed(from the little orange icon by the clock) and this time i just did the sudo apt-get install update then tried to run kde I got this again

michael@michael-linux:~$ sudo apt-get install kde
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package kde is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package kde has no installation candidate
michael@michael-linux:~$

So all the default settings should be current.

2) I believe the blue screen said "you can choose between..." blah blah blah and then it said <ok> it left no options to do anything, I would have just closed it manually.

I would like to note that the only thing I've done differently from when everything worked to now when it doesnt work is install windows.. I am dual booting now. When everything worked linux was my only install.

When you say it used to work, that may well have been under another release you probably had the universe repository enabled. The "kde" package exists in all releases in the universe repository:-

http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=kde&searchon=names&version=all&release=all

You should enable the universe repo first, then install the kde package if that's what you want.

https://help.ubuntu.com/community/Repositories

Best MCBTunes (liquidchill) said : #13

You guys were spot on! I did something similar to what the help page said and it updated all my repositories... then I tried installing both the kde and the kubuntu-desktop package. And both would allow me to at least download them. Now I just want to figure out why kubuntu-desktop is the recommended package... better for updates etc.

Cheers!
Mike.

It's simply because kubuntu-desktop has all the necessary dependancies set so that when you install it you get the whole of kubuntu. If you install the kde package you get only the minimum bits necessary to run kde, not all the extra stuff.

Here's the proof :)

alan@wopr:~$ apt-cache show kde | grep Depends
Depends: kde-core (>= 5:47), kde-amusements (>= 5:47), kdeaccessibility (>= 4:3.4.3), kdeaddons (>= 4:3.4.3), kdeadmin (>= 4:3.4.3), kdeartwork (>= 4:3.4.3), kdegraphics (>= 4:3.4.3), kdemultimedia (>= 4:3.4.3), kdenetwork (>= 4:3.4.3), kdepim (>= 4:3.4.3), kdeutils (>= 4:3.4.3), kdewebdev (>= 4:3.4.3)

alan@wopr:~$ apt-cache show kubuntu-desktop | grep Depends
Depends: acpi, acpi-support, acpid, adept, akregator, amarok, anacron, apmd, ark, arts, avahi-daemon, bc, bogofilter, cdparanoia, cdrdao, cdrecord, cupsys, cupsys-bsd, cupsys-client, cupsys-driver-gutenprint, dbus, dc, digikam, diveintopython, doc-base, dvd+rw-tools, foo2zjs, foomatic-db, foomatic-db-engine, foomatic-db-hpijs, foomatic-filters, fortune-mod, gdb, gs-esp, gtk2-engines-gtk-qt, gwenview, hal, hotkey-setup, hwdb-client-kde, k3b, kaddressbook, kaffeine-xine, kamera, karm, katapult, kate, kcontrol, kcron, kde-guidance, kde-systemsettings, kdeadmin-kfile-plugins, kdebase-kio-plugins, kdegraphics-kfile-plugins, kdemultimedia-kfile-plugins, kdemultimedia-kio-plugins, kdenetwork-filesharing, kdenetwork-kfile-plugins, kdepasswd, kdepim-kio-plugins, kdepim-wizards, kdeprint, kdesktop, kdm, kdnssd, keep, kexi, kfind, kghostview, khelpcenter, kicker, kio-apt, kio-locate, kipi-plugins, klipper, kmail, kmailcvt, kmenuedit, kmilo, kmix, kmplayer-konq-plugins, knetworkconf, knetworkmanager, knotes, konq-plugins, konqueror, konqueror-nsplugins, konsole, kontact, konversation, kooka, kopete, korganizer, kpdf, kpf, kppp, krdc, krfb, krita, ksmserver, ksnapshot, ksplash, ksplash-engine-moodin, ksvg, ksysguard, ksystemlog, ktorrent, kubuntu-artwork-usplash, kubuntu-default-settings, kubuntu-docs, kubuntu-konqueror-shortcuts, kwalletmanager, kwin, landscape-client, language-selector-qt, lftp, libarts1-akode, libgl1-mesa-glx, libglut3, libnss-mdns, libpam-foreground, libsasl2-modules, libstdc++5, libxp6, linuxprinting.org-ppds, min12xxw, mkisofs, pmount, pnm2ppa, powermanagement-interface, qca-tls, readahead, screen, slocate, smbclient, speedcrunch, ttf-bitstream-vera, ttf-dejavu, ttf-freefont, unzip, usplash, vorbis-tools, wvdial, x-ttcidfont-conf, xkeyboard-config, xorg, xterm, zip

MCBTunes (liquidchill) said : #15

proof enough for me. I'll start installing asap... then I can get all those updates done... if i remember there is like 82 of them!