Strange bash output error when trying to run app's as root

Asked by Michal Dziczkowski on 2016-06-06

hey, I (still) use Ubuntu 14.04 and when attempted to run app's from the bash console as root, I had recieved a strange error output:

No protocol specified

** ([app info trunchated for privacy concerns]): WARNING **: Could not open X display
No protocol specified
No protocol specified
WARNING : Shell not installed or running
No protocol specified

([app info trunchated for privacy concerns]): Gtk-WARNING **: cannot open display: :0

Any idea how to solve it?

NOTE: similiar error show up by many other apps as well

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2016-06-27
Last reply:
2016-06-28

Are you connected to the server via SSH over a network or are you sat at the system creating the errors?

What is the output of:

lsb_release -a; uname -a

Thanks

Bellow is the output for requested commands. Note: This is a temporary configuration before system re-install

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty
Linux ubuntu 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014 i686 athlon i686 GNU/Linux

Are you sat at the system and running commands, or are you connected via SSH?

the commands are run on the system and not thru SSH

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

hello? any more question or suggestion about resolving the strange behavior?

Manfred Hampl (m-hampl) said : #7

What kind of help do you expect if you do not tell us the name of the app that failed?

similiar error appears on many apps with I try to run from bash, with includes even nautilus and gnome-system-monitor

Manfred Hampl (m-hampl) said : #9

Ok, this can serve as a starting point.

Please provide the full output of the commands

sudo lshw -C display
sudo nautilus
xhost

output of commands (runned as root):

lshw: http://pastebin.com/h89p46X2
xhost: http://pastebin.com/47EkdTf0

for now this. Whenever I get again the error from nautilus then I will include it here

Manfred Hampl (m-hampl) said : #11

I assume that nautilus was working this time without giving the "No protocol specified etc." error messages, is that correct?

ad #11:

yes, but only because I had runned it after starting from a "fresh" live CD. Else it's showing up the error similiar like in the topic start

Manfred Hampl (m-hampl) said : #13

Did you provide the output of the two other commands also from a live system booted from a CD, or was that from the hard disk installation?

both were from liveCD because I'm doing a backup before system re-install (I plan to install a newer version of the system in 64-bit instead of currently used 32-bit from liveCD)

Manfred Hampl (m-hampl) said : #15

How do you think that we can diagnose the root cause of your problem, if you provide information about from a live system and not from the system that you have installed on your hard disk?

If you plan to do a new installation anyhow, I do not see any benefit in trying to get the problem solved, because the system will be replaced soon.

The problem is that this error apears itself in any version of Ubuntu since 12.04 and probably will apear in thr 16.04 too. That why I think it would be a good idea to look closer what could cause it

Manfred Hampl (m-hampl) said : #17

If you want us to have a look at the problem, you have to provide the information that we request - from your real system and not another one.

Was it one and the same system with the error message since 12.04 (upgraded version to version), or did you see the same error message on different installations?

I'll try in near time (not exactly sure yet when) to install the new system and see if the mentioned above error will apear

Can you help with this problem?

Provide an answer of your own, or ask Michal Dziczkowski for more information if necessary.

To post a message you must log in.