/sbin/bootlogd

Asked by Wolf Canis on 2006-12-26

Hello,
I have, in /etc/default/bootlogd, bootlogd enabled, but the boot messages before start of syslogd don't saved in any log file.
I have examined the script /etc/init.d/bootlogd and I found that this script need /sbin/bootlogd. But it doesn't exist.
I tried to install it, but it was in no repository (synaptic package manager).
Where can I find this daemon.

Background:
I have problems at boot (see request 2690). And to figure out what's the problem I need the boot messages before syslogd.

Any help or comments are welcome.

Thanks in advance,
                                  Mr Canis

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Wolf Canis
Solved:
2007-11-22
Last query:
2007-11-22
Last reply:
2007-11-09
Wolf Canis (wolf-canis) said : #1

Hello,
isn't there nobody, whom can help?
How could it disappear or another possibility during the installation process were a error.
I don't know, but one is clear the /etc/init.d/bootlogd is still there but /sbin/bootlogd isn't.

Is there under Ubuntu another way to save the earlier boot messages, the boot
parameter earlyprintk=vga,keep doesn't work. The kernel crashed.

Please have a look to my request #2690. I figured out some details and wrote them there.

Thanks in advance,
                                  Mr Canis

Wolf Canis (wolf-canis) said : #2

Hello,
the link to the request mentioned above:

https://launchpad.net/ubuntu/+ticket/2690

Thanks in advance,
                                  Mr Canis

Antoine Delvaux (tonin) said : #3

/etc/init.d/bootlogd is part of the 'initscripts' package and /sbin/bootlogd is in 'sysvinit'. However, quite happily, there's a dependence between both packages, so you should'nt have one without the other.

Can you check if you have both installed? Which version of Ubuntu are you using?

Wolf Canis (wolf-canis) said : #4

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello Antoine Delvaux,
thanks for your answer.
I'm using Ubuntu 6.10 edgy with all upgrades and the package
'initscripts' are installed but 'sysvinit' are not. In the
dependencies of 'initscripts' is written that it conflicts with
'sysvinit'.
The programm /sbin/bootlogd doesn't exist on my system.

Thanks in advance.
Mr Canis
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFF+Y4VxRIbpRJ0HZARAjRTAJ946kthLi6GPCK8ArJSan/u5lMvRQCdFF2w
OIjgcBcNzNN7D1zLAYIVm9w=
=ZATJ
-----END PGP SIGNATURE-----

___________________________________________________________
Try the all-new Yahoo! Mail. "The New Version is radically easier to use" � The Wall Street Journal
http://uk.docs.yahoo.com/nowyoucan.html

Antoine Delvaux (tonin) said : #5

Well, my observations was based on 6.06 Dapper but should still be true on Edgy. It's the sysvinit source package which creates the two binary packages. I guess both should be installed.

For Edgy: https://launchpad.net/ubuntu/+source/sysvinit/2.86.ds1-14.1ubuntu16

For Dapper: https://launchpad.net/ubuntu/+source/sysvinit/2.86.ds1-6ubuntu32

Not sure why they're not. If you try to install the package named 'sysvinit', what happens?

Wolf Canis (wolf-canis) said : #6

Hello Antoine Delvaux,
that's the answer from synaptic:

To be removed
   startup-tasks
   system-services
   ubuntu-minimal
   upstart
   upstart-compat-sysv
   upstart-logd

I think to install 'sysvinit' isn't a good idea. There must be another
reason why bootlogd isn't installed in edgy.
I have an other laptop (Toshiba Tecra 8100) with edgy. On this
installation bootlogd isn't installed too, but all boot messages appear
in dmesg.
It's a little bit strange.

Mr Canis

___________________________________________________________
Like being first? Check out the all-new Yahoo! Mail today.
http://uk.docs.yahoo.com/nowyoucan.html

Antoine Delvaux (tonin) said : #7

Mr Canis,

Indeed, having those packages being removed is not a good thing. However I still don't understand how you have initscripts installed without sysvinit.

Which package version of initscripts is installed? (run 'apt-cache showpkg initscripts') And which version of sysvinit are you trying to install? An output of 'apt-get -s install sysvinit' (which simulates the installation of sysvinit) could help.

Thanks.

Antoine Delvaux (tonin) said : #8

BTW, bootlogd purposes isn't to make boot messages available under the 'dmesg' command or /var/log/dmesg file but to save console boot messages (what is normaly printed on the console screen) in /var/log/boot.

It's the duty of /etc/init.d/bootmisc.sh (part of initscripts package) to store the 'dmesg' boot time output into /var/log/dmesg. The dmesg command returns what is currently stored in the kernel ring buffer. This buffer is of fixed size and so is regularily overwritten (it is not only used at boot time). That's why bootmisc.sh is run during boot, to save those messages in a file before they get overwritten.

Thus, even if both are created at boot time, output of /var/log/boot and /var/log/dmesg should be quite different.

Wolf Canis (wolf-canis) said : #9

Hello Antoine Delvaux,
thanks for the brief description, but exactly the earliest boot messages are missing. The dmesg output begins with the message from hda_intel driver and in /var/log/boot the first entry is " Mar 20 05:44:23 rcS: * Files under mount point '/var/run' will be hidden. "

below the output from apt-cache and apt-get.

$ apt-cache showpkg initscripts
Package: initscripts
Versions:
2.86.ds1-14.1ubuntu16 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_edgy_main_binary-i386_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_edgy_main_binary-i386_Packages
                  MD5: ec7950bbf347ec12ad53e2cee302ade8

Reverse Depends:
  upstart-compat-sysv,initscripts
  sysvinit,initscripts
  multipath-tools,initscripts 2.85-16
  e2fsprogs,initscripts 2.85-4
  bootchart,initscripts
Dependencies:
2.86.ds1-14.1ubuntu16 - libc6 (2 2.4-1) mount (2 2.11x-1) e2fsprogs (2 1.32+1.33-WIP-2003.04.14-1) debianutils (2 2.13.1) lsb-base (2 3.0-6) sysvutils (0 (null)) mdutils (0 (null)) sysv-rc (3 2.86.ds1-1.2) sysvinit (3 2.86.ds1-12) mdutils (0 (null)) sysvinit (3 2.85-12) libc6 (0 (null)) libc6.1 (0 (null)) libc0.1 (0 (null)) libc0.3 (0 (null))
Provides:
2.86.ds1-14.1ubuntu16 -
Reverse Provides:

-------------------------------------------

$ sudo apt-get -s install sysvinit
Password:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libpcap0.7 upstart-compat-sysv procmail startup-tasks ubuntu-minimal
  system-services upstart-logd libdb4.2 resolvconf upstart liblockfile1
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  startup-tasks system-services ubuntu-minimal upstart upstart-compat-sysv
  upstart-logd
The following NEW packages will be installed:
  sysvinit
0 upgraded, 1 newly installed, 6 to remove and 0 not upgraded.
Remv ubuntu-minimal [1.30]
Remv startup-tasks [0.2.7-7]
Remv system-services [0.2.7-7]
Remv upstart-logd [0.2.7-7]
Remv upstart-compat-sysv [0.2.7-7]
Remv upstart [0.2.7-7]
Inst sysvinit (2.86.ds1-14.1ubuntu16 Ubuntu:6.10/edgy)
Conf sysvinit (2.86.ds1-14.1ubuntu16 Ubuntu:6.10/edgy)

------------------------------------------------

Thanks in advance,
                             Mr Canis

Antoine Delvaux (tonin) said : #10

Ok, I now understand the conflict, it's because of the new 'upstart' package which is replacing the sysvinit, see https://wiki.ubuntu.com/ReplacementInit

As it is work in progress (full replacement is to be due for Festy), a replacement for sysvinit is included in upstart, but not yet a replacement for initscripts. This does explain why you don't have the /sbin/bootlogd (as it is part of sysvinit) and why you still have /etc/default/bootlogd and it's starting script (as those are part of initscripts).

I guess either bootlogd is to be included in upstart or the configuration files needs to be suppressed. I'll fill a small bug report with that.

However, as you can see from your /var/log/boot message file, another logging daemon is now in use, it's called 'logd' and is part of 'upstart'. This is really the bootlogd replacement. As this one, it's only capturing start jobs output directed to the console and so doesn't print kernel boot messages.

The kernel boot messages should be saved in your /var/log/dmesg, but if you cannot see all of them in there, that's another story.

qiuye (qiuyew) said : #11

Hello Antonie Delvaux,

does it mean, that the package "sysvinit" can do all the thing what the new package "upstart" does?
i have this question because there is still no /sbin/bootlogd by feisty, i'd like to log the boot, but without the /sbin/bootlogd, i can do nothing...

Thanks

qiuye

Antoine Delvaux (tonin) said : #12

The aim is indeed to replace sysvinit completely, but the transition is not complete now I think.

Pär Lidén (par-liden) said : #13

Hello, I'm having the same problem too, I would very much want to get this bootlogd output, but it's not working. Is there any possibility to do some kind of workaround, like compiling and installing bootlogd manually or something? Does anyone know how to do that? I would be very happy if someone could help med with this, because I'm trying to debug a problem where the system sometimes hangs at boot.

Pär Lidén

Pär Lidén (par-liden) said : #14

Oh, I forgot to mention, I am using Ubuntu 7.10.

Wolf Canis (wolf-canis) said : #15

Hello,
I use following kernel parameter:

ignore_loglevel log_buf_len=16M

And of course without quiet splash!

More about kernel parameter are in

a) /usr/share/doc/linux-doc-2.6.22/Documentation/kernel-parameters.txt.gz
b) /usr/src/linux/Documentation/kernel-parameter.txt

Hope it helps.

Mr Canis

Pär Lidén (par-liden) said : #16

Thanks for the suggestion, I'll try it out.

Wolf Canis (wolf-canis) said : #17

Hello,
good luck ;-)

Mr Canis

Wolf Canis (wolf-canis) said : #18

Hello,
I close this support ticket because the problem isn't bootlogd but logd and the new upstart concept.
https://wiki.ubuntu.com/ReplacementInit?highlight=%28Init%29
https://wiki.ubuntu.com/ReplacementInitDiscussion?highlight=%28Init%29
https://wiki.ubuntu.com/ReplacementInitscripts?highlight=%28Init%29

Older documents concerning bootlogd that could be a solution in my opinion:
https://wiki.ubuntu.com/UbuntuDownUnder/BOFs/BootLogd?highlight=%28bootlogd%29