is there a fix for the slow boot in hardy?

Asked by Shane Fagan on 2008-04-09

i noticed that hardy is a lot slower than gutsy for boot time i was just wondering is that for a reason or is it a glitch and is there a fix available?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Bhavani Shankar
Solved:
Last query:
Last reply:
Best Bhavani Shankar (bhavi) said : #1

Hello again Shane...

Its a well known bug in ubuntu please refer:

https://bugs.edge.launchpad.net/ubuntu/+source/usplash/+bug/197228

and as discussed in one of the comments there:

To avoid that very long boot time, add "clocksource=hpet" (without the quotes) to your ubuntu kernel boot line. If it works, you can apply it permanently by editing your /boot/grub/menu.list file.

A bit more info on the above: Give the following command in a terminal (applications -> accessories -> terminal)

 gksudo gedit /boot/grub/menu.lst

Then add "clocksource=hpet" to the end of the # defoptions line:

    # defoptions=ro quiet splash clocksource=hpet

Your defoptions line may differ a little, just add the recommended text to the end of the line, save the file, then close the editor.

Afterwards, in a terminal, run:

    $ sudo update-grub

This will update grub to use the new option. Afterwards, reboot, and then run the system again and review for speed..

Hope it helps

Bhavani Shankar.

Thanks Bhavani Shankar, that solved my question.

yep shaved off about 30-40 seconds thanks for your help

Bhavani Shankar (bhavi) said : #4

No mention.. Glad that I could help you out.... :)