Fatal Resolution Problem With All Ubuntu 16.04 Distros

Asked by supusr on 2016-04-26

I have been using Debian and Ubuntu distros for 3 years, and have had the same computer for all that time. It is a 2011 Asus CM6850-5 with an ¡5 chip, integrated Intel graphics, and 12 G of RAM. I never had any problem burning iso disks and installing from them until this 16.04 release. I especially like Xubuntu and Ubuntu MATE and was really looking forward to testing both before installing the LTS version of one of them to be my permanent OS for the next couple of years. However, on both (and all other flavors and the main Ubuntu, too) the display is so blurry and distorted that installing is almost impossible, though I am familiar enough with the prompts to get through it. Upon booting into the new system the problem persists, although I am able in Xubuntu to get a (barely) readable display. My native display is 1920x1080 at 60 Hz, but I can't achieve that. cIt makes no sense to keep using the 15.10 versions because they will not be supported much longer, so I'm temporarily using Linux Mint 17.3 XFCE, though I don't care for Linux Mint. In Mint, the following terminal output is generated with specific relevant information:

supusr@cm6850-5 ~ $ lspci -nnk | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09)
Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
Kernel driver in use: i915
00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
Subsystem: ASUSTeK Computer Inc. P8 series motherboard [1043:844d]
Kernel driver in use: mei_me
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 05)
Subsystem: ASUSTeK Computer Inc. P8 series motherboard [1043:844d]
Kernel driver in use: ehci-pci
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 05)
Subsystem: ASUSTeK Computer Inc. P8H67 Series Motherboard [1043:841b]
Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 [8086:1c10] (rev b5)
supusr@cm6850-5 ~ $ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)

I believe this is a Ubuntu or maybe a kernel driver issue, but would very much appreciate any help that may be available. I miss Ubuntu, because it always has just worked until now.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2016-05-11
Last reply:
2016-05-27

What is the output of:

sudo lshw -C display

Thanks

supusr (richolad-1) said : #2

supusr@cm6850-5 ~ $ sudo lshw -C display
  *-display
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:35 memory:fe000000-fe3fffff memory:c0000000-cfffffff ioport:f000(size=64)

B. C. Schmerker (bcschmerker) said : #3

After scanning recent Bugs for the i915 driver, it appears that we have cause for a new Bug due to a suspected regression in Kernel(s) 4.n.m-x-generic and perhaps others involving the Intel® i9xx Express Sets™, but as of 27 April 2016 the necessary information for such a bug is incomplete, as I observed in:
http://ubuntuforums.org/showthread.php?t=2321772

supusr (richolad-1) said : #4

OK. Good to know, because I now know to use another distro that uses a different kernel for now. Is there a way I could find out if and when a fix or update is available so I could use the newest Ubuntu?

supusr (richolad-1) said : #5

OK. There is an issue with this driver in this kernel. Question: Could I install an earlier kernel in the terminal (sudo apt-get install linux-image-4.1.23-lts linux-headers-4.1.23-lts) and then reboot? Would Ubuntu 16.04 still work? Would the fix be permanent?

supusr (richolad-1) said : #6

I was asked to send this info for those who were helping me earlier: For those using the Intel ¡915 integrated graphics driver not supported by the newer linux kernels in 16.14, this is the fix: install the older kernel that works (linux-image-4.2.0-040200-generic_4.2.0-040200.201510260713_amd64.deb) (and headers), then mark it as locked in synaptic, then reboot, and it works. One can now get native resolution 1920x1080 working and thereby use 16.04.

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

ricardisimo (ricardisimo) said : #8

Just adding my name to the list... Same situation

ricardisimo (ricardisimo) said : #9

By the way, downgrading to image 4.2.0 did not help. I locked it in synaptic, but are there other steps involved? Do I need to uninstall the newer versions as well?

supusr (richolad-1) said : #10

I am now using MX-15 Fusion temporarily because I ultimately could not resolve the resolution issue, but I think you need to reboot. I cannot remember exactly, but clearly I could not figure it out, either, or I would be using Ubuntu or one of its flavors.

Hello, I have the exact same problem as the one detailed here with Lubuntu 16.04 LTS except OS works fine with external VGA monitor connected up until I log in and then exactly 37 seconds later, it absolutely freezes. No way to access unless I hard reboot every.single.time.

This problem occurred today, 20180529 as a direct result of an update to Google Chrome and another to ubuntu.

The only way the ext monitor works is if I wait for entire system to completely boot up and then plug in ext monitor. The resolution is completely borked and there is no way to set a wallpaper over there separate from what is on the laptop monitor.

I have tried messing with LXrandr as well as installing nitrogen. Absolutely futile. Nitrogen works up until I change a desktop and then it slaps the ext monitor wallpaper back to what is on whichever desktop I'm on.

Outputs of above referenced screens found at following links:

output of lspci

https://drive.google.com/file/d/1DaWn1lRiDi9ZQbEWpihodmr8_PxPex3J/view?usp=sharing

output of lshw
https://drive.google.com/open?id=1fd8ix5PAZmA6hPf8v2ZMYqPBhqU6j_9X

supusr (richolad-1) said : #12

I finally resolved this problem around June of 2016 by installing a dedicated (nvidia) graphics card to overide and assist the integrated one. No problems with any Ubuntu, Debian, or other distro since.