libdb3 not present but need to compile

Asked by Mante on 2008-04-07

Need libdb3 (has been removed from hardy) to compile the following package
http://www.da-cha.jp/files/hotkeys-0.6.1.tar.gz
I've tried other libraries but without success. Is there any substituted package?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-04-07
Last reply:
2008-04-08

This question was originally filed as bug #213641.

James Westby (james-w) said : #1

Hi,

Your problem isn't really a bug report, so I converted
it to a question.

The package libdb3 is an old version of libdb, and it
has been replaced by newer versions. The most
recent version is in libdb4.6.

However, the difficulty is that there may be changes
required for the package that you want to compile for
it to work with the newer versions. It's impossible
to know without trying it, so I suggest that you give
it a go.

Thanks,

James

Cesare Tirabassi (norsetto) said : #2

hotkeys 0.5.7.4-0.1 (which we have in our repo) builds with libdb4.5. I would be surprised that you need libdb3 for a more recent version, just go with libdb4.5

Can you help with this problem?

Provide an answer of your own, or ask Mante for more information if necessary.

To post a message you must log in.