Hardware (i386) not supported

Asked by Mathew on 2008-04-05

I just installed Xubuntu 7.1 as a fresh install on an old PC to play around with it. When I try to install any piece of software through Add/Remove programs I receive a message that the software can not be installed and it may not be supported on my hardware (i386).
I read the two other posts that I was able to find on this subject one did not address the issue at all and while the other one was solved the solution was specific to that person's problem not a general solution.
So I am writting to see if anyone has any hints for me to try, any commands to run and lines of code to look for and delete?
Someone mentioned looking at the contents of /etc/apt/source.list but for that solution it looked like their install was looking a CD from a previous install of a different version of Kubuntu.

I also tried selecting different servers from the preferences and I also made sure to check off the other two boxes in the source tab so that it was not only looking for the package on a CD.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Mathew
Solved:
2008-04-07
Last query:
2008-04-07
Last reply:
2008-04-06
Mathew (mathew-crist) said : #1

Additional info I installed the PC (Intel x86) desktop CD version of Xubuntu not the 64 bit.

I don't know why this sometimes happens in gutsy, but the solution is to open System > Administration > Software sources and check the repositories you want. That's at least main, but you'll probably want universe and multiverse too.

Mathew (mathew-crist) said : #3

Yeah I did have those checked but what appears to have solved the problem is on the Sources tab (I believe that was it) there were 3 check boxes, one for the CD and two for different URLs. I had all 3 checked and when I unchecked CD it worked. So my guess is that for whatever reason it was just checking for the CD and not the web. But then again that may not have been the exact solution either because even with the CD in the drive is gave that error. Who knows but at least now it works so when I go live with Xubuntu/Ubuntu I will know where to look if I run into this problem again.

Thanks!