Sound not working on Gateway 100 laptop

Asked by David Frossard on 2006-12-21

I've got a Gateway E100M superslim laptop (it's basically the same model as the NX100X and other current "100" models -- odd Gateway naming system) with no sound from the speakers. I'm running a fully updated Ubuntu 6.10.

The sound card info, from the Gateway site:

SigmaTel® 9200 Audio Chipset
SoundBlaster® Pro, MIDI and Windows® Sound System Compatible
3D Sound Support
AC’97 2.3 Compliant

The Sound Configuration app lists the default sound card as "HDA Intel" only.

Sound software is installed and enabled. Rhythmbox (etc.) seems to "play" supported sound files, but no sound comes out of the speakers or headphone jack. There are no startup sounds or beeps of any kind through the speakers, though they are enabled in software. The hardware button has sound turned on (I can toggle between on and mute, and change volume, with hardware buttons, but nothing helps.) I've gone through alsa configuration; the configurator seems to identify the sound card and write the appropriate configuration files, but sound ultimately does not work. The machine is totally silent when running Linux.

I've tried the newest Red Hat Fedora Core, Debian Etch, and Knoppix as well -- all with no luck -- so it would seem to be a systemic Linux thing. (Sound works fine in Windows XP.)

Any insights would be appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
David Frossard
Solved:
2008-04-30
Last query:
2008-04-30
Last reply:
2007-12-07
David Frossard (dfrossar) said : #1

Device Manager lists the audio controller as:

Intel 82801G (ICH7 Family) High Definition

ASHFAQ (eng-ashfaq83) said : #2

Address:- house #c-69,street#1
Ghazikot Township
Mansehra,nwfp
Pakistan

Hoodsy (jay-debuda) said : #3

Hi,

I have had a similar problem with a gateway desktop for a number of years and I came across the answer about 5 months back.

If your using Ubuntu 6.10: open the volume control and click on the tab called "Switches". There should be an option for SB Live! Analog/Digital Output jack - Click on this and you should be good to go.

Basically you have to switch from digital to analog to get the signal to work. I assume that the output quality isn't as great as digital but it works.

Hope this helps,
Hoodsy

David Frossard (dfrossar) said : #4

Hoodsy,

The only switch available for selection at Volume Control > Switches is "IEC958" -- which seems to have no effect on or off. There's no SB Live option, though the sound card is listed as Sound Blaster compatible.

Over time, I've also manually selected every option within the Sound Preferences applet (as well as letting the system autodetect the sound system) -- to no avail. I've never been able to get a peep out of the sound system while running Linux (though, as I said, Windows works fine, so the hardware is in fact functional).

Thanks for the advice, though. It was worth a try. Any further hints are welcome.

David

Mackenzie Morgan (maco.m) said : #5

Try adding
options snd-hda-intel model=m2-2

to your /etc/modules. My Intel sound on Gateway was malfunctioning til I added that. This should work on 82801G (ICH7) (rev 02)

David Frossard (dfrossar) said : #6

Maco,

Following your advice, my /etc/modules file now looks like this (the first three options were already there):

fuse
lp
sbp2
options snd-hda-intel model=m2-2

Unfortunately, I still don't have any sound, even after rebooting. Am I doing something wrong? Are there other modules that should be loading?

BTW, I've now upgraded to Feisty. When I click on a sound file, it very nicely installs the proper codex, but there is still no sound.

All my other issues running Ubunto on this machine have been resolved, but this one is persistent. Further advice appreciated.

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

David Frossard (dfrossar) said : #8

I've tried Feisty on this laptop now. Wireless networking was handled much better, but sound is still off. My desktop, also running FF, is fully functional. It's just this one laptop model that has this one glitch. Puzzling.

bqp1167 (fmaldonado) said : #9

I have the same problem same laptop. running kubuntu 7.04. Any help would be much appreciated

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

David Frossard (dfrossar) said : #11

Upgraded now to Gutsy (7.10) -- sound still does not work.

I believe this issue is now on the bug list, but I could be misinformed.

Launchpad Janitor (janitor) said : #12

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

David Frossard (dfrossar) said : #13

I upgraded to Hardy Heron (8.04), and still had no success getting sound to work on this laptop. But it also struck me that I hadn't upgraded the BIOS on this machine in a long time (mostly because I expected the BIOS upgrade to be a Windows-only thing and I didn't want to reinstall Windows just to do that). And in fact, the newest BIOS patch comes in the form of an .exe file only.

Fortunately, using Wine, one can unpack this file into its components. At that point, I burned the resulting ISO to a CD and then booted from that CD. The BIOS was successfully patched to v. 76.19, from v.76.10.

The result: Working sound.

So, apparently, it wasn't Ubuntu that was out of compliance, or not finding the proper hardware, but something in the Gateway BIOS that was incorrect.

Thanks to everyone who chipped in with good advice, however. Much appreciated. That's the ubuntu spirit.

David Frossard (dfrossar) said : #14

Problem solved.