Cant Enable Wifi At Asus Laptop Series X450JB

Asked by Pratomo Asta Nugraha on 2016-02-14

Hi Today I Was Installing Ubuntu And Make It Dual Boot With Windows At My Laptop ( ASUS X450JB )
And After Finished Installing Cant Even Enabled My Wifi , So I Got Trouble When I Want To Acces The Internet
Because Of That If I Want To Connect To Internet I Must Reboot And Switch To Windows Just To Do That .

Laptop Specs :
Taken From DX DIAG :
  Operating System: Windows 10 Pro 64-bit (10.0, Build 10586) (10586.th2_release.160104-1513)
                 Language: Indonesian (Regional Setting: Indonesian)
      System Manufacturer: ASUSTeK COMPUTER INC.
             System Model: X450JB
                     BIOS: BIOS Date: 12/14/15 10:01:11 Ver: 04.06.05
                Processor: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz (8 CPUs), ~2.6GHz
                   Memory: 6144MB RAM
      Available OS Memory: 6026MB RAM
                Page File: 3529MB used, 9151MB available

---------------
Display Devices
---------------
          Card name: Intel(R) HD Graphics 4600
       Manufacturer: Intel Corporation
          Chip type: Intel(R) HD Graphics Family
           DAC type: Internal
        Device Type: Full Device

          Card name: NVIDIA GeForce 940M
       Manufacturer: NVIDIA
          Chip type: GeForce 940M
           DAC type: Integrated RAMDAC
        Device Type: Render-Only Device
         Device Key: Enum\PCI\VEN_10DE&DEV_1347&SUBSYS_1B6D1043&REV_A2
     Display Memory: 5008 MB
   Dedicated Memory: 1995 MB
      Shared Memory: 3012 MB

=================
Wireless Device :
=================

Manufacturer: Qualcomm Atheros Communications Inc.
Description: Qualcomm Atheros AR956x Wireless Network Adapter
Driver version: 10.0.0.321
Physical address: ‎DC-85-DE-FC-67-99

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2016-02-15
Last query:
2016-02-15
Last reply:
2016-02-15

Connect to a wired connection and get fully updated. This will help a lot. Windows doesn't give nearly enough detail.

Jeremy (wa113y3s) said : #2

The wireless card should be supported, so I suspect it is hardblocked, check

rfkill list all

If it shows a hard block

echo "options asus_nb_wmi wapf=4" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf

Reboot and see if wireless works

Hmm Okay, I'll Report Back After I Try This .

Please also try the solution mentioned here:

https://askubuntu.com/questions/682420/wifi-fnf2-is-not-working-on-ubuntu-15-04-on-asus-laptop-x450jb

So blacklist the acer_wmi kernel module in the /etc/modprobe.d/blacklist.conf file and then reboot and retest wireless.

At rfkill list all
it shows :
acer_wireless .
soft block : yes
hard block : no .

already read the https://askubuntu.com/questions/682420/wifi-fnf2-is-not-working-on-ubuntu-15-04-on-asus-laptop-x450jb
but i dont know how to block it .

I got it working by blacklisting acer_wmi driver in /etc/modprob.d/blacklist.conf then reboot the machine. Thank you so much @Pilot6 – Andy Librian Oct 7 '15 at 10:02
 <<<<<<<<<<<<<<<<<<<<<< How To Do This ?

Run:

echo "blacklist acer_wmi" | sudo tee -a /etc/modprob.d/blacklists confirm > /dev/null

I think there is a typo in your command, Andrew.

@Pratomo: Google.com should be your best friend. Search for "blacklist acer_wmi blacklist.conf" and several websites give you the solution. Anyway, run this command:

sudo gedit /etc/modprobe.d/blacklist.conf

Using the gedit editor, scroll down and add the following configuration line at the end of the text file:

blacklist acer_wmi

Then save the change. Reboot and retest wireless.

Thanks it's worked .
I could enable wifi now but the fn + f2 key still not working , i also cannot disable the touchpad .

@Pratomo: could you please set the thread status to "solved", as the wireless issue is solved?

Please create a separate new thread for the touchpad issue.

Thanks Mark Rijckenberg, that solved my question.