I/O possible with Ubuntu 7.10

Asked by ThomasH on 2008-03-27

I have written a serialport program in c and it works fine with the previous version of Ubuntu linux (Version 6.06) . But when I upgraded to Ubuntu 7.10 I've got the message "I/O Possible" immidiately after receiving a character on the serialport. I've tried /dev/ttyS1, /dev/ttyUSB0, same message on both devices

Have anyone experienced the same problem? Any soloutions?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Jim Qode (jimqode) said : #1

Could you try and run your program as root (with sudo) and see if that fixes the problem? It might be a user rights problem.

ThomasH (thomas-haugen) said : #2

Tried it now, the program still reports "I/O Possible"

Jim Qode (jimqode) said : #3

This may be a bug. Could you try it with Hardy Beta live CD to see if the problem persists. I'll turn this into a bug report if the problem is still there in hardy.

ThomasH (thomas-haugen) said : #4

Do you mean the Ubuntu 8.04 Beta Release Live CD or the Ubuntu 7.10 Live CD? I will have to download Ubuntu 8.04 Beta Release in order to test my app with this.

Thank you for helping me!

Jim Qode (jimqode) said : #5

Ubuntu 8.04 Beta Live CD. Hardy Heron is the codename for 8.04

ThomasH (thomas-haugen) said : #6

"IO Possible" still in Ubuntu 8.04 Beta version!

It seems like the handling of this SIGIO event did fail somewhere between Ubuntu 6.06 and 7.10. This is a list of libc versions on my system with the different Ubuntu versions:

Ubuntu 6.06 -> /lib/libc-2.3.6.so
Ubuntu 7.10 -> /lib/libc-2.6.1.so
Ubuntu 8.04 Beta -> /lib/libc-2.7.so

Jim Qode (jimqode) said : #7

I can't seem to find a bug report for this. I think you should go and open one.

Can you help with this problem?

Provide an answer of your own, or ask ThomasH for more information if necessary.

To post a message you must log in.