avahi disabled my computer, how can I able it?

Asked by len

My PC is has been hi-jacked by Avahi network services. I was doing just fine up until 2 weeks ago suddenly after signing in a message appeared informing me that Avahi disabled my .local network because they do not 'Recommend it'. I tried umpteen times all that's been suggested by the Ubuntu community entered all possible instructions etc. but to no avail. As it is I can only have access to it as a 'Guest User' with no 'admin' rights. This is ridiculous--being hi-jacked like this. Nothing I've done seems to get rid of the blasted thing. Anyone can suggest what needs doing to correct this situation? ( my OS is Ubuntu 14.04 LTS) Thanking you in anticipation.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

What is the full Terminal output of this command?

cat /etc/default/avahi-daemon ; uname -a ; host -t SOA local; cat /etc/lsb-release ; dpkg -L avahi-daemon

The following bugreport might contain a valid workaround procedure for you:


Revision history for this message
Mark Rijckenberg (markrijckenberg) said :
Revision history for this message
len (leonardleigh15) said :

Hi Mark, thanks for the info. I do not know the full terminal output of this command because I cannot even get into the site as an administrator. I tried all these commands via the Guest user terminal the messages I get are: permission denied or not authorized. At the moment I am logged in as the Guest User. I would like to Un-install Ubuntu 14.04 from this PC, but each time I go to a site which promises an uninstall package it either has Windows un-installation command ( which I do not have in this PC- it is a dedicated Ubuntu PC) or it turns out to be boot-repair-kit for the installation of Ubuntu. It is like catch-22 situation. Any idea how to ub install Ubuntu 14.04?

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

You do not need to reinstall Ubuntu, if you forgot your sudo password.

Please read this first:



You can uninstall applications, but you cannot write "uninstall an
operating system", because there is no such thing as 'uninstalling' an OS.

You can 'replace' or 'overwrite' an operating system using boot install media (for example: using USB stick, CDROM drive, etc...)

Revision history for this message
Mark Rijckenberg (markrijckenberg) said :

Here are more guides about Ubuntu:


Revision history for this message
len (leonardleigh15) said :

Hello Mark, I took one of your advises and over-wrote Linux Mint on Ubuntu. Problem solved. Thank you very much for your help and support.