kernel 4.2 incompatible with old soft

Asked by Mikhail Rokhin on 2015-12-13

version.h is absent in headers upcoming with new kernel-4.2, so it leads to failure to compile kernel modules of some older programs like Symantec SAV, etc. Some like virtualbox guest additions (v 5.0.10) claim that can't find headers for current kernel.

Kernel-3.x still have it in place, for e.g. /usr/src/linux-headers-3.19.0-39/include/linux/version.h .

Could you correct it to allow compatibility, please?

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-12-13
Last query:
2015-12-13
Last reply:
2015-12-13

I suggest you report a bug.

Jorge Castro (jorge) said : #2

Reporting bugs to the kernel has an entire page of instructions on how to do it:

https://wiki.ubuntu.com/Kernel/Bugs

Thanks actionparsnip, that solved my question.

ubuntu-bug linux-headers-4.2.0-19