dpkg commando does'nt work any more

Asked by Roelof

Hello everybody,

when i do sudo dpkg -i "packet_name" are install a program with synaptic i get the following error.

fault in buffer_read(fd): filelist-file before packet `dnsutils': Invalid argument

Installation halted because to many faults

(i translated it from dutch)

I use ubuntu 6.10 edgy

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Ryan Kavanagh (ryanakca) said :

Are you getting a sigsev as well?

Revision history for this message
Frode M. Døving (frode) said :

If you posted the full command you execute and the resulting error, that would be helpfull.

- Frode

Revision history for this message
ufa (ufa-ogros) said :

I am having the same problem.

I posted in the forum:

Lendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências
Reading state information... Pronto
É preciso fazer o download de 0B/69,8MB de arquivos.
Depois de desempacotamento, 109MB adicionais de espaço em disco serão usados.
Quer continuar [S/n] ?
Selecionando pacote previamente não selecionado libsdl-net1.2.
(Lendo banco de dados ... dpkg: erro processando /var/cache/apt/archives/libsdl-net1.2_1.2.5-7_i386.deb (--unpack):
falha em buffer_read(fd): lista de arquivos do pacote `openoffice.org-evolution': Argumento inválido
E: Sub-process /usr/bin/dpkg received a segmentation fault.

It is in portuguese, so i will translate:

(reading database.... dpkg: error processing /var/cache/apt/archives/libsdl-net1.2_1.2.5-7_i386.deb (--unpack):
Failed in buffer_read(fd): packet list archive 'openoffice.org-evolution': Invalid Argument

So i cant do anything, i tried to purge/remove the ooo-evolution, and nothing works, always i fell in the same error.
I tried:

dpkg --configure -a
apttitude install openoffice.org-evolution

With the same error. I tried to "fsck /dev/hda1 -r" but returns clean.

Does someone have a clue?

Revision history for this message
ufa (ufa-ogros) said :

Just adding,
any command that is or derivate from a dpkg -i, or a remove, or a reinstall, gives me that error.

Revision history for this message
Frode M. Døving (frode) said :

I read the thread at ubuntuforums.org and it looks like this ticket should be closed.
Please close this if the problem is solved.

Revision history for this message
greylica (greylica-msn) said :

The problem is related to an archive inside /var/lib/dpkg that tells dpkg, apt-get and aptitude, the primary sources of your mounted distribution. (available) .
Normally, this happens when you are reading the archive when a lock is placed inside /var/cache/apt and the hardware fails or a unexpected shutdown happens. And then, the archive is renamed, or placed inside lost and founds. You can do a simple rename on the archive but You can also copy from another source and replace this archive as well.
This archive is normally read only.

Glad to help. :)

Can you help with this problem?

Provide an answer of your own, or ask Roelof for more information if necessary.

To post a message you must log in.