Ubuntu

onboard video problem

Asked by Harold meneley on 2008-03-17

Compaq Presario SR1033WM has onboard Intel 845G video and I can install Linux (Debian, Ubuntu, Knoppix) onto the machine as is.
 BIOS only allows selection of primary video - ONBOARD or PCI - no disable and no BIOS update available
When I try PCI with nVidia or any other video card to install - I get errors installing Linux
Install with ONBOARD then tried to reconfigure xorg and then switching to PCI/nVidia - failed
Tried most boot options acpi=off noapic nolapic pci=noacpi irqpoll notsc no_timer_check clock=pmtmr
Always errors out with smp_apic_timer_interrupt

The problem is in the video card module being setup by /dev during boot - it sets up the Intel 845G even when PCI is selected
If I select ONBOARD with the nVidia card setup - I get the boot up till Login on the Intel then it goes to the nVidia but back to the Intel at Shutdown
Very not cool - can't tell when it is done and don't want seperate monitors hooked up
I had no problem with Windows setup on this machine.

I am willing to troubleshoot or test any options you might have.
I was hardware repairman for 12 years and know some programming stuff ( Visual Basic, PHP, etc...)

Feel free to suggest or point me in the right direction as I have several of these machines along with other video cards and PCs

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Harold meneley
Solved:
2008-03-27
Last query:
2008-03-27
Last reply:
Harold meneley (meneleyh) said : #1

Call trace shows up after
Waiting for /dev to populate

[<c0103747>] apic_timer_interrrupt+0x1f/0x24
[<e00e76d1>] intel_i830_configure+0xe2/0xf3 [intel_agp]
[<e00fe2a2>] agp_add_bridge+0x169/0x283 [agpgart]
[<c0210e08>] __driver_attach+0x0/0x5d
[<c01c1b34>] pci_device_probe+0x36/0x57
[<c0210d69>] driver_probe_device+0x42/0x8b
[<c0210e40>] __driver_attach+0x38/0x5d
[<c021088a>] bus_for_each_dev+0x33/0x55
[<c0210cd3>] driver_attach+0x11/0x13
[<c0210e08>] __driver_attach+0x0/0x5d
[<c02105a3>] bus_add_driver=0x64/0xfd
[<c01c1c70>] __pci_reguster_driver+0x47/0x63
[<c01358d9>] sys_init_module+0x16c3/0x1846
[<c0161b28>] cp_new_stat64+0xfd/0x19f
[<c0102c11>] sysenter_past_esp+0x56/0x79

It looks like it tries to configure I830 through the agpgart module???
----nVidia should be the one configured----
is this possibly from the pci device probe or bus check???
or is this caused by the result of agpgart ????

Harold meneley (meneleyh) said : #2

While trying to find information on the agpgart module, I ran into a thing about the boot process and modprobe. After some more investigating, I added intel_agp and agpgart to /etc/modprobe.d/blacklist. I powered down the system. I boot up to setup changed the video to PCI and saved/exit. I was amazed to see the computer populate the /dev and gnome and the gdm start. I now have a functioning system using the nVidia video in the PCI slot.

again.....
add intel_agp and agpgart to the bottom of /etc/modprobe.d/blacklist

I didn't need to change the xorg.conf file because I had installed the nVidia driver and used it to configure xorg

I haven't tried using both video cards, but I don't see any reason for me to.

This fixed all the Linux distros I tried .. Debian, Ubuntu, Knoppix