Cannot download the metalink and therefore the iso; UBUNTU-14.04.2

Asked by Dr U P Singh on 2015-08-02

I have running Windows 8.1 on my Lenovo Z50-70 Laptop.
I downloaded "Ubuntu 14.04.2 LTS" from
I also PAID $4 for Ubuntu Desktop ($2) and Ubuntu on public clouds ($2).
When I try to install it by running "wubi.exe", following error occurs while installing with "UBUNTU environment:
I tried on three different systems, but all face the same problem.
I also tried different desktop environment, viz. edubuntu, kubuntu, Ubuntu. It also downloaded more than 2GB file edubuntu-14.04.2-dvd-i386.iso but could not installed.
Please see a screenshot here:

Please help!

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:

Wubi has not been developed for over 3 YEARS and is completely abandoned. Do not use it.

Resize your NTFS partition and install to the freed space. Making a dual boot system. If you want to try Ubuntu in a minimally system changing way then install Virtualbox in Windows and install Ubuntu there to test it.

Wubi wasn't even good when development was active

Dr U P Singh (upsingh1980) said : #2

Please go through the lines deeply. Don't reply with having an overview.

You suggested to avoid using wubi.exe but you didn't advised the alternate method to install Ubuntu.
The only installer, that I could see in the complete ISO file, is wubi.exe.
The total file in ISO download "ubuntu-14.04.2-desktop-amd64.iso" can be seen here (screenshot):

My Laptop is new. 1TB hoard disk is there. Sufficient Disk space (>=90) is empty.
Even C drive has 85% (200GB) empty space.

Please suggest with complete and clear process, if you know, otherwise, do not try to deviate my question.

Thanks in advance.

Resize the NTFS partition in Windows to make free space. Disk manager can do this

Boot to the Ubuntu CD and install to the freed space. The CD you have is bookable, just like when you install Windows.

Dr U P Singh (upsingh1980) said : #5

Dear Sir
I studied of your suggestions. I tried with Bootable USB, Bootable DVD but I could not installed Ubuntu on my system (Lenovo Z50-70).
The process automatically terminates with the notice "AN SERIOUS UNRECOVERABLE ERROR OCCURRED DURING INSTALLATION. A DESKTOP SESSION WILL NOW RUN .....", and automatically Live Session starts.
However, the same USB and DVD installs UBUNTU on other systems (HP, WIPRO, etc.) but those also do not run and ask to download Language Support and some other supports, but I unluckily none of UBUNTU, EDUBUNTU, KUBUNTU connects to internet (neither office internet nor home), however earlier versions 12.04 connects to internet.
Can any one reply separately to all issues, please?

Thanks in advance.

michael (yellupcm-gmail) said : #6

The sites have more information, that may be helpful.

Hope they help.

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.