Wireless internet not working

Asked by Raghu on 2008-03-13

Hi,

I have a Dell VOSTRO 1000 with an AMD 64-bit processor and a Dell 1490 802.11 a/g wireless card (Broadcom). I'm unable to connect to the internet using wireless. I was trying to configure wireless on my laptop and I did something and unknowingly, I have deleted the wireless connection from my laptop. I mean - earlier when I opened Network manager I would get three types of connections - wired, wireless and modem. Now I get only wired and modem. Can you please help retrieve the wireless connection? I would also need steps to set it up for internet (using ndiswrapper I think?). Thanks!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Raghu
Solved:
2008-04-04
Last query:
2008-04-04
Last reply:
2008-04-03
peter b (b1pete) said : #1

hello Raghu,

pls take a look at

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Gutsy

they are self explanatory; just follow the step by step howto and it'll get you there.

hope this helps.

peter b

Raghu (raghunandanhegde) said : #2

Hi Peter,

Restricted Driver Manager says my Broadcom43xx firmware is in use. I had downloaded it and enabled the firmware. But there is no wireless connection in my network manager. Can you please help me with that? Thanks

peter b (b1pete) said : #3

Raghu,

pls go down page on the last url posted - Troubleshooting - remove then reinstall the module and continue with

iwconfig

please post the output of iwconfig.

peter b

Raghu (raghunandanhegde) said : #4

Hi,

iwconfig says

 lo no wireless extensions
 eth0 no wireless extensions

Thanks,
Raghu

Raghu (raghunandanhegde) said : #5

Restricted Drivers manager says the status for Firmware for Broadcom family 43x chipset family is "In Use" and it is enabled (the check-box is checked), but I don't get Wireless connection in the Network Manager GUI :(

peter b (b1pete) said : #6

Raghu,

now, System-->admin-->network do you see only eth0 ? or do you see also wifi ? (doubtful)

if you do NOT see wifi go to system-->admin-->synaptic and do a search for

network-manager and

network-manager-gnome

if checked (installed) pls right click and choose complete uninstall, let it finish, it'll tell you that then do in a terminal

sudo apt-get install network-manager-gnome --> it'll install it then

sudo /etc/init.d/dbus restart

then restart the PC and check again system-->admin-->network there should be also a wifi connection

pls tell me if that's the case. do also

sudo iwconfig

and tell me what's the output.

peter b

peter b (b1pete) said : #7

Raghu,

just to be clear,

sudo apt-get install network-manager-gnome

that's the command; pls DO NOT ENTER --> ...... That's only an explanation!! sorry, it should have been on another line

peter b

Raghu (raghunandanhegde) said : #8

Hi,

This is the output I got when I tried the apt-get command in the terminal

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

peter b (b1pete) said : #9

after finishing the operations in synaptic pls close it then do the apt-get commands --> you can not have open synaptic and carry out apt-get or aptitude commands.

peter b

Raghu (raghunandanhegde) said : #10

Hi Peter,

I executed the above commands.. there were no errors but network manager still doesn't show a wireless. It only shows wired and modem.

iwconfig output is the same as before.
lo no wireless extensions.

eth0 no wireless extensions.

Thanks

peter b (b1pete) said : #11

did you restart the pc after the commands?

Raghu (raghunandanhegde) said : #12

Yes I did, but to no avail

peter b (b1pete) said : #13

ok, it appears that something is wrong somewhere, I don't know in these circumstances whether the next thing will help you -we'll try it.

first thing do go to synaptic again and this time search again for network-manager and network-manager-gnome

right click and select complete uninstall including the conf files

close synaptic

go to this url

http://sourceforge.net/project/showfiles.php?group_id=194573

it is a package called wicd --> pls pick the stable version and download it --> it'll go to desktop, it's a deb package

double click on it --> it'll open and install it then

go to applications-->internet and click on icon wicd --> a gui will open then go to preference and see what interfaces it sees

tell me what you see after the above finished.

that's one avenue.

the second, or the first, your choice, I'd recommend do this first before wicd above

just go to system-->admin-->restricted drivers and disable the bcmxx driver and do a new install as shown on the second url of this thread --> I think is on my first post. PLEASE follow the steps V CLOSELY depending whether you do it CONNECTED to the internet or OFFLINE ; another thing, please pick the RIGHT fwcutter file CORRESPONDING to the distro you have -they are distro specific. suggestion, if you do it off line pls make a hard copy of the howto and checkmark every step finished so at the end you're sure that everything was done according to the documentation. CAUTION - this procedure requires network-manager TO BE INSTALLED so, if you decide to do this first them pls DO NOT uninstall network-manager. ONLY wicd REQUIRES network-manager NOT INSTALLED.

tell me how it goes.

peter b

peter b

Raghu (raghunandanhegde) said : #14

Hi Peter,

I followed your second idea.. of disabling the bcmxxdriver and enabling it again. I followed the steps mentioned and did it online. It didn't give me any options for downloading the fwcutter file.

The URL that was used for downloading the file was http://xeve.de/down/wl_apsta.o

What is the next step? I still can't see the wireless connection in my network manager.

Thanks!

Raghu (raghunandanhegde) said : #15

Do I need to do the wicd step as well, after the firmware re-enabling?

peter b (b1pete) said : #16

Raghu,

there is something that we're missing somewhere. my point is this: with the restricted drivers ONLINE installs personally I had troubles. so saying that and the experience I had with another question re same subject recently, the other person did not have a conn'n to internet and was forced to use OFFLINE steps and was successful with no problems. the offline I find much more thorough and to the point ie the user is in full control of what specifically must be downloaded and the steps are v concise. I would recommend to give a try to the offline procedure; to be v specific - there are 2 files -->

one is the so called fwcutter WHICH IS DISTRO/CPU SPECIFIC --> 386, amd64 etc

quote .....'

Off-line Installation

This procedure outlines the process of downloading the neccessary installation files using a separate Internet enabled PC as an intermediary. If you have a working Windows partition, then you can use that to get the file you need and reboot into Ubuntu to finish the installation.

1) Download the [WWW] bcm43xx-fwcutter package from the Universe repository.

    *

      Intel compatible - [WWW] bcm43xx-fwcutter_006-3_i386.deb
    *

      64 bit - [WWW] bcm43xx-fwcutter_006-3_amd64.deb
    *

      PowerPC - [WWW] bcm43xx-fwcutter_006-3_powerpc.deb

2) Download the firmware from [WWW] http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o or see Firmware Sources below.

3) Transfer these files on to the Ubuntu machine.

4) Double-click the bcm43xx-fwcutter-*.deb package to install with the package installer. You may receive a warning that there is the same version available from the channel, but as it's not currently accessible you will have to proceed with this file.

5) During installation it will ask you if you would like it to fetch and extract the firmware. This step will fail without an Internet connection so just click Forward and then close the the package installer.

6) Open System -> Administration -> Restricted Driver Manager and you will see that under the Firmware drop down arrow it says Firmware for Broadcom 43xx chipset family and under Status it says Not in Use.

6) Tick the box under Enabled to enable the firmware.

7) Click Enable Firmware to continue.

8) Select Use a local file and browse to the wl_apsta-3.130.20.0.o firmware file and click Open.

9) Click Ok to extract the firmware.

10) If the status has changed to In use, then you are successful.

'...... end of quote

the other one the so called asta.o file use the link as indicated. after you have downloaded the two GOOD files to folder of your choice proceed with the steps indicated and observe v closely every step. before proceeding the restricted bcm driver must not be in use.

as far as the wicd package, you can give it try; I doubt that there'll be any success --> the wifi must be there to work, however, I never tried it without it. it is a great package.

now, please tell me exactly what chipset your broadcom wifi uses - it may very well be that your chipset is not supported yet. take a look at

http://linuxwireless.org/en/users/Drivers/b43#supported

tell me how it goes.

peter b

Raghu (raghunandanhegde) said : #17

Hi Peter,

I disabled the firmware thro' Restricted Driver Manager. I downloaded the driver for my machine (AMD 64-bit) from the Universe repository but when I tried installing the debian package, it said "Wrong architecture".

I removed network manager thro' the Synaptic Package manager and downloaded and installed wicd. It seems to be working OK because I was able to bring up the screen after navigating to Internet - wicd.

The options that are available under wicd are : Network, Disconnect, Refresh, Preferences. About and Quit. It also says "No network found". The wireless network is available and working fine since I can access it thro' Windows correctly.

What would you suggest now?

Thanks,
Raghu

peter b (b1pete) said : #18

Raghu,

pls go to system-->admin-->syst monitor-->syst tab and paste here what it says

secondly, do in a terminal

uname -a

and paste here what it says

thirdly, do in a terminal

gedit /etc/network/interfaces

and paste here its contents. we'll work from here on based on this output.

peter b

Raghu (raghunandanhegde) said : #19

Hi Peter,

These are the outputs that you asked for.. I have emailed you the attachment of system monitor - system tab

raghoos@raghoos:~$ uname -a
Linux raghoos 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Output for gedit /etc/network/interfaces
-----------------------------------------
auto lo
iface lo inet loopback
iface eth0 inet dhcp
address 192.168.1.3
netmask 255.255.255.0
gateway 192.168.1.1

iface eth1 inet dhcp
wireless-key
wireless-essid SAPE183

Let me know if you need anything else from me.

Raghu (raghunandanhegde) said : #20

Hi Peter,

Please see the attachment

Thanks,
 Raghu

On Mon, Mar 17, 2008 at 1:59 AM, peter b <
<email address hidden>> wrote:

> Your question #26976 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/26976
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> Raghu,
>
> pls go to system-->admin-->syst monitor-->syst tab and paste here what
> it says
>
> secondly, do in a terminal
>
> uname -a
>
> and paste here what it says
>
> thirdly, do in a terminal
>
> gedit /etc/network/interfaces
>
> and paste here its contents. we'll work from here on based on this
> output.
>
> peter b
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/26976/+confirm?answer_id=17
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/26976
>
> You received this question notification because you are a direct
> subscriber of the question.
>

peter b (b1pete) said : #21

OK Raghu,

Here I am - I was a little busy with some other things - sorry for the delay.

- first, looking at your answers - it appears that you're having installed an optimized amd64 kernel ie i686 - no wonder that you've got the message wrong architecture; the deb packages in the two posts above ARE FOR i386, amd64 NOT FOR i686

- secondly, you would have in this situation to IDENTIFY via
lspci
command the SPECIFIC bcmxx chipset that is present on your PC - how to go about it? just follow the instructions given on my first post, first url above, or the same thing in the url that I'll post below

- thirdly, given the optimized -686 kernel you're having installed, THE PROBLEM MUST BE APPROACHED DIFFERENTLY - for broadcom chipsets it appears that for ubuntu NDISWRAPPER MUST be employed AND WINDOWS DRIVERS MUST BE USED, however, pls notice the caveats in the following url; also, my personal experience with ndiswrapper - it may be fantastic with no problems or it may cause all kinds of grief. As I said in a previous post, there are NO OPEN SOURCE drivers for this architecture - it was a suspicion that crept in my mind after the couple of attempts made.

- so, herebelow the url mentioned above

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff

that'll help you sort out the problem - hopefully - and the associated url's listed within it. As you'll see, the procedure is totally different and more laborious. I would suggest to get quite familiar with it or feel your way in - it's not hard but it requires maximum diligence and attention. It is done for feisty but it appears to work on your gutsy distro too. As I said, within this url there is a link to

https://help.ubuntu.com/community/WifiDocs/Device/Broadcom_BCM4311_rev_01_(ndiswrapper)

which contains more info, pls read that too.

There you have it; pls follow the best you can these howto's and let me know how things go - I'll help the best I can -. good luck.

peter b

Raghu (raghunandanhegde) said : #22

Hi Peter,

Sorry for the late reply... I was busy and spend time on this :(

I checked lspci and the version of Broadcom on my laptop is BCM4312... it is mentioned in the list given in the URL above. So, do I just need to follow the steps mentioned there now?

My next reply might also take some time since I'm traveling, but I'm determined to get to the root of this problem :)

Thanks!
Raghu

peter b (b1pete) said : #23

good news Raghu, you're lucky, however, it appears that 4312 HAS TWO FLAVOURS specifically a 01 and 02 rev. THIS THING IS SPECIFIED BY lspci command output.

Just a word of CAUTION in view of this

- for each version THERE IS A DIFFERENT url hence DIFFERENT DRIVER WHICH IS A KEY ASPECT OF A SUCCESSFUL INSTALL.

sure, after this step, again, DIFFERENT url's or step 2a or 2b based on the output of lspci, proceed with the install as outlined in step 3.

keep me posted how things go.

peter b

Raghu (raghunandanhegde) said : #24

Hi Peter,

Sorry for the very late response... I was traveling and couldn't work on Linux. I wanted a clarification from you. I looked up this site http://linuxwireless.org/en/users/Drivers/b43 and it says BCM 4312 is not supported. What does that mean? And where can I get Windows wrapper drivers for my card?

Thanks

peter b (b1pete) said : #25

OK Raghu,

just forget for the time being what that site says, that refers to the open source drivers which we know that are not avail--> let's see how the ubuntu howto (the url I posted) instructions perform. So have a go AD LITERAM with the instructions on

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff

I understand that you already started with

lspci

and identified the bcmxx as bcm4312 HOWEVER, YOU DID NOT POST WHAT VER IS THERE and I drew your att'n on the previous post to this fact which is CRUCIAL. so pls rerun

lspci

and MAKE SURE THAT YOU DOWNLOAD THE APPROPRIATE DRIVER FOR WHAT'S INSTALLED --> THAT'S either 2a or 2b on the howto. pls complete ONE ONLY PENDING WHAT VER YOU'VE GOT, then proceed with step 3 and following.

.....'And where can I get Windows wrapper drivers for my card?'..... answer: point 2a or 2b answers that question. the files are EITHER

sp33008.exe

or

sp34152.exe

NOT BOTH!!!! after downloading them, extract them; they'll be located in your /home.

peter b

Raghu (raghunandanhegde) said : #26

Oops! Sorry I forgot to add... mine is BCM4312 rev01... so it's step 2b, but the FTP link directs to compaq.com... will it work for Dell as well?

peter b (b1pete) said : #27

hopefully....., it will unless Dell with their optimized kernel i686 did something, it's hard to say at this moment.

Raghu (raghunandanhegde) said : #28

Hi Peter,

I did the extraction and it went off perfectly fine. But when I proceeded to step 3, the first command failed.

The command is sudo ndiswrapper -i bcmwl5.inf.

The output I got was Error: no ndiswrapper utils found!

So I did NOT proceed with the remaining steps in step 3.

Peter, so now are we back to trying with the GNOME network panel? What about wicd? I'm thoroughly confused :(

Bhavani Shankar (bhavi) said : #29

Hello raghu

This link can be of some help

http://ubuntuforums.org/showthread.php?t=405990

You can install ndiswrapper related packages...

Please open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

peter b (b1pete) said : #31

OL Raghu,

Don't be confused, so far so good. now,

firstly, go to system-->admin-->synaptic open it and do a search on ndis --> there'll be two packages --> one is called ndiswrapper..... and the second one is called ndiswrapper-utils..... , pls right click on both and select completely remove including config files; then apply and the two packsges will be removed.

secondly, restart your PC and after that AGAIN go to synaptic and this time after searching for ndis pls pick INSTALL both packages; carry on the install and AGAIN restart your PC; now we have a clean install of ndiswrapper. pls confirm that everything went OK.

thirdly, pls tell me where. I mean the path, is the DOWNLOADED file spxxxxx.exe extracted --> it should be somewhere in /home/<yourname> folder; to find out just go Places-->home folder--><yourname> and tell me if you can find some files called bcmxxx.inf and bcmxxx.sys

now, after all these preparatory steps fulfilled OK, we can proceed to installing the drivers. several cautions an this exercise
     - first. when using command ndiswrapper THE PATH TO THE xxxx.inf and xxxxx.sys files MUST BE ENTERED AD LITERAM AS WELL AS THE NAME OF THE xxxx.inf FILE ---> ALL ARE CASE SENSITIVE!!
     - secondly, EVERY TIME I USED ndiswrapper AND SUCCEEDED, THE FOLDER CALLED IN THE PATH MUST CONTAIN, V IMPORTANT POINT, ONLY and I UNDRLINE THE WORD ONLY, xxx.inf AND xxxx.sys.

so, being mindful of all above, pls tell me EXACTLY the name of all files that are there xxxx.inf AND xxxxx.sys --> for sure there'll be some that contain ...32.... or ....64.....

we'll continue after I get answers to all above. don't be confused --> the things are on the right track.

peter b

Raghu (raghunandanhegde) said : #32

Hi Peter,

I did the first two steps as mentioned. My system now has a fresh installation of NDIS and NDIS utilities. As for the location of the bcm files, I'm attaching the snapshot of my home folder to you in an email.

Let me know if you don't get it.

Thanks,
Raghu

Raghu (raghunandanhegde) said : #33

Hi Peter,

Please find the attachment of the home folder of my machine.

Thanks,
 Raghu

On Sun, Mar 30, 2008 at 10:24 PM, peter b <
<email address hidden>> wrote:

> Your question #26976 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/26976
>
> peter b proposed the following answer:
> OL Raghu,
>
> Don't be confused, so far so good. now,
>
> firstly, go to system-->admin-->synaptic open it and do a search on ndis
> --> there'll be two packages --> one is called ndiswrapper..... and the
> second one is called ndiswrapper-utils..... , pls right click on both
> and select completely remove including config files; then apply and the
> two packsges will be removed.
>
> secondly, restart your PC and after that AGAIN go to synaptic and this
> time after searching for ndis pls pick INSTALL both packages; carry on
> the install and AGAIN restart your PC; now we have a clean install of
> ndiswrapper. pls confirm that everything went OK.
>
> thirdly, pls tell me where. I mean the path, is the DOWNLOADED file
> spxxxxx.exe extracted --> it should be somewhere in /home/<yourname>
> folder; to find out just go Places-->home folder--><yourname> and tell
> me if you can find some files called bcmxxx.inf and bcmxxx.sys
>
> now, after all these preparatory steps fulfilled OK, we can proceed to
> installing the drivers. several cautions an this exercise
> - first. when using command ndiswrapper THE PATH TO THE xxxx.inf and
> xxxxx.sys files MUST BE ENTERED AD LITERAM AS WELL AS THE NAME OF THE
> xxxx.inf FILE ---> ALL ARE CASE SENSITIVE!!
> - secondly, EVERY TIME I USED ndiswrapper AND SUCCEEDED, THE FOLDER
> CALLED IN THE PATH MUST CONTAIN, V IMPORTANT POINT, ONLY and I UNDRLINE THE
> WORD ONLY, xxx.inf AND xxxx.sys.
>
> so, being mindful of all above, pls tell me EXACTLY the name of all
> files that are there xxxx.inf AND xxxxx.sys --> for sure there'll be
> some that contain ...32.... or ....64.....
>
> we'll continue after I get answers to all above. don't be confused -->
> the things are on the right track.
>
> peter b
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/26976/+confirm?answer_id=30
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/26976
>
> You received this question notification because you are a direct
> subscriber of the question.
>

peter b (b1pete) said : #34

sorry Raghu, I did not find any attachment.

pls. open a terminal and do

cd /home/<yourname>

where <yourname> is the subfolder in /home that usually contains the files mentioned. then do

ls -l

where l is the lower character L; you'll see all files and any subfolders there. pls. highlight the entire page/s by left click and drag down until all entries are highlighted then right click and select copy , do not do now anything than left click where you'd like that pasted then right click and select paste --> the highlited selection will be pasted there, there in your case would be the post here.

pls do that and send me the file names that were extracted.

peter b

Raghu (raghunandanhegde) said : #35

Hi Peter,

Resending the attachment again..

Thanks,
Raghu

On Mon, Mar 31, 2008 at 7:47 PM, Raghu <email address hidden> wrote:

> Hi Peter,
>
> Please find the attachment of the home folder of my machine.
>
> Thanks,
> Raghu
>
>
> On Sun, Mar 30, 2008 at 10:24 PM, peter b <
> <email address hidden>> wrote:
>
> > Your question #26976 on Ubuntu changed:
> > https://answers.launchpad.net/ubuntu/+question/26976
> >
> > peter b proposed the following answer:
> > OL Raghu,
> >
> > Don't be confused, so far so good. now,
> >
> > firstly, go to system-->admin-->synaptic open it and do a search on ndis
> > --> there'll be two packages --> one is called ndiswrapper..... and the
> > second one is called ndiswrapper-utils..... , pls right click on both
> > and select completely remove including config files; then apply and the
> > two packsges will be removed.
> >
> > secondly, restart your PC and after that AGAIN go to synaptic and this
> > time after searching for ndis pls pick INSTALL both packages; carry on
> > the install and AGAIN restart your PC; now we have a clean install of
> > ndiswrapper. pls confirm that everything went OK.
> >
> > thirdly, pls tell me where. I mean the path, is the DOWNLOADED file
> > spxxxxx.exe extracted --> it should be somewhere in /home/<yourname>
> > folder; to find out just go Places-->home folder--><yourname> and tell
> > me if you can find some files called bcmxxx.inf and bcmxxx.sys
> >
> > now, after all these preparatory steps fulfilled OK, we can proceed to
> > installing the drivers. several cautions an this exercise
> > - first. when using command ndiswrapper THE PATH TO THE xxxx.inf and
> > xxxxx.sys files MUST BE ENTERED AD LITERAM AS WELL AS THE NAME OF THE
> > xxxx.inf FILE ---> ALL ARE CASE SENSITIVE!!
> > - secondly, EVERY TIME I USED ndiswrapper AND SUCCEEDED, THE FOLDER
> > CALLED IN THE PATH MUST CONTAIN, V IMPORTANT POINT, ONLY and I UNDRLINE THE
> > WORD ONLY, xxx.inf AND xxxx.sys.
> >
> > so, being mindful of all above, pls tell me EXACTLY the name of all
> > files that are there xxxx.inf AND xxxxx.sys --> for sure there'll be
> > some that contain ...32.... or ....64.....
> >
> > we'll continue after I get answers to all above. don't be confused -->
> > the things are on the right track.
> >
> > peter b
> >
> > --
> > If this answers your question, please go to the following page to let us
> > know that it is solved:
> >
> > https://answers.launchpad.net/ubuntu/+question/26976/+confirm?answer_id=30
> >
> > If you still need help, you can reply to this email or go to the
> > following page to enter your feedback:
> > https://answers.launchpad.net/ubuntu/+question/26976
> >
> > You received this question notification because you are a direct
> > subscriber of the question.
> >
>
>

Raghu (raghunandanhegde) said : #36

Hi Peter, I resent the attachment since cd/home/my folder name didn't work...

Please let me know if you got it... if you haven't then, I'll just type the names of the files you need and send them to you.

Thanks,
Raghu

peter b (b1pete) said : #37

Raghu,

pls enter

cd /home/<yournemefolder>

there is a space between cd and /home....

Raghu (raghunandanhegde) said : #38

Hi Peter, here is the output

raghoos@raghoos:~$ cd /home/raghoos
raghoos@raghoos:~$ ls -l
total 10952
-rw-r--r-- 1 raghoos raghoos 761856 2006-04-28 17:12 bcm1xsup.dll
-rw-r--r-- 1 raghoos raghoos 10485 2006-04-28 17:12 bcm43xx64.cat
-rw-r--r-- 1 raghoos raghoos 10513 2006-04-28 17:12 bcm43xx.cat
-rw-r--r-- 1 raghoos raghoos 45568 2006-04-28 17:12 Bcmnpf64.sys
-rw-r--r-- 1 raghoos raghoos 545792 2006-04-28 17:12 bcmwl564.sys
-rw-r--r-- 1 raghoos raghoos 675862 2006-04-28 17:12 bcmwl5.inf
-rw-r--r-- 1 raghoos raghoos 429184 2006-04-28 17:12 bcmwl5.sys
-rw-r--r-- 1 raghoos raghoos 81920 2006-04-28 17:12 bcmwliss.dll
-rw-r--r-- 1 raghoos raghoos 33664 2006-04-28 17:12 bcmwlnpf.sys
-rw-r--r-- 1 raghoos raghoos 69632 2006-04-28 17:12 bcmwlpkt.dll
-rw-r--r-- 1 raghoos raghoos 122880 2006-04-28 17:12 bcmwls32.exe
-rw-r--r-- 1 raghoos raghoos 209408 2006-04-28 17:12 bcmwls64.exe
-rw-r--r-- 1 raghoos raghoos 22830 2006-04-28 17:12 bcmwls.ini
-rw-r--r-- 1 raghoos raghoos 176128 2006-04-28 17:12 bcmwlu00.exe
-rw-r--r-- 1 raghoos raghoos 2313329 2006-04-28 17:12 data1.cab
-rw-r--r-- 1 raghoos raghoos 36304 2006-04-28 17:12 data1.hdr
-rw-r--r-- 1 raghoos raghoos 512 2006-04-28 17:12 data2.cab
drwxr-xr-x 2 raghoos raghoos 4096 2008-03-31 19:42 Desktop
drwxr-xr-x 2 raghoos raghoos 4096 2008-02-25 23:27 Documents
lrwxrwxrwx 1 raghoos raghoos 26 2008-02-26 04:47 Examples -> /usr/share/example-content
-rw-r--r-- 1 raghoos raghoos 346602 2006-04-28 17:12 ikernel.ex_
-rw-r--r-- 1 raghoos raghoos 168448 2006-04-28 17:12 is.exe
-rw-r--r-- 1 raghoos raghoos 28 2006-04-28 17:12 launcher.ini
-rw-r--r-- 1 raghoos raghoos 417 2006-04-28 17:12 layout.bin
drwxr-xr-x 2 raghoos raghoos 4096 2008-02-25 23:27 Music
-rw-r--r-- 1 raghoos raghoos 466944 2008-03-14 21:34 nautilus-debug-log.txt
drwxr-xr-x 2 raghoos raghoos 4096 2008-02-25 23:27 Pictures
drwxr-xr-x 2 raghoos raghoos 4096 2008-02-25 23:27 Public
-rw-r--r-- 1 raghoos raghoos 45056 2006-04-28 17:12 setup.exe
-rw-r--r-- 1 raghoos raghoos 595 2006-04-28 17:12 Setup.ini
-rw-r--r-- 1 raghoos raghoos 162689 2006-04-28 17:12 setup.inx
-rw-r--r-- 1 raghoos raghoos 628 2006-04-28 17:12 setup.iss
-rw-r--r-- 1 raghoos raghoos 7886 2006-05-24 16:43 sp33008.cva
-rwxrwxrwx 1 raghoos raghoos 4318656 2008-03-29 23:42 sp33008.exe
drwxr-xr-x 2 raghoos raghoos 4096 2008-02-25 23:27 Templates
drwxr-xr-x 2 raghoos raghoos 4096 2008-02-25 23:27 Videos
raghoos@raghoos:~$

Thanks,
Raghu

peter b (b1pete) said : #39

OK Raghu, you've done it.

now, before we proceed with the crucial steps ahead I have to tell you a couple of things, firstly, this driver install process MAY BE A FULL SUCCESS or MAY BE A FLOP, why? because of the very nature of the distro you have installed --> you've got an OPTIMIZED kernel apparently done by Dell which is an ubuntu genuine kernel but.... patched; because of that it MAY or MAY NOT, only the future will tell, whether the packages that we'll be using are fully compatible and functional under the PATCHED/OPTIMIZED Dell kernel. secondly, ndiswrapper works v well with the ubuntu genuine distro, I do not know if that'll be the case wit Dell's distro -never used ndiswrapper with Dell distros, and thirdly, ndiswrapper has v strict rules that MUST BE FOLLOWED TO THE LETTER, if not, then to try and correct the problems is quite an exercise. PLEASE FROM HERE ON OBSERVE THE BEST YOU CAN WHAT WE"LL BE DOING, and a suggestion, if in doubt pls ask before proceeding.

so, cognizant of these caveats,

- pls go to places-->home folder and open it; on menu bar pick File and select create new folder option; on the right panel highlight the unnamed folder (newly created) and right click on it then pick rename option and on the icon title enter, say, bcmdrivers -YOU MUST ENTER IT EXACTLY AS SHOWN BECAUSE OF WHAT FOLLOWS. you should have a new folder-->the path is /home/raghoos/bcmdrivers

- in this folder - bcmdrivers - we'll copy the following two files -ATT'N, ONLY THESE TWO FILES- from /home/raghoos folder

bcmwl5.inf

and

bcmwl5.sys

for sure you know how to copy and paste. after done PLS CHECK THAT IN bcmdrivers FOLDER THERE ARE ONLY THE TWO FILES ABOVE. AND, V V IMPORTANT!! ALL THESE OPERATIONS ARE CASE SENSITIVE HERE AND FOLLOWING. the folder names, file names MUST BE ENTERED EXACTLY AS INHERITED FROM CABEXTRACT AND AS CREATED AND SHOWN.

next, pls enter in a terminal

sudo ndiswrapper -i /home/raghoos/bcmdrivers/bcmwl5.inf

exactly as shown above IF ALL STEPS BEFORE FOLLOWED. you should/will get some kind of message after this command carried out. PLS COPY IT EXACTLY AND POST IT SO I CAN SEE IT. we'll continue after all above done; just for your peace of mind --> if this command succeeded we're pretty much out of the woods so to speak.

pls do your best and tell me how it went --> output of last command.

peter b

Raghu (raghunandanhegde) said : #40

Hi Peter, here is the output of the last command..

raghoos@raghoos:~$ sudo ndiswrapper -i /home/raghoos/bcmdrivers/bcmwl5.inf
[sudo] password for raghoos:
installing bcmwl5 ...
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2

Please let me know what I need to do next.

Thanks,
Raghu

peter b (b1pete) said : #41

I don't know, we'll see. pls do

sudo ndiswrapper -l

l being the small L

pls post the message after that command here.

peter b

peter b (b1pete) said : #42

checking further, pending what the last command message is, I mean the

sudo ndiswrapper -l

probably the .inf file, in your case, would require

bcmwl564.sys

we'll see after you post the message after last command run.

peter b

Raghu (raghunandanhegde) said : #43

raghoos@raghoos:~$ sudo ndiswrapper -l
[sudo] password for raghoos:
bcmwl5 : driver installed
        device (14E4:4312) present (alternate driver: bcm43xx)

Here is the output you asked for...

peter b (b1pete) said : #44

that's good, I'd say v good, that's the normal message that things are OK1.

now, pls. do

sudo depmod -a

you'll see no output but there'll be a short delay until the raghoos@..... appears again on terminal. after this pls do

sudo modprobe ndiswrapper

then do

sudo cp /etc/network/interfaces /etc/network/interfaces.orig

there'll be no output, then do

echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces

then do

sudo ndiswrapper -m

then do

echo 'ndiswrapper' | sudo tee -a /etc/modules

pls post all messages after the commnds above. we'll continue after that.

peter b

Raghu (raghunandanhegde) said : #45

raghoos@raghoos:~$ sudo depmod -a
[sudo] password for raghoos:
raghoos@raghoos:~$ sudo modprobe ndiswrapper
raghoos@raghoos:~$ sudo cp /etc/network/interfaces /etc/network/interfaces.orig
raghoos@raghoos:~$ echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces
auto lo
iface lo inet loopback

raghoos@raghoos:~$
raghoos@raghoos:~$ sudo ndiswrapper -m
adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper ...
raghoos@raghoos:~$ echo 'ndiswrapper' | sudo tee -a /etc/modules
ndiswrapper
raghoos@raghoos:~$
raghoos@raghoos:~$
raghoos@raghoos:~$

Here you go again, sir!

peter b (b1pete) said : #46

ok, all's fine.

now, we'll blacklist the bcm43xx driver in the kernel. pls do

sudo gedit /etc/modprobe.d/blacklist

the editor will open a new window, move the cursor JUST WITH THE ARROW KEYS AFTER THE LAST CHARACTER OF THE LAST ENTRY then press twice enter key--> you'll have a blinking cursor AT THE BEGINNING OF A NEW LINE; AT THIS BLINKING CURSOR ENTER EXACTLY THE FOLLOWING LINES; OBVIOUSLY, YOU"LL HAVE TO PRESS ENTER AFTER THE FIRST LINE TO OPEN THE SECOND ONE

# Blacklist bcm43xx wifi driver
blacklist bcm43xx

check entries AND AT THE BLINKING CURSOR AT THE END OF SECOND LINE PRESS ENTER KEY ONCE MORE AND LEAVE IT THERE. BE V CAREFUL OF ALL ABOVE EDITING PLS.

now, on the command bar pls select File-->Save and press it; after that File-->Quit. the editor will close and new editted file saved.

now, just reboot the PC. we'll continue after that.

peter b

Raghu (raghunandanhegde) said : #47

Done!

peter b (b1pete) said : #48

ok, now, pls do

sudo aptitude remove wicd

that'll remove wicd; then

sudo aptitude network-manager network-manager-gnome

that'll install network-manager and .....-......-gnome. after these pls do

ifconfig

and

iwconfig

pls post here the outputs.

peter b

Raghu (raghunandanhegde) said : #49

raghoos@raghoos:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1D:09:AC:49:12
          inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::21d:9ff:feac:4912/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:583 errors:0 dropped:0 overruns:0 frame:0
          TX packets:616 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:521363 (509.1 KB) TX bytes:82225 (80.2 KB)
          Interrupt:20

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

raghoos@raghoos:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:off/any
          Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
          Bit Rate:54 Mb/s Tx-Power:32 dBm
          RTS thr:2347 B Fragment thr:2346 B
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

raghoos@raghoos:~$

Peter, sudo aptitude... didn't work I think.. it said Unknown command "network-manager"

peter b (b1pete) said : #50

v sorry, my mistake; it should be

sudo aptitude install network-manager network-manager-gnome

do this first please.

then, pls go to Places-->home folder, on the left panel double click on

File system

and after that on right panel double click on

etc

on right panel scroll to a folder called

network

double click then highlight interfaces-->right click-->open option, a window will open. copy and paste its contents here. we'll continue after that.

peter b

PS.

is there any change as far as the access point is concerned? the last post of yours on mar17 shows the essid

SAPE183

is that still the case? secondly, we'll try first to connect to an access point without any encription key and see how it goes; the last access point I could see that's got a key.

p b

Raghu (raghunandanhegde) said : #51

Hi Peter,

The gnome installer went off without a hitch this time. However, I didn't find any left and right panels as you have mentioned (?). Also, there is no change in the access points and ESSID from the last time.

Thanks,
Raghu

peter b (b1pete) said : #52

first, do this

echo 'ENABLED=0' | sudo tee -a /etc/default/wpasupplicant

then do

gedit /etc/network/interfaces

post the contents here pls

peter b

Raghu (raghunandanhegde) said : #53

raghoos@raghoos:~$ echo 'ENABLED=0' | sudo tee -a /etc/default/wpasupplicant
[sudo] password for raghoos:
ENABLED=0
raghoos@raghoos:~$ gedit /etc/network/interfaces

auto lo
iface lo inet loopback

iface eth0 inet dhcp

auto eth0

The outputs you asked for... by the way, also wanted to tell you that System --> Admin --> Network is now showing "Wireless" under the connections tab, something which was not happening for quite a while now.

Thanks,
Raghu

peter b (b1pete) said : #54

ok, all is just fine. your new conn'n is eth1 --> see your iwconfig command output. as a matter of fact, that was the name of your wifi conn'n - when you posted the contents of /etc/network/interfaces file on mar 17 -just take a look. the contents of that file is still there but under interfaces.orig name.

now pls do

sudo gedit /etc/network/interfaces

as you'll see, the file interfaces that we're going to edit - see below how- contains an auto conn'n to eth0 which for sure you have used. we'll leave that conn'n there BUT remove the auto eth0 line and, based on your statement that there is no change to the access point config --> we'll reestablish the config of eth1 to essid SAPE183, so the interfaces file should look like below --> CAUTION!! start editing FROM THE BOTTOM OF FILE firstly placing cursor on the last line character and use backspace key to remove

auto eth0

then add the following lines as shown below AGAIN OBSERVING the good editing practice as shown on a prev post

iface eth1 inet dhcp
wireless-key
wireless-essid SAPE183

auto eth1

AND, TO BE ON THE SAFE SIDE we'll comment out the wired conn'n; so your interfaces file FINAL should look as follows

auto lo
iface lo inet loopback

# iface eth0 inet dhcp

face eth1 inet dhcp
wireless-key
wireless-essid SAPE183

auto eth1

CHECK pls and do file-->save and then file-->quit, then open a terminal and do

sudo ifup eth1

then do

sudo iwlist eth1 scan

pls post the output of the 2 last commands here. the last command will, hopefully see you SAPE183 essid.

peter b

PS. if allok we'kll then go system-->admin-->network; you should have at least 2 entries if not 3 the last for modem if you pc has such thing.

Raghu (raghunandanhegde) said : #55

raghoos@raghoos:~$ sudo gedit /etc/network/interfaces
[sudo] password for raghoos:
raghoos@raghoos:~$ sudo ifup eth1
/etc/network/interfaces:8: option with empty value
ifup: couldn't read interfaces file "/etc/network/interfaces"
raghoos@raghoos:~$ sudo iwlist eth1 scan
eth1 Scan completed :
          Cell 01 - Address: 00:08:5C:EF:6F:88
                    ESSID:"c-182"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:34/100 Signal level:-74 dBm Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
          Cell 02 - Address: 00:11:50:09:DC:BF
                    ESSID:"belkin54g"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:9/100 Signal level:-90 dBm Noise level:-96 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
          Cell 03 - Address: 00:08:5C:53:BB:5E
                    ESSID:"Smart Villa1"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:12/100 Signal level:-88 dBm Noise level:-96 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
          Cell 04 - Address: 00:08:5C:7C:32:77
                    ESSID:"jaykin"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:9/100 Signal level:-90 dBm Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
          Cell 05 - Address: 00:90:4C:7E:00:64
                    ESSID:"Umesh"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:14/100 Signal level:-87 dBm Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
          Cell 06 - Address: 00:1B:2F:57:89:7C
                    ESSID:"olive -1"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:6/100 Signal level:-92 dBm Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : WEP-40
                        Pairwise Ciphers (2) : WEP-40 TKIP
                        Authentication Suites (1) : PSK
                       Preauthentication Supported
                    IE: WPA Version 1
                        Group Cipher : WEP-40
                        Pairwise Ciphers (2) : WEP-40 TKIP
                        Authentication Suites (1) : PSK
          Cell 07 - Address: 00:17:9A:D6:6F:F2
                    ESSID:"SAPE183"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.437 GHz (Channel 6)
                    Quality:100/100 Signal level:-32 dBm Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=200
                    Extra:atim=0

Peter... the outputs you asked for...

Just one thing, when you have repeated the interfaces file for confirmation above, you have mentioned face instead of iface. I hope it's iface? I have saved it as iface in the interfaces file. And yes, there are 3 entries in the Network Settings, including modem.

And also, I was working in Linux using a wired internet connection. And it got disconnected after the above changes. But in the network panel, the wireless option is checked. Are we close to solving the problem now? :)

peter b (b1pete) said : #56

ok Raghu, all is just fine. you DID the right move by adding the -i- to -face- it should have been iface - my typo sorry.

yes, it's normal to get disconnected the wired network - remember? we commented out the wired connection eth0 ?.

now, your eth1 wifi scanned ok and could see quite a few access points where you are. there is one essid called belkin54g I could see that there is no key on. we'll try to connect to this one to complete this thread re driver that got quite long. so the first move -pls do

sudo gedit /etc/network/interfaces

we'll edit so the file looks as follows

auto lo
iface lo inet loopback

# iface eth0 inet dhcp

iface eth1 inet dhcp
wireless-essid belkin54g

auto eth1

then pls go file-->save and file-->quit.

now, let's check system-->admin-->network the 3 entries should be there BUT the wired connection MUST NOT HAVE A CHECKMARK ON if it does then remove it and you'll see a bullet running left to right --> let it complete the interface change and close the window.

on desktop top bar -do you have a network monitor applet showing? if not then right click on an empty space on it and pick add to panel option then from the window that opens select the network monitor applet from system&hardware header --> click add and close window. there should be an applet showing. right click on it and select wireless networking.

reboot your pc. you should be connected to ap belkin54g.

tell me how it went.

peter b

Raghu (raghunandanhegde) said : #57

Did everything as suggested but it didn't work. I added the network monitor applet to the panel, but it didn't have an option to choose wireless. But it's properties showed eth1:avahi and status:disconnected.

I checked System --> Admin --> Network and wireless was checked there. It's properties showed ap bekin54g.

Just to be sure Peter, I think I'm probably "legally" only allowed to access SAPE183. I have the key for that connection.

peter b (b1pete) said : #58

go the desktop, top panel, network applet and enter just

eth1

take out :avahi

Raghu (raghunandanhegde) said : #59

Did that.. but still the status is showing disconnected. The number of packets sent and received are also shown as 0. Actually, there is a signal strength indicator next to the applet and it's showing no strength. Can we try the same with SAPE183? Maybe it'll work??

peter b (b1pete) said : #60

Raghu,

one thing is certain --> the driver is there -in place- and working perfectly, it scans with no problems through the new interface eth1 created: it saw the ap adjacent. we'll try one more thing

now, just to recheck before conclusion, reopen the network from system-->admin and make sure that the following are in place

select by highlighting the connection
click properties
make sure that the ESSID entry shows belkin54g
make sure that Passport type entry is WPA Personal
make sure that Configuration entry is showing Automatic Configuration (DHCP)
then select OK

if you still can not connect to belkin54g ap is because that ap has the filtered mac option set and does not allow connections if they are not on its list. if you know the admin of that ap you can ask him/her to enter on the list your mac address tempoararily just to get a conn'n to an ap. it can be deleted v easily after by him/her.

failing this it's very hard for me to go further on this thread/question, it is a different matter (connection problems) that is not pertinent to this thread which is drivers and create a new interface: that, I feel, should be addressed on a new different thread - a new specific question; for sure somebody will help you - it may be me or somebody hotter than me on connection matters. for me to continue on this thread with a different topic is of no help to the community - tackle something that is totally different than wireless interfaces/drivers - I'd have to go into wpasupplicant installation, configuration and all aspects re encription keys, probably even mac filters and on and on. I hope you see my point.

so, I propose closing this thread - it got quite long- and open a new question/thread with a specific question re ACCESS POINT CONNECTION THROUGH AN EXISTING INTERFACE.

it was a pleasant experience helping you get back the lost interface.

best regards and enjoy your new ndiswrapper created wifi interface.

peter b

Raghu (raghunandanhegde) said : #61

Hi Peter, this solved my problem... and now I'm able to connect to the wireless thro' my laptop... thanks a ton for your help... yeah, this thread did stretch so your efforts are all the more appreciated.

Thanks!
Raghu

peter b (b1pete) said : #62

glad to hear that it helped you connect to an ap. once again, best regards and take care.

cheerios,

peter b