4.x kernel not updating from Software Updater

Asked by Dan Gillmor on 2015-07-28

I'm running 14.04 and installed the 4.02 kernel several months ago because it supported my hardware better (ThinkPad T450s) than the 3.13 kernel.

When I run software update, however, it does not update the 4.x kernel at all -- just the 3.13 one.

I also see that 4.0.x is marked EOL at kernel.org and that 4.1.3 is now listed as the current stable kernel.

Questions:

-- Do I need to install the newest kernel manually as I did with 4.0 in the first place?
-- And what would happen if I just removed 3.13 from my system? Would that cause the Software Updater to look for 4.x updates?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2015-07-29
Last query:
2015-07-29
Last reply:
2015-07-29

The 4.xx kernel is not from the official repos, you probably installed it using a deb so it won't magically update because the package system cannot see a newer version of the kernel to install.

If the hardware is working, why do you want to change the kernel anyway??

Best Manfred Hampl (m-hampl) said : #2

The package management system will only look for a 3.13 kernel for trusty.

If you install the linux-meta-lts-vivid package, your system will install and upgrade the 3.19 kernels.

A kernel from the 4.0 or 4.1 series can - for the time being - only be installed manually.

Later this year there will most probably a linux-meta-lts-wily package be published, that will then care that the kernel versions that will be the current ones for wily at that time will also be made available to trusty.

Dan Gillmor (dan-gillmor) said : #3

As noted, I replaced the 3.13 kernel in order to get all my hardware working. What I see now is that I'm a number of releases back from the most recent 4.0.x (and suspect there have been security updates I should have, yes?).

The 3.19 kernel also gave me some problems with hardware.

Appreciate the responses!

Manfred Hampl (m-hampl) said : #4

For the time being (until linux-meta-lts-wily will be made available - not before October 2015, more probably February 2016) the only chance to get a 4.* kernel is a manual installation.

By your first installation of a 4.0 kernel you have left the path that is supported by Ubuntu, and now it is your own responsibility to care for updates of the kernel.

Which is basically what I said

Dan Gillmor (dan-gillmor) said : #6

Thank all for the help. As suggested I'm going to be sure to update the kernel manually from now on. I'll keep an eye on the repositories so I don't miss the updates.

Dan Gillmor (dan-gillmor) said : #7

Thanks Manfred Hampl, that solved my question.