Steam doesn't work correctly after kernel update

Asked by Eduardo Medina on 2015-07-28

Hi, I have my home folder and the root folder separated in different drives.

The last kernel update (3.13.0-59 on K/Ubuntu 14.04.2) broke the Steam compatibility in the two computers I have with Ubuntu, one with Ubuntu and the other with Kubuntu. Since that, I can't see the games I have installed in my computer, and when I try to install one game it the location of installation shows this.

https://mega.co.nz/#!Dw0CASoJ!nlRVlqoiqW64cXmcuOSjBE_OfFjXmnEJyPrO3d9DCQM

If you are a Steam user, you can see that my Steam installation folder doesn't appear, and when I try to set an alternate location in my home folder it says that I don't have permissions to do that.

Running Steam through a graphical console I get these strange messages that look like a some kind of bug.

------
Generating new string page texture 87: 2048x256, total string texture memory is 3,98 MB
Generating new string page texture 88: 1024x256, total string texture memory is 5,03 MB
assert_20150728164016_7.dmp[4072]: Finished uploading minidump (out-of-process): success = yes
assert_20150728164016_7.dmp[4072]: response: CrashID=bp-d14bc380-5b2d-427f-8345-03b4a2150728
assert_20150728164016_7.dmp[4072]: file ''/tmp/dumps/assert_20150728164016_7.dmp'', upload yes: ''CrashID=bp-d14bc380-5b2d-427f-8345-03b4a2150728''
CAPIJobRequestUserStats - Server response failed 2
Generating new string page texture 93: 256x256, total string texture memory is 5,29 MB
PNG load warning Interlace handling should be turned on when using png_read_image
Generating new string page texture 96: 128x256, total string texture memory is 5,42 MB
------

The "Generating new string" lines look correct, but the others you can see seem that not. The rest of Steam (Store, Community) doesn't work.

I took the "/tmp/dumps/assert_20150728164016_7.dmp" file for anyone who want to see the result it sends to me.

https://mega.co.nz/#!igNVwKiB!OWevW8o4FlTTxgddCkfSR8eqI4mjBzL4KScyvP_JEg8

I'm waiting for instructions.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-07-28
Last query:
2015-07-28
Last reply:
2015-07-28

If you boot to the older kernel, is it ok?

Eduardo Medina (edu-rm-85-z) said : #2

The previous kernel (3.13.0-58) works perfect. The games installed look white, while in the newer kernel they look grey, like they were uninstalled.

https://mega.co.nz/#!3klRgSTY!EDmwiIlDIXpUG77XwSb9bjZx3TwChxASEuxHBAj0fAc

Then roll back to the good kernel and apt pin the kernel so it doesn't upgrade.

Eduardo Medina (edu-rm-85-z) said : #4

I can install KOTOR II in Ubuntu (Unity) with the 3.13.0-55 kernel. It's a laptop I just use twice in a month and I don't update it everyday.

Eduardo Medina (edu-rm-85-z) said : #5

How do I do to pin the kernel?

Too hard to search the web for guides....?

https://help.ubuntu.com/community/PinningHowto

Eduardo Medina (edu-rm-85-z) said : #7

That web page gave me a 500 error some time ago ¬¬ .

Thank you very much for your help.

Eduardo Medina (edu-rm-85-z) said : #8

Thanks actionparsnip, that solved my question.

Manfred Hampl (m-hampl) said : #9

There is a bug report about this problem Bug #1479093

Manfred Hampl (m-hampl) said : #10

The 3.13.0-61 version of the kernel is said to solve the problem. You should now be able to un-pin the 3.13.0-55 kernel version and let the system upgrade to the -61 version.

Eduardo Medina (edu-rm-85-z) said : #11

Yes, I see now that the latest kernel version (61) works perfect.