can't play video using any player

Asked by idwidar on 2008-03-13

i can't play video using any player ,i tried using mplayer and vlc player but no video displayed ,only sound can be heared without any picture , i tried also installing the codec that mplayer requested but the problem persists , also i found that ubuntu is reading my display card properly.my display adapter chip is sis 661fx.i don't know how to solve this problem ?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-03-16
Last reply:
2008-08-06

Open MPlayer → right click in window → Preferences → Video → Available drivers → change driver → choose one from these "xv", "x11", "gl".

idwidar (idwidar) said : #2

thank u for ur response
i chose the g1 video driver from the preference menu in the mplayer ,it's the best one working ,and i can now play video but it's so slow ,The movement of the shapes is so slow and it's hanging,can u help me

naufal (musp-student) said : #3

hello,
try open your player from terminal and post the result here.

idwidar (idwidar) said : #4

hello ,
thank u for ur help ,this is the output from opening mplayer in terminal

MPlayer 2:1.0~rc1-0ubuntu13.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Usage: mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
 -vo <drv> select video output driver ('-vo help' for a list)
 -ao <drv> select audio output driver ('-ao help' for a list)
 vcd://<trackno> play (S)VCD (Super Video CD) track (raw device, no mount)
 dvd://<titleno> play DVD title from device instead of plain file
 -alang/-slang select DVD audio/subtitle language (by 2-char country code)
 -ss <position> seek to given (seconds or hh:mm:ss) position
 -nosound do not play sound
 -fs fullscreen playback (or -vm, -zoom, details in the man page)
 -x <x> -y <y> set display resolution (for use with -vm or -zoom)
 -sub <file> specify subtitle file to use (also see -subfps, -subdelay)
 -playlist <file> specify playlist file
 -vid x -aid y select video (x) and audio (y) stream to play
 -fps x -srate y change video (x fps) and audio (y Hz) rate
 -pp <quality> enable postprocessing filter (details in the man page)
 -framedrop enable frame dropping (for slow machines)

Basic keys: (complete list in the man page, also check input.conf)
 <- or -> seek backward/forward 10 seconds
 down or up seek backward/forward 1 minute
 pgdown or pgup seek backward/forward 10 minutes
 < or > step backward/forward in playlist
 p or SPACE pause movie (press any key to continue)
 q or ESC stop playing and quit program
 + or - adjust audio delay by +/- 0.1 second
 o cycle OSD mode: none / seekbar / seekbar + timer
 * or / increase or decrease PCM volume
 x or z adjust subtitle delay by +/- 0.1 second
 r or t adjust subtitle position up/down, also see -vf expand

 * * * SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPTIONS AND KEYS * * *

naufal (musp-student) said : #5

hello,
when you want to open mplayer from terminal you must type input file,
example:
$mplayer /home/user/Shared/The simpson.mpg

I'm so sorry for my bad english

idwidar (idwidar) said : #6

hello ,
i opened the mplayer as u told me , the player opened with a blue screen without any video ,and this is the output displayed in the terminal,

idwidar@idwidar-desktop:~$ mplayer /media/sda7/films/1408/uni-1408.avi
MPlayer 2:1.0~rc1-0ubuntu13.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /media/sda7/films/1408/uni-1408.avi.
AVI file format detected.
VIDEO: [XVID] 606x256 24bpp 23.976 fps 796.8 kbps (97.3 kbyte/s)
Clip info:
 Software: Nandub v1.0rc2
SUB: Detected subtitle file format: subviewer
SUB: Read 798 subtitles.
SUB: Adjusted 23 subtitle(s).
SUB: Added subtitle file (1): /media/sda7/films/1408/uni-1408.srt
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Forced audio codec: mad
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 606 x 256 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.37:1 - prescaling to correct movie aspect.
VO: [xv] 606x256 => 606x256 Planar YV12
A: 482.1 V: 482.1 A-V: 0.007 ct: 0.033 11559/11559 4% 0% 2.1% 12 0

naufal (musp-student) said : #7

hello,
try to install Gstreamer extra plugins from Add/Remove Application
Applications ----> Add/Remove Applications
and search for:
Gstreamer extra plugins

hope this help...

fiftystorms (stormsg1) said : #8

I had the same problem. I couldn't play video (avi, kvcd, mkv) any video on any player (VLC, Winamp, WinDVD, WMP, and a couple others). Every time I tried, I might get a couple seconds of audio... sometimes... but definitely no video. Seconds later, I had a Dr. Watson. Actually it was a windows explorer has encountered a problem and must close immediately... do you want to send an error report... message.

The solution... It doesn't matter what media player that you are using... the one with all of the advanced codecs in it... your VLC or Mplayer or Winamp... if you messed with the settings in one of them, they all get screwed up. Set them back to their default, all of them, or one at a time until you hit the one you messed with. that'll fix it.

In my case, I had checked off all of the video filters in VLC media player. I forget what I was trying to accomplish a few days back, but I wanted to improve something. There was no immediate change to anything so I forgot that I had changed anything at all. A couple days later and I am pissed that I couldn't play any file. 3 days after that and I struck gold. problem solved. hope this helped somebody!

Can you help with this problem?

Provide an answer of your own, or ask idwidar for more information if necessary.

To post a message you must log in.