Google earth installs, but drops 7.10 back to login when I try to start it

Asked by John Hagerman on 2008-03-13

I have installed Google Earth in 7.10 from Synaptic and from Google's site and it installs either way without any problem. However, when I do Applications>Internet>Google Earth, the computer drops back to login. Username and password brings it back up, with the Home folder instead of my usual opening screen. Closing the Home folder takes me back to normal.
I once ran Google Earth on 7.04 with no problem, and I seem to remember running it in 7.10 before a recent full reinstall. Is there something I am not seeing, or am I missing something?

Jack

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
John Hagerman
Solved:
2008-03-29
Last query:
2008-03-29
Last reply:
2008-03-28
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

John Hagerman (handj949) said : #2

Gotcha, has it? Me too!

Jack

John Hagerman (handj949) said : #3

Hey, just solved my own problem!
When I did the OS reinstall, I forgot to start the NVIDIA Accelerated Graphics Driver. That's all it took.
I have to admit I remembered it because I was reading other questions about Google Earth and saw a mention of graphics card drivers.
For other folks with the same problem, that driver is accessed through Administration>Restricted Drivers Manager.
I'm a happy man!

Jack

agblat (agblat) said : #4

Thanks, John, that provides another avenue to getting Google Earth up and running.