attempt to fix screen resolution caused ubuntu to not login

Asked by piekea on 2006-12-02

Hi there,

I installed ubuntu successfully, but the highest screen resolution was 1024x768, and i ideally wanted 1280x1024, so after some searching around, i used the following:

"sudo dpkg-reconfigure xserver-xorg"

Before doing that however, i made a backup of the xorg.conf as xorg.conf_backup

after doing the sudo dpkg-reconfigure xserver-xorg, the logiin screen appeared, and it looks like its in the 1280x1024 like i wanted, but upon attempting to logon, it maked the screen go black and it then goes back to the login screen again.

What id really like is to be able to logon again and have the 1280x1024 resolution.

Advice is greatly appreciated.

Thanks,

James

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-02-17
Last reply:
2007-02-18
Matt Smith (mattsmith) said : #1

I know this may sound like a stupid question, but are you sure your monitor can handle 1280x1024? because to me that would explain the black-out. Also, are you using any propriatery graphics drivers?

Christoffer Karvonen (xopher) said : #2

There might be something in your (gnome-?)session that conflicts with the reconfigured X. Try logging in with a fresh session: Hold down CTRL+SHIFT when logging in. (http://www.collaborium.org/onsite/jos2000/related/guides/gnome/reset-session.html)

piekea (spam-kincell) said : #3

Hi there,

Thanks for the help,

My monitor is ok with 1280x1024 resolution, ive had both Windows and Mac OSX displaying on it at that resolution. 1280x1024 is the monitors native resolution.

The funny thing is, after I did those changes, the login screen does appear to be in 1280x1024 as it was 1024x768 before.
Ive just realised though, after a couple of tries to login, that when the blackout occurs, when it lasts a little longer, it gives my monitor the chance to display "out of range" for a fraction of a second, before goingback to the login screen again. My screen can handle 1280x1024 definatly.

I tried to login with a fresh session using CTRL+SHIFT when logging in, but I cant seem to be able to do it. Ive tried holding CTRL+SHIFT when pressing enter but that makes nothing happen, i tried holding them after pressing enter, also tried holding them all the time, but that doesnt seem to work either.

Ive tried all the different sessions in options on the login screen, only failsafe terminal works. I have a backup of the xorg.conf file so that could be restored in the terminal?

Many thanks for your help, greatly appreciated.

James

What make and model of video card does your machine have?

What make and model of screen are you using?

Chances are when you choose 1280x1024 Ubuntu is trying to drive the monitor at a refresh rate that the screen cannot cope with. It may need a little more delicate configuration than just the screen resolution. Once we know the make and model of video card and screen this may be easier to do.

piekea (spam-kincell) said : #5

The Video card is an onboard Intel 865G Chipset

The monitor is a Sony SDM - HS75P

The DVI input is 60hz and I use my Mac on that (at 1280x1024)

For my PC (with ubuntu on it) i use the analog VGA input, which is 48-75hz

Hope this helps!

Thanks,

James

Dave Walker (davewalker) said : #6

Hi James,

Are you still experiencing this problem?

piekea (spam-kincell) said : #7

Hi,

I would be if i still had the Ubuntu partition, although a got rid of it after a while of not being able to sort it : (

James

Dave Walker (davewalker) said : #8

James,

That is unfortunate, as you no longer require support on this matter - can you mark it as 'solved'.

if you decide to try again please re-open this support request - and we will be happy to help.

Can you help with this problem?

Provide an answer of your own, or ask piekea for more information if necessary.

To post a message you must log in.