“ffmpeg shared in Vivid” can't be installed under Vivid

Asked by Tong Sun on 2015-06-02

This is a question specifically for “ffmpeg shared in Vivid”
https://launchpad.net/~mc3man/+archive/ubuntu/ffmpeg-test1/+packages
but I can't change the project to it so I'm leaving with Distribution:Ubuntu.

I found that I can't install it under Vivid. The following is what I got.

How to get ffmpeg installed under Vivid?

Thanks

$ sudo apt-get update
...
Ign http://security.ubuntu.com vivid-security InRelease
Ign http://ppa.launchpad.net vivid InRelease
Get:1 http://security.ubuntu.com vivid-security Release.gpg [933 B]
Hit http://ppa.launchpad.net vivid Release.gpg
Get:2 http://security.ubuntu.com vivid-security Release [63.5 kB]
Hit http://ppa.launchpad.net vivid Release
Hit http://ppa.launchpad.net vivid/main amd64 Packages
Hit http://ppa.launchpad.net vivid/main Translation-en
Get:3 http://security.ubuntu.com vivid-security/main Sources [17.4 kB]
Get:4 http://security.ubuntu.com vivid-security/universe Sources [7,113 B]
Get:5 http://security.ubuntu.com vivid-security/main amd64 Packages [46.0 kB]
Get:6 http://security.ubuntu.com vivid-security/universe amd64 Packages [20.0 kB]
Hit http://security.ubuntu.com vivid-security/main Translation-en
Hit http://security.ubuntu.com vivid-security/universe Translation-en
Fetched 155 kB in 3s (41.2 kB/s)
Reading package lists... Done

$ sudo apt-get install ffmpeg
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ffmpeg : Depends: libavcodec-ffmpeg56 (>= 7:2.6.2-1~vivid) but it is not going to be installed
          Depends: libavdevice-ffmpeg56 (>= 7:2.6.2-1~vivid) but it is not going to be installed
          Depends: libavfilter-ffmpeg5 (>= 7:2.4) but it is not going to be installed
          Depends: libavformat-ffmpeg56 (>= 7:2.6.2-1~vivid) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ apt-cache policy ffmpeg
ffmpeg:
  Installed: (none)
  Candidate: 7:2.6.2-1~vivid
  Version table:
     7:2.6.2-1~vivid 0
        500 http://ppa.launchpad.net/mc3man/ffmpeg-test1/ubuntu/ vivid/main amd64 Packages
     7:2.5.7-0ubuntu0.15.04.1 0
        500 http://myown.archive.ubuntu.com/ubuntu/ vivid-updates/universe amd64 Packages

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 15.04
Release: 15.04
Codename: vivid

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Doug McMahon
Solved:
2015-06-03
Last query:
2015-06-03
Last reply:
2015-06-03

Contact the PPA maintainer to inform them of the issue

Tong Sun (suntong001) said : #2

Please elaborate on "how", as I've already explained that I can't change the project to it so I'm leaving with Distribution:Ubuntu.

Manfred Hampl (m-hampl) said : #3

What is the output of the commands

uname -a
lsb_release -crid
sudo dpkg --audit
apt-get --simulate libavcodec-ffmpeg56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56

Tong Sun (suntong001) said : #4

Thanks Manfred.

Here they are:

$ uname -rsvp
Linux 3.19.0-18-generic #18-Ubuntu SMP Tue May 19 18:31:35 UTC 2015 x86_64

$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 15.04
Release: 15.04
Codename: vivid

$ sudo dpkg --audit

$ sudo dpkg --audit | wc
      0 0 0

$ apt-get --simulate libavcodec-ffmpeg56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56
E: Command line option --simulate is not understood

$ apt-get --dry-run libavcodec-ffmpeg56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56
E: Command line option --dry-run is not understood

$ sudo apt-get --no-act libavcodec-ffmpeg56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56
E: Command line option --no-act is not understood

Tong Sun (suntong001) said : #5

$ sudo apt-get --simulate install libavcodec-ffmpeg56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libavcodec-ffmpeg56 : Depends: libfdk-aac0 (>= 0.1.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

Could switch to mencoder instead. Or mplayer...

Best Doug McMahon (mc3man) said : #7

It appears you my not have multiverse repo enabled. That is where libfdk-aac0 resides. Can be seen easily by example here -
apt-cache policy libfdk-aac0
libfdk-aac0:
  Installed: 0.1.3-1
  Candidate: 0.1.3-1
  Version table:
 *** 0.1.3-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/multiverse amd64 Packages
        100 /var/lib/dpkg/status

So enable multiverse in Software Sources > Ubuntu Software, reload sources & try again. Otherwise you could disable the ppa, reload sources & install the vivid version of ffmpeg which only offers ffmpeg native aac encoding, ie. the worst of all possible aac encoding options.

Manfred Hampl (m-hampl) said : #8

Sorry that I made the error of omitting the "install" parameter in my proposed command, but it seems that you were able to correct that yourself.

Doug apparently has spotted the root cause - the missing multiverse repository.

Tong Sun (suntong001) said : #9

Bingo! Thanks Doug.

Tong Sun (suntong001) said : #10

Thanks Doug McMahon, that solved my question.