Reset an application

Asked by Luis M.Jacinto on 2015-05-11

Ubuntu 12.04

After install QuitCount by mistake enter wrong data, now I find theres no way to edit or reset the data.
I uninstall and reinstall the application, when start the same wrong data is shown.
How to reset this application
Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2015-05-14
Last query:
2015-05-14
Last reply:
2015-05-12

Most likely there is a "hidden folder" with application data in it that you need to delete. You can view hidden files in Nemo (a file browser) by choosing "View->Show Hidden Files". If you are using different file browser such as Nautilus the procedure should be somewhat similar.

Locate the hidden folder for QuitCount and open it - delete all the files it contains. Then relaunch the application and you should be reset.

You can also do this using a terminal - Press Ctrl-Alt-T. Type the command ls -a and it should give a listing of all files and folders . The hidden files/folders will all begin with a period so most likely you will see a folder named .quitcount . If so then enter the command rm .quitcount/* .

Luis M.Jacinto (ljacinto) said : #2

Found Quitcount all over folders of File System but can't delete the files, I eventual uninstall with
Synaptic and now I have left 3 files one is quitcount.png second is quitcount_1.8-2_i386.deb and last
QuitCount (open properties, it says “desktop configuration file (application/x-desktop)”) click Delete
on these files nothing happens.
How can I delete theme?
Thank you

Manfred Hampl (m-hampl) said : #3

The general security concept of Unix allows modification on system files only by the root user.
On Ubuntu putting "sudo" in front of a command temporarily gives you administrative privileges.

What is the output of the terminal commands

sudo updatedb
locate --ignore-case quitcount

Luis M.Jacinto (ljacinto) said : #4

luis@luis-G41M-Combo:~$ sudo updatedb
[sudo] password for luis:
luis@luis-G41M-Combo:~$ locate --ignore-case quitcount
/home/luis/.cache/software-center/download-cache/screenshots.ubuntu.com_screenshot-with-version_quitcount_1.8-2
/home/luis/.cache/software-center/piston-helper/rec.ubuntu.com,api,1.0,recommend_app,quitcount,,c026b1476c686fe823a114f0fc39936c
/home/luis/.cache/software-center/piston-helper/rec.ubuntu.com,api,1.0,recommend_app,quitcount,,e3e8ccece81eb499d283a28fdacac4f5
/home/luis/.cache/software-center/rnrclient/reviews.ubuntu.com,reviews,api,1.0,reviews,filter,en,ubuntu,oneiric,any,quitcount,page,1,helpful,,0f26e5863fc04ce8b85071b600299dbd
/home/luis/.cache/software-center/rnrclient/reviews.ubuntu.com,reviews,api,1.0,reviews,filter,en,ubuntu,precise,any,quitcount,page,1,helpful,,59b0b190084432a34d94a02d1fd751ac
/home/luis/.config/quitcount
/home/luis/.config/quitcount/config
/home/luis/Ubuntu Help NEW/Reset QuitCount.odt
/usr/share/app-install/desktop/quitcount:quitcount.desktop
/usr/share/app-install/icons/quitcount.png
/var/cache/apt/archives/quitcount_1.8-2_i386.deb
luis@luis-G41M-Combo:~$

Best Manfred Hampl (m-hampl) said : #5

Your private configuration file for quitcount (that most probably contains the wrong settings is /home/luis/.config/quitcount/config

Start nautilus (the file explorer program), use ctrl-h to display also hidden files, navigate into the .config folder in your home directory and delete the whole quitcount subfolder.

This should remove your settings, and after new installation of quitcount you most probably start with standard vanilla settings.

The command to delete the config file from within a terminal is

rm -rf ~/.config/quitcount

Luis M.Jacinto (ljacinto) said : #6

Thanks Manfred Hampl, that solved my question.