How do you create a LiveUSB that doesn't require a CD?

Asked by Cerin on 2015-04-13

The current 14.04 ISOs can only be installed from CD.

Many modern computers no longer have CD drives, since booting from USB is almost universally supported.

The page https://help.ubuntu.com/community/Installation/FromUSBStick describes booting and installing Ubuntu from USB, but these instructions do not work with the current 14.04 ISOs.

If I use the Startup Disk Creator to take a 14.04 Ubuntu ISO and turn a 4GB flash drive into a bootable installer, it will boot, and I can start the installation, but after I confirm my keyboard, the installer will prompt me to enter the CD...which of course I won't have, causing the installation to fail. Since a 4GB USB drive is roughly a big as a DVD, and much larger than a CD, I'm not sure why the installer requires a CD.

Is this a huge bug in 14.04 or am I missing something?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2015-04-15
Last reply:
2015-04-15

No, you can't only install them from CD. Wherever you read that is wrong. You can use tools like unetbootin or the PenDriveLinux 1-2-3 installer to put the data onto the USB stick or even an SD card if your BIOS can boot that.

Did you MD5 test the ISO you downloaded?

Cerin (chrisspen) said : #2

I didn't read it anywhere, I discovered it first-hand. Try it yourself. Download a 14.04 server ISO then use the Startup Disk Creator tool in 12.04 to write it to a USB drive. Then try to install it on a computer. The installer will fail half-way, complaining that it can't find a CD.

And please don't recommend old obsolete third-party projects unetbootin. Have you tried them? I'm running unetbootin now. It only lists Ubuntu 11.04! Ubuntu's standard Startup Disk Creator has worked fine for past releases, but something changed in 14.04, and now it requires a CD.

Cerin (chrisspen) said : #3

And yes, I checked the md5 hash. The ISO was perfectly fine.

Manfred Hampl (m-hampl) said : #4

You can create a USB stick with unetbootin for any Ubuntu version when you enter the .iso file name besides the "Diskimage" radio button, see http://sourceforge.net/dbimage.php?id=300347

(Remark: I have not verified your main problem, telling that the 14.04 server .iso asks for a CD. Which version did you try, 32 bit or 64 bit? Please provide the full file name!)

I did try it myself. It's how I have installed all my Ubuntu's (Since Gutsy (Ubuntu 7.10) from 2007).

Also try the pendrivelinux 1 2 3 installer as well as unetbootin. You will need to format the storage to FAT32 first, then put the data onto the drive using your choice of tool.

Cerin (chrisspen) said : #6

I know how to write an ISO to a USB drive. That's not the problem. The problem is that the installer in ubuntu-14.04.2-server-amd64.iso requires a CD. Using unetbootin vs Startup Disk Creator vs PenDriveLinux doesn't matter. They don't change the installer on the ISO.

I just used unetbootin to write ubuntu-14.04.2-server-amd64.iso to a 4GB flash disk and ran into the same problem. The installer still requires the CD to proceed.

Manfred Hampl (m-hampl) said : #7

I just downloaded the ubuntu-14.04.2-server-amd64.iso file and installed a new server from in (in a VM) and I was not asked for a CD.
At what moment of the installation process to you get the prompt for a CD? What was the last successful question before?
What selections do you make when installing?
Does the system have network connection at the moment of being installed?

Cerin (chrisspen) said : #8

> At what moment of the installation process to you get the prompt for a CD? What was the last successful question before?

I think it was to confirm keyboard/language.

> What selections do you make when installing?

It happens for both the "Install Ubuntu" and "Rescue a system" options.

> Does the system have network connection at the moment of being installed?

Yes, internet is available. If I do the "Try Ubuntu" option, it has full Internet. I'm not sure how to test if the installer has the driver loaded for networking. The installer never asks about the network or prompts me.

Manfred Hampl (m-hampl) said : #9

Maybe you are referring to the window with the title "detecting hardware to find CD-ROM drives" as shown in the eighth picture of http://askubuntu.com/questions/340965/how-do-i-install-ubuntu-server-step-by-step ? The installer should continue, if does not find an optical drive.

If you want us to try reproducing your problem, you have to provide all steps that you execute (including the information on all your selections).

What kind of make and model is your system?

Cerin (chrisspen) said : #10

I have an optical drive, but there's nothing in it. I'm installing from a USB drive...not the CD/DVD drive.

My system is an Asus RS100-E7/PI2 (http://www.newegg.com/Product/Product.aspx?Item=N82E16816110061). Pretty simple hardware. Two network jacks. I tried booting with each and the result is the same.

I used all the defaults. I basically just hit "enter" until the problem occurred...but here at the exact steps.

From the unetbootin splash screen:

1. Install Ubuntu Server
2. Select a language => English
3. Select your location => United States
4. Configure keyboard => no
5. Configure the keyboard => English (US)
6. Configure the keyboard => English (US)

Now it gives me the message:

    Detect and mount CD-ROM

    Your installation CD-ROM couldn't be mounted. This probably means that the CD-ROM was not in the drive. If so you can insert it and try again.

    Retry mounting CD-ROM? Yes/No

Selecting Yes results in the same screen...because there's no CD in the drive.

Selecting No results in the message:

    An installation step has failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Detect and mount CD-ROM

Since I'm installing from a LiveUSB, isn't this a bug? Why would a LiveUSB require the CD under any circumstances?

How do I report this as a bug? Launchpad seems designed to make it nearly impossible to report a bug without ubuntu-bug...and since this is an installer issue, I can't run ubuntu-bug.

http://ubuntuforums.org/archive/index.php/t-1369628.html

Seems unetbootin is the cause. Make the installer media using the PenDriveLinux 1-2-3 installer. There is also a command to run in a different Type while the installer is moaning. Seems that the installer still looks for files in /cdrom

Cerin (chrisspen) said : #12

No, unetbootin is not the cause. Please stop saying this. And no, I will not use a Windows program to make a Linux LiveUSB.

OK then you can use dd to spit the file to the USB stick.

Assuming the USB stick is /dev/sdz

sudo dd if=~/Downloads/filename.iso of=/dev/size bs=1M

Will put the ISO onto the USB storage. Your device will be different. Use:

sudo fdisk -l

To see which yours is.

Obviously change the input file location and name too.

Can you help with this problem?

Provide an answer of your own, or ask Cerin for more information if necessary.

To post a message you must log in.