Problem with graphics card driver - Radeon 1650

Asked by yorganfoogy on 2008-03-05

Hi, I just recently intstalled Ubuntu. As soon as I booted up, I downloaded all of the ubdates it said that there was. It also said that there was a restricted driver that I could use for my graphics card. So, I checked the box and it installed the driver. Then I rebooted my computer like it said. However, once it got past the Ubuntu progress bar thing, it just went to a black screen. So, I completely re-installed Ubuntu 7.10, thinking that it was just corrupt. This time I DIDN'T install the updates, but I DID install the graphics card driver and rebooted. It did the same thing, so I'm guessing there is a problem with that driver.

Is there a different way to install the drivers, or is it possibly detecting the wrong driver? I mean, I want to play some games through wine, but I obviously can't do that without enabling the graphics card driver. What's wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier
Solved:
Last query:
Last reply:
Revision history for this message
yorganfoogy (yorganfoogy123) said :
#1

Actually, I was wrong. It's not Radeon 1650, it's 1600. Can't anyone help?

Revision history for this message
Olivier (olivier-lacroix) said :
#2

Hi !

Could you be more precise on the model of your card ?

entering lspci in a terminal may help you get the exact model

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#3

Hi.

Under the graphics card, here is everything it said:

ATI Technologies Inc RV530 [Radeon X1600] (Secondary)

Also, I've more recently tried the direct download from the ATI website, and a manual download of the driver through the terminal. They both did the same thing.

Revision history for this message
Olivier (olivier-lacroix) said :
#4

OK. I was to tell you to get the newest possible fglrx driver but if that fails, let's try an other one.

Add that line to the file /etc/apt/sources.list

deb http://ppa.launchpad.net/tormodvolden/ubuntu gutsy main

you can do that by entering in a terminal

sudo gedit /etc/apt/sources.list

or, if you are stuck without graphical interface, switch to a console using crt+alt+F1

and open the file with

sudo nano /etc/apt/sources.list

save and close.

reload package list. and install xserver-xorg-video-radeonhd

open the file /etc/X11/xorg/conf
and change the driver line saying "fglrx" in "radeonhd"

save and close. you're good to go !

Tell me if you need more precise instructions.

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#5

Hi.

I was confused about which line(s) I change in xorg.conf and what I change those line(s) to. I just don't want to try anything before I know for sure. I've done everything else before that.

Thanks~

Revision history for this message
Olivier (olivier-lacroix) said :
#6

Ok. Search for the device section of the xorg.conf file. See the exerpt of mine below

Section "Device"
        Identifier "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
        Driver "fglrx"
        Busid "PCI:1:0:0"
EndSection

and transform it in

Section "Device"
        Identifier "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
        Driver "radeonhd"
        Busid "PCI:1:0:0"
EndSection

Of course, leave your identifier and Busid identical to yours.

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#7

This is what I have:

Section "Device"
 Identifier "Generic Video Card"
 Driver "vesa"
 BusID "PCI:1:0:0"
EndSection

so I need to make it into

Section "Device"
 Identifier "Generic Video Card"
 Driver "radeonhd"
 BusID "PCI:1:0:0"
EndSection

this?

Revision history for this message
Olivier (olivier-lacroix) said :
#8

exactly !

Tell me how it goes

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#9

Didn't work... when I restarted it went into "Low Graphics Mode"

Any other ideas? If not, that's alright. I mean, it's certainly functional, and everything SEEMS to be displaying correctly. It wouldn't be too bad if I had to dual boot with Windows in order to play games.

Revision history for this message
Olivier (olivier-lacroix) said :
#10

weird... Try to add thoses lines at the end of the xorg.conf file

Section "Extensions"
Option "Composite" "Off"
EndSection

Section "ServerFlags"
Option "AIGLX" "Off"
EndSection

Revision history for this message
Olivier (olivier-lacroix) said :
#11

the driver you are currently using, vesa, is not aperformant driver. It's only a fallback driver. So using any other driver will bring you better performance.

Please post here the /var/log/Xorg.0.log.old and /var/log/Xorg.0.log files.

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#12

Well, what you just told me to do didn't work - Low Graphics again. And you want me to post two entire files in a message?

Revision history for this message
Olivier (olivier-lacroix) said :
#13

Yeah. Providing an attachment would be better... but there is no way to do that in the question section of launchpad. If you can, provide an external link to those files. Otherwise, at least post them in two different messages.

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#14

Oh wow... I just looked at them. They're gigantic. Would you mind if I put them up on Megaupload?

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#15
Revision history for this message
Olivier (olivier-lacroix) said :
#16

Hum... There is nothing about radeonhd in there... One is about successfully loading the vesa module, and the other one is about going back to the failsafe mode and therefore... loading vesa.

Could you try to get a log where Xorg tries to load the radeonhd driver ? I have no real idea on how to proceed since I don't really know how the failsafe mode works.

look for the word RADEONHD in the /var/log/X* for instance using the command

cat /var/log/Xorg* | grep RADEON and attach the relevant file.

Please also attach your xorg.conf file

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#17

I'm sorry I'm being so much trouble. I have never done anything in Ubuntu and, frankly, I have no idea what you just said after the first couple of sentence. How would I go about getting a log like that? the last three lines I'm just completely lost about. I'm sorry... I guess everyone has to start somewhere.

Revision history for this message
Best Olivier (olivier-lacroix) said :
#18

OK. didn't realise you were new to this, since you were doing pretty well so far :-)

There are various Xorg (the graphic server, ie the thing that fails here) log in the folder /var/log , all begining with Xorg. <something>

The problem is when Xorg fails to launch, gdm (the connexion manager) relaunches it in failsafe mode. And as a result, the relevant logs are lost... which prevents from knowing what failed.

Since the failsafe procedure is coded in gdm, we are going to shut it and the graphical server "by hand". To do that, you are going to switch to a Terminal, using the combo CTRL+ALT+F1 . (you have 7 virtual screens available in linux by default : 6 terminal and one for the graphical server. you can switch between them using the combo I mentionned and replacing F1 by F2, F3... F7)

So you have a nice terminal in front of you. Not really userfriendly but you don't have really the choice :-)

log in and enter the following

sudo killall -9 gdm

now gdm is off. then enter

startx

(with the radeonhd driver selected in the xorg.conf)

this should fail. but the failure will be dumped to a log file, which is what we are looking for.

You should get the prompt back. Save the log to a file entering

cat /var/log/Xorg.0.log > log.txt

restart gdm entering

sudo /etc/init.d/gdm restart

you should get into failsafe mode, and be able to log in. You will find the relevant log in the file log.txt in your home folder. Upload that file you had a hard time harvesting to megaupload and give me the link.

Revision history for this message
Olivier (olivier-lacroix) said :
#19

I hope I have been clearer. Don't forget to have the radeonhd driver selected in the xorg.conf file before launching startx !

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#20

Thanks a lot. That was a lot clearer. Really, I'm pretty good with computers (I've run XP for a while), but all this is pretty new to me. Thanks for being patient.

Anyway, here's the link http://www.megaupload.com/?d=WDSI4MK0

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#21

Wow! I don't know what happened but I think my problem is fixed!!

I had just installed some updates and my computer needed a restart. So I did it but then realized that I hadn't changed the conf file back to vesa, and I thought it would just crash, but it didn't! It actually started up and everything looks a whole lot different, so I think the driver worked! I don't know what happened...

So thanks a lot for your help, something we did in this whole process fixed it (and I also learned quite a bit about Ubuntu). Thanks!!!

yorganfoogy~

Revision history for this message
yorganfoogy (yorganfoogy123) said :
#22

Thanks Olivier, that solved my question.

Revision history for this message
Olivier (olivier-lacroix) said :
#23

Great !

Just for info, you have 2 options to make your graphic card run :

  - fglrx : the restricted driver from ATI. Your first attempt failed, maybe now it won't ?

  -radeonhd : the new opensource driver resulting from the move towards more open development from ATI. This driver lacks many features since it is in its early stage of development. No 3D games with that one, sorry. But that should change during this year.

I never had great experience with the closed source driver, even if big efforts have been made to improve it : suspend/resume issues, poor speed for unknown reasons on my hardware... So, I think you are better rebooting sometimes in windows to play and stick with the radeonhd driver. But the choice is of course yours.