WiFi not working on a Fujitsu-Siemens AMILO Pro V3505 laptop

Asked by sopsys on 2006-11-29

I removed the edited question, because someone was asking for help with WinXP Pro. (S)He also changed the distribution into BOSS from Ubuntu.

If you have the old question, feel free to copy & paste it here.

This question can also be removed, as it's obsolete by now as for the newest BIOS update for the laptop.

- Aleksi

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Patrice DUROK
Solved:
2009-04-06
Last query:
2009-04-06
Last reply:
2008-11-30
sopsys (sopsys) said : #1

Here's some information from the wireless card based on lspci -v output:

04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
        Subsystem: Intel Corporation Unknown device 1001
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d4000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [c8] Power Management version 2
        Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [e0] Express Legacy Endpoint IRQ 0
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number XX-XX-XX-XX-XX-XX-XX-XX

To see if the IPW3945 is supported by your kernel:-

$ grep IPW3945 /lib/modules/`uname -r`/build/.config

On my (Ubuntu Feisty) machine which is running kernel 2.6.19 I see this as the result:-

CONFIG_IPW3945=m
# CONFIG_IPW3945_DEBUG is not set
CONFIG_IPW3945_MONITOR=y
CONFIG_IPW3945_PROMISCUOUS=y

I don't know if the kernel you are using supports it, if so, then yay, if not then there is your problem. If it does support it (you see something like what I get) then it could be missing firmware? The home page for that driver is below, and has a download for the firmware.

Interestingly here's the package I would expect the kernel to be in (again remember I have a newer kernel than you on this box):-

alan@wopr:~$ dpkg -l linux-restricted-modules-`uname -r` | grep ^ii
ii linux-restricted-modules-2.6.19-5-generic 2.6.19.1-1 Non-free Linux 2.6.19 modules on x86_64 generic

Lets see if that package has any files with 3945 in the name:-

alan@wopr:~$ dpkg -L linux-restricted-modules-`uname -r` | grep 3945
/sbin/ipw3945d-2.6.19-5-generic

Ooo, lets see what that file is:-

alan@wopr:~$ file /sbin/ipw3945d-2.6.19-5-generic
/sbin/ipw3945d-2.6.19-5-generic: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), for GNU/Linux 2.6.9, stripped

http://ipw3945.sourceforge.net/ looks to be the driver for that device.

Tim Rietmann (tsr-the-truth) said : #3

Hi Eetu,

many Linux users have been having problems with their WiFi kill switches. Some dirty fixes for this issue that might also work for you are:
- disable the swtich in your BIOS, if possible
- always boot with the WiFi switch being ON

Of course, Alan's guess that your ipw3945 driver is not working correctly, might be the cause of your problem as well. But if you are using the current default Kernel that comes with Ubuntu 6.10, this seems unlikely.

sopsys (sopsys) said : #4

This same problem has happened with every ubuntu version from 5.10 to 7.04.
And i'm using feisty ATM.

Also, i tried the method you suggested in your answer, to disable the switch, but all it did was disable the whole wifi chip, so that didn't help.

sopsys (sopsys) said : #5

i also had exactly the same driver installed, wifi should work if the kill button is overridden. I think that the problem is with this laptops MB, not the wifi card.
If i remember right, it was not working on windows vista neither, just with xp (the original install)

Tim Rietmann (tsr-the-truth) said : #6

Eetu,

I'm sorry that my input did not help you solve your problem. Since I don't own a Laptop that matches your hardware configuration, I am not sure whether I am either not qualified to answer to your question, or whether this is a new topic that requires clarification within the community.
If the latter is the case, then I'm sure the community would greatly appreaciate any new insights that you might stumble upon.

- Tim

sopsys (sopsys) said : #7

If anyone else is able to help me, i would be appreciated. Thanks in forward.

Hi all,
I'm having the same problem.

This is my card:
04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
        Subsystem: Intel Corporation Unknown device 1001
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d4000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [c8] Power Management version 2
        Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [e0] Express Legacy Endpoint IRQ 0
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number a7-a3-75-ff-ff-de-18-00

With NDIS:

andrea@kubra:~$ ndiswrapper -l
Installed ndis drivers:
w39n51 driver present, hardware present

This is whit the original Fujitsu-Siemens Windows
XP drivers and it does not work since the rf_kill is
allways on even with this driver.

With ipw3945 driver:

From dmesg:

[ 3582.408000] ieee80211_crypt: registered algorithm 'NULL'
[ 3582.420000] ieee80211: 802.11 data/management/control stack, git-1.1.13
[ 3582.420000] ieee80211: Copyright (C) 2004-2005 Intel Corporation <email address hidden>
[ 3582.464000] ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux, 1.1.3mp
[ 3582.464000] ipw3945: Copyright(c) 2003-2006 Intel Corporation
[ 3582.464000] ACPI: PCI Interrupt 0000:04:00.0[A] -> GSI 17 (level, low) -> IRQ 16
[ 3582.464000] PCI: Setting latency timer of device 0000:04:00.0 to 64
[ 3582.468000] ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection
[ 3584.412000] ipw3945: Radio Frequency Kill Switch is On:
[ 3584.412000] Kill switch must be turned off for wireless networking to work.

root@kubra:~# /sbin/ipw3945d
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.22
Intel PRO/Wireless 3945ABG Network Connection found at:
 /sys/bus/pci/drivers/ipw3945/0000:04:00.0
Daemon launched as pid 14034. Exiting.

I'm sure it's a BIOS BUG.

bye,
Andrea

P.S.
it's a Fujitsu-Fiemens AMILO Pro V3505
and I'm using the latest BIOS (A0V).

bye,
Andrea

Tested also with BIOS B0E,
and it does NOT work.

BIOS B0E:
Solved problems:

- modify cardbus register to fix some 1394 pc-card not work issue.
- support pc-beep for new codec alc0861d.
- support pentium t2060 cpu.
- support vista fast resume solution.
- BEFORE LOGIN WINDOWS, BIOS WILL STILL TAKE RESPONSIBILITY OF WIRELESS
  LED CONTROL.
- support audio codec alc861-c and alc861-d.
- support vista
- system hung up if reboot after resuming from s3.

It make me dream, but I was wrong...

bye,
Andrea

Patrice DUROK (karmaplc) said : #11

Hi Andrea,
It works on my Amilo Pro V3505 with BIOS B0E (08.01.2007).

No, it does not work on my 3505...

Tell me something more:

driver version?
firmware?
distro?
what can I do to turn off rf_kill?

I'm using firmware 1.14.2 with daemon 1.7.22 on Feisty.
Kernel 2.6.20-6-generic from feisty.

But is the same with all driver/daemon/firmware
and with some custom kernel...

Are you using Windows to turn off rf_kill and then using it under
Linux after an hot reboot?

Tell me more, please!

bye,
Andrea

Best Patrice DUROK (karmaplc) said : #13

Hi,
I turned off rf_kill and updated the bios in Windows.
During the POST, I saw that the Wifi LED was on. I logged in Ubuntu with my wifi connection active.
I use kernel 2.6.17-10-generic from edgy eft, firmware 1.14.2 with daemon 1.7.22.
It even worked with an Ubuntu edgy live cd.
I didn't test Feisty yet.
Hope it will help, bye.
Patrice

ok, i tried on the 3505 of a friend and
it work, and i will try on mine soon...

but it require Windows, and this is a BIG
problem since I don't have windows at all...

bye,
Andrea

Now it work with Linux, even if I power off my laptop (and I remove the battery/cable to ensure a cold reboot): it seems that the wifi card (or the bios) remember that Windows turned off rf_kill.

I used an harddisk with Windows from another 3505 and I used it only one time.

So, I'm not too happy but... Windows repaired my hardware!

For every one that have only Linux: You must use Windows at least one time, or you can't use your wifi card.

What a bad news...

bye,
Andrea

I have the same Laptop Amilo Pro 3505 and I've just installed Ubuntu 6.10 from a disk I downloaded and burnt today. I was suprised to see that the WiFi is not on by default! I'm still confused and need some hand holding whilst I get my head round linux.

I had thought it would just be a case of entering my wep key - but I can't work out where to go to do that properly either. Argh! I took a look in Network Settings and Found Wireless there - tried to set it up but no joy. Could it be a rf_kill thing - or whatever?!?

could someone talk me through it step by step? noob style
please?!

as I said before it work, but
you need some special practice:

1) update your BIOS to version B0E, here:
    http://support.fujitsu-siemens.com/com/support/downloads.html

2) enter the BIOS and set the default status for wifi to ENABLED.

3) boot with windows, torn on the wifi and do an hot reboot.
    NOTE: Windows should be the original one that come with the 3505...

It should work.

If it work now it will work even after a power cicle, but some time
you may need to come back to windows to wake up the WiFi card...

bye,
Andrea

Hmm - I've tried that and I still have no Wireless...

The wifi light is on - but I don't see the wireless Lan bars icon to say that there are networks nearby.

I'm not sure that I've got the settings right in networking settings? - my wep key I'm not sure whether to put Ascii or hex

Under windows it just works! eek!

Any advice? Thanks for the help so far

Goran Popov (goranpop) said : #19

Hi all,
I have Ubuntu 7.04, BIOS BOF, Amilo Pro V3505.
Solution to this problem is to download Acer Hotkey driver for Linux:
               http://www.cakey.de/acerhk/

Build it

modprobe acerhk

echo 1 > /proc/driver/acerhk/wirelessled

and it work.

I didn't try to use it but the led turned on and
network adapter shown on

Robert Sicoie (robert-sicoie) said : #20

Hello,

Goran's solution works for me on Ubuntu 7.10, Amilo Pro V3505.
Thanks,
Robert

andreajordan (andreajordan) said : #21

Ho letto nelle risposte ma... non trovo il mio caso: Installato linux in dual boot sul mio amilo pr v2000 con wi-fo Intel pro wireless2200bg. Ho scaricato e installato i driver per linux, la sch wifi mi si accende all'avvio di windows (enabled da bios ) ma se carico linux non da segni di vita e non me la vede.,

Trond Thorbjørnsen (tthorb) said : #22

Goran Popov's solution worked for me as well.

Robert Sicoie (robert-sicoie) said : #23

Now I am able to turn on wireless but I cannot turn it off without rebooting.
I tried

echo 0 > /proc/driver/acerhk/wirelessled

and

modprobe -r acerhk

but wireless was still working.
Wireless on/off button isn't working.
Does anyone of you solved this issue?
Thanks.

Goran Popov (goranpop) said : #24

Try to load fsam7400 modul:

modprobe fsam7400
#start
echo 1 > /proc/driver/wireless/radio

#stop
echo 1 > /proc/driver/wireless/radio

It's software killswitch for F-S Amilo laptops and compatible.

Goran Popov (goranpop) said : #25

Sorry ,stop is:
echo 0 > /proc/driver/wireless/radio

It work on Ubuntu 7.10, BIOS BOF, Amilo Pro V3505

Try to see /var/log/syslog

bq (balique) said : #26

For my amilo pro v3405, i simply have to go to windows and enable/disable the wifi.
Then this state stays until the next change (in windows again).
So the wifi works fine, only you have to enable it.

I was able to make the wireless work from linux, not through the button.
1. Install the acerhk module.
2. load the module ( sudo modprobe acerhk ).
3. in shell write ( echo "on" >> /proc/driver/acerhk/wirelessled )

and the wireless will turn on, I well try to porte the Amilo Pro v3505 hotkeys to acerhk.

Allan Nordhøy (comradekingu) said : #28

I got it to work on a fresh ubuntu 8.04 install, then when i updated the kernel it was gone again.
Going back to the old didnt do the trick, nor did a reinstall.
The solution lies in the Bios version, because the killswitch button does not work.
This was confirmed by trying another card known to work.

Solution:
I was able to get it to work with the latest firmware (B0G)
Its available from fujitsu-siemens http://support.fujitsu-siemens.com/Download/ShowDescription.asp?SoftwareGUID=7F5DC06C-7C41-453C-A791-2D9039BB73FA&OSID=665F4A20-6E31-43C3-82C2-D98CE773007C&Status=True&Component=Flash%20Bios%20for%20AMILO%20Pro%20V3505
Dont worry about the XP category selection, BIOS is the same regardles of OS.
Burn .ISO to disk and boot. Press F12 to select CD during post.
Write "FLASH" when prompted.

gilrim (jsl-elvenhome) said : #29

I've got a 3505, running 8.10 b1.
At and after install, the wireless worked perfectly, with good throughput and no problems whatsoever. after a update yesterday, it stopped working. I've tried loading acerhk (it wasn't before), to dis-/en-able the wirelessled, but that made no difference whatsoever.
I don't have a clue as to what part have changed that should do this, but its not working now at least.

Allan Nordhøy (comradekingu) said : #30

Thats what happens on 8.04. I imagine the same goes for 8.10. Update the BIOS like i described earlier in the thread.

gilrim (jsl-elvenhome) said : #31

I've already updated to B0G a while ago, so that's not what's causing this issue.
interesting bits from lshw
*-firmware
          description: BIOS
          vendor: Phoenix Technologies LTD
          physical id: 0
          version: R01-B0G (04/27/2007)
          size: 104KiB
           *-network DISABLED
                description: Wireless interface
                product: PRO/Wireless 3945ABG [Golan] Network Connection

sopsys (sopsys) said : #32

Thanks Patrice DUROK, that solved my question.