[hardy] Gnome doesn't start - brown screen and cursor but nothing else

Asked by Caroline Ford on 2008-02-28

Binary package hint: gnome-panel

Hardy locked up so I restarted. Now gnome will not start unless I choose fail safe settings. I get a brown screen and a moving mouse cursor but nothing else. CTRL-ALT-1 gives me a terminal and CTRL-Backspace restarts X. However I cannot get any further without running in failsafe mode.

If I run top from a terminal very few processes are running. None of evolution is - I have the bug where evolution-data-services consumes 100% CPU. That bug hasn't caused gnome to fail before though.

I have a broken package - onboard (which fails with a python error) if this is connected.

ProblemType: Bug
Architecture: i386
Date: Thu Feb 28 15:07:20 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/yelp
Package: yelp 2.21.90-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
SourcePackage: yelp
Uname: Linux 2.6.24-8-generic i686

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Caroline Ford
Solved:
2008-03-01
Last query:
2008-03-01
Last reply:
2008-03-01
Caroline Ford (secretlondon) said : #1
Caroline Ford (secretlondon) said : #2

This is nothing to do with yelp - I used "report a problem" in yelp as I couldn't find one connected to gnome-panel.

i'm using metacity (my hardware doesn't run compiz).

Gnome-panel has changed today as I no longer yet a software updates icon, the pop up box thing doesn't point at anything, just a divider. Also my gnome-power-manager icon is now on all the time, showing a battery that is discharging but the text says it at 100%.

gnome-panel 1:2.21.92-0ubuntu1
gnome-power-manager 2.21.93-0ubuntu1

onboard 0.87 (latest version won't install)

Sebastien Bacher (seb128) said : #3

Thanks for your comments. This does not appear to be a bug report as such. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. http://launchpad.net/support

Caroline Ford (secretlondon) said : #4

The bug is that gnome doesn't start. I don't know what information I can provide - there is nothing in debugging procedures that seemed relevant.

I'm still running in failsafe mode and I haven't changed anything.

What answer would I want from the support tracker?

Caroline Ford (secretlondon) said : #5

making my bug invalid so I can convert to a question.

I still think this was handled *very* badly. That message was downright rude.

Caroline Ford (secretlondon) said : #6

I have been told my bug is actually a support request - I would hope as a member of the bug squad I would know the difference..

I can't login to gnome any more - something has changed, I'm guessing with a recent update.

It's not obviously a problem with X, X restarts fine and the cursor moves. The machine isn't locked up and I can get a terminal by alt-ctrl-1.

I can start gnome by using the failsafe option.

Robert Di Gioia (digioiar) said : #7

Hi

Sounds like the lockup may have messed up your X config...

In a terminal window, type the following command to reconfigure X. As long as you're not running a special video driver, you should be able to use the defaults. If you use a special driver, tell it which one you want it to use and let the others items remain at the default.

sudo dpkg-reconfigure xserver-xorg

Good luck

peter b (b1pete) said : #8

hello Caroline Ford,

just a question, why use Hardy? the way I understand, it is still in alpha stages; beta will be released by the end of march. for sure you know what alpha means.

did you try the current Gutsy release? I'm certain that you will not face the type of problems described. just let us know if you encounter similar problems with Gutsy should you decide to use it.

regards,

peter b

Caroline Ford (secretlondon) said : #9

Why use hardy - because I'm a bug triager and reporter. I've been using hardy since alpha 3. My use of hardy allowed me to discovered loads of bugs (now fixed) and to confirm loads more!

This problem has cleared up - I think as a result of an upgrade. I suspect it may be connected to bug #151536, as evolution data services generally uses 100% of my CPU unless I attach gbd to it!

When gnome wouldn't load it was notable that eds wasn't running.

It could be solved by any of the updates since I reported it. I don't think it is an X problem as gdm loaded, gnome-session?

peter b (b1pete) said : #10

As you probably know, gnome-device-manager will, hopefully, be integrated in ubuntu hardy rel. for the first time replacing the hal-device-manager. no doubt this is a major undertaking that will affect other areas; to effectively manage the hardware not only displaying it is quite a task; this new device mgr for sure will have to interact with X or vice versa and, as you know, X was working .... well, as it was working .... I don't want to enter into that. now, to pinpoint in this environment what specifically causes a problem is a very hard nut to crack so to speak, why? because all details necessary 'to crack it' are not at my disposal.

no doubt, your contribution to this effort by testing the new os while in alpha stages is to be commended. my approach on the other hand is to let the architects/developers 'tie' all the pieces the best they can and after beta release do some testing, report bugs and do support on various forums which, in my case is a very satisfying experience. why this approach? I'm not in the 'thick of things' so to speak in the development stages -there are other people much more qualified that do these things for living which is not my case.

by the way, re your 100% use of CPU resources, just a comment, even in Gutsy amd64 firefox is still using both CPU's at close to 100% when flash installed -now, question, which package/library/update causes this? there's no doubt that one of the latter does this, which one? I couldn't get to the bottom of this one yet, still working on it.

regards,
peter b