How to remove qt-ap-spi

Asked by Luis M.Jacinto on 2014-11-07

Ubuntu 12.04
I
How to remove the package qt-ap-spi ?
Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-11-09
Last query:
2014-11-09
Last reply:
2014-11-09

sudo apt-get --purge remove qt-ap-spi

or use software centre...

Luis M.Jacinto (ljacinto) said : #2

Following your suggestion, Terminal result:
is@luis-G41M-Combo:~$ sudo apt-get --purge remove qt-ap-spi
[sudo] password for luis:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package qt-ap-spi
luis@luis-G41M-Combo:~$

I look everywhere for qt-ap-spi
 but cant find it.
This come about from Thread #257100 which I never had a answer, I was advised to upgrade to Librecad 2.0.6. I did this but the gremlin continued, then was advised to
sudo apt-get --purge remove qt-ap-spi
. After I tried on Terminal “librecad” the result was this:
 Open Terminal enter “librecad” it open with error in terminal but I carry on on saving file it close again sending result of Terminal it might help.
 luis@luis-G41M-Combo:~$ librecad
RS_DEBUG::setLevel(3)
RS_DEBUG: Critical
RS_DEBUG: Errors
RS_DEBUG: Warnings
Got bus address: "unix:abstract=/tmp/dbus-O7dlqekdI5,guid=a610166aaed5b8adc8e17e040000001d"
Connected to accessibility bus at: "unix:abstract=/tmp/dbus-O7dlqekdI5,guid=a610166aaed5b8adc8e17e040000001d"
Registered DEC: true
Registered event listener change listener: true
QSpiAccessible::accessibleEvent not handled: "8008" obj: QObject(0x0) " invalid interface!"
QSpiAccessible::accessibleEvent not handled: "8008" obj: QSidebar(0xb7de550, name = "sidebar") "sidebar"
FIXME: handle dialog start.
QSpiAccessible::accessibleEvent not handled: "8008" obj: QObject(0x0) " invalid interface!"
Interface is not valid
ASSERT failure in : "Got an update for an invalid inteface. Investigate this.", file atspiadaptor.cpp, line 899
Aborted (core dumped)
luis@luis-G41M-Combo:~$

As I have another HD with Ubuntu 14.04 install LibreCad and tried the same file save and it work
perfectly.
I hope this will help
Please can you help to fix this.

Manfred Hampl (m-hampl) said : #3

I cannot find any information about an Ubuntu package "qt-ap-spi". Maybe this is a typo error and should read "qt-at-spi"?

Manfred Hampl (m-hampl) said : #4

In https://bugs.launchpad.net/ubuntu/+source/qt-at-spi/+bug/998012 the instructions is to remove qt-at-spi not the inexistent qt-ap-spi.

Try

sudo apt-get purge qt-at-spi

Luis M.Jacinto (ljacinto) said : #5

Apologize for the qt-ap-spi.
Following your suggestion I can now save the files it is working properly.
Thank you.

Please mark the question as solved

Thanks

Luis M.Jacinto (ljacinto) said : #7

Thanks actionparsnip, that solved my question.