Charset problem with iso

Asked by Will J.B. Hus


First, I find Ubuntu by far the best of the many distros I tried.
But: as my (almost former) Windows-work depends on a correct internationalization, I can't accept that Ubuntu/nautilus is unable to read a correct Windows directory-listing (using Gnome). The accented characters are gone and appear as "?". Surely, this will affect other programs too, e.g. MySQL.
I found out that only UTF-8 charmaps are installed, whereas my Windows uses either iso8859-1 or iso8859-15.
I tried correcting things in fstab, but the problem lies not there.
How do I convince Gnome to use nl_NL_iso8859-15 with euro?


Will J.B. Hus

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

Revision history for this message
Will J.B. Hus (wjbhus) said :

I found the solution! All commands in terminal-window.

  sudo dpkg-reconfigure locales

a list appears, but it is impossible to select a new charset (bug?), so copy the exact name of the charset. Cancel/exit the script.

  sudo gedit locale.gen >> add the name of the charset >> save and exit.

  sudo locale-gen >> the charsets are initialized

  sudo gedit smb.conf >> change for the Windows-partitions "UTF8" to "iso8859-15" (or your local charset) >> save >> close >> done!

Revision history for this message
Will J.B. Hus (wjbhus) said :

Well, this worked while I stayed logged-in. But the next day trouble again! I thought my solution would do the job, but this time it didn't. So, I'm unable to open Windows-files or to play music-files containing "exotic" (but utterly normal European) characters. Strange, but OpenOffice imports my files with those characters correctly (provided that their file name doesn't have them!).

Revision history for this message
Manu Cornet (lmanul) said :

Why is it impossible to select another charset while doing "sudo dpkg-reconfigure locales" ? What happens exactly ?

Revision history for this message
Will J.B. Hus (wjbhus) said :

In the list of the dpkg-reconfigure script iso8859-15 figures without asterisk. But it is/seems impossible to set an asterisk. So I added the name of the charset manually to the locale.gen file and then ran locale-gen. This time I could select the iso charset. Opening the script without running gave an asterisk at the charset! I added iso8859-15 to the Windows partitions in fstab. Now I could read the Windows filenames AND OpenOffice read my Windows files correctly. But now the language of the Gnome desktop appeared in English though my local language still is Dutch nl_NL. I set back the charset to UTF-8 and my desktop was OK. OpenOffice still reads my files correctly, but Nautilus refuses to do so and gives "invalid encoding" to the filenames with "foreign" characters. I understand that is possible to internally translate iso to UTF-8 without the intervention of the user. But how?
I think that this issue is very important (not only for my sake!), as Ubuntu is meant for the whole world (that is what I hope!). I think your formula will save the world from an ugly monopoly and your distribution is able to satisfy both the migrants and/or beginners, and the technically more informed power user.

Revision history for this message
Kuba (kuba-xpl) said :

I have the same problem with ISO8859-2. OpenOffice2 opens files correctly but than writes them with different coding. This is surely a bug.

Can you help with this problem?

Provide an answer of your own, or ask Will J.B. Hus for more information if necessary.

To post a message you must log in.