boot failure but not a new instalation

Asked by Plumtree on 2008-02-25

Has been running well for months. Today we cannot boot 7.10 on dual boot with windows.

It seems to hang here;

[260.536137] hub 1-1:1.0 connect debounce failed, port 2 disabled
the numbers change but this phrase comes up endlessly

I can boot windows from the Live CD at "Boot from first hardisk"

I can't run Ubuntu from live cd!

I have, on a suggestion from a forumite, disconnected my USB ethernet connection to the Router but it made no diff.

How do I get Ubuntu 7.10 back again and running normally?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Andreas Bauer
Solved:
2008-02-29
Last query:
2008-02-29
Last reply:
2008-02-27
Andreas Bauer (bauer-andi) said : #1

Hello Plumtree,

have you already tried to boot up using the "nousb" kernel boot parameter? This will, as a first step, disable you USB hardware but might at least enable you to boot your system. Do you receive the same error message when booting from the live cd?

Regards,

Andi

Plumtree (redptc) said : #2

I was getting nowhere and my pc just wouldn't boot even Windows! Next morning, determined to sort things, I turned the PC on, made a cup of coffee and returned to the 'login screen'. Thought all was well but continual booting caused the fault again.

After about boot #10 or 11, it started with the "connect-debounce failed Phrase". It seemed to get progressively worse untill booting was not possible.

My first guess is overheating????

I don't have the 'smarts' to sort it out.........any help or tips?

Andreas Bauer (bauer-andi) said : #3

It seems this is a known bug in the linux kernel (see bug #88530). Do you have an onboard Bluetooth receiver on your PC? If so, you should try disabling it in BIOS and try again. Also, have you tried disabling USB with the "nousb" kernel option or in your BIOS? What did you observe?

As Leann Ogasawara suggests in comment 44 (https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/88530/comments/44), you might also want to try the new Hardy kernel (version 2.6.24) and see if that helps.

Plumtree (redptc) said : #4

Many thanks, Andreas & Leanne, for your very thoughtful and considered help.

It is interesting to note that the 'event' occurs immediately after ' * Starting Bluetooth Services (ok) ' but while I do not have any Bluetooth hardware on board, Ubuntu starts something!

It is also interesting that I have been able to boot to Ubuntu flawlessly again this morning. Things seems to work after a 'rest'???? I am using Windows now because I could not boot to Ubuntu again.

I haven't tried "nousb". My connection to the internet is via a Netgear USB adaptor and I am concerned about being able to restore my internet connection after cutting off the USB connectors.

I like the idea of trying the Hardy kernel but I do not have the ability to download to a DVD. Do you know of a way of getting it on a disk?

I have no need for Bluetooth! I was also wondering If there was some way of removing the command, * Starting Bluetooth sevices, from the start-up procedure. Do you know? Perhaps, without this challenge there would be no need to 'connect-debounce'

Plumtree (redptc) said : #5

The other aspect that is curious is the fact that windows does not boot unless there is a substantial 'cool down period' after running Ubuntu or Windows!

Is there some way of getting Hardy on a disk without down loading?

Best Andreas Bauer (bauer-andi) said : #6

The "nousb" kernel parameter only disables USB for this very system start. After rebooting, everything is back to normal. I was just wondering whether it's possible for you to boot without USB when you couldn't with USB enabled.

If you're just interested in the Ubuntu kernel, you don't have to download the entire CD/DVD. You can use a script I found at a blog (http://www.stickyness.de/2008/02/01/kernel-2624-in-ubuntu-gutsy-gibbon-sehr-einfach-zu-installieren/):

1. Download the python script from
http://forum.ubuntuusers.de/download/8901/
and save it e.g. in your home directory.
2. Make it executable by typing
chmod +x hardy.py
in a console.
3. Start the script via
sudo python hardy.py

The script will now download and install the Hardy kernel package, you will have to restart afterwards. Note that your old kernel will not be removed, you can still choose to boot with it from the grub menu.

This "cooling down" thing puzzles me - as quite a lot of people seem to have this problem, it seems to be a kernel bug, but this "cooling down" usually is a hint on some hardware issue...

You can disable Bluetooth quite easily, just follow this tutorial:

http://ubuntu-tutorials.com/2007/11/24/disable-bluetooth-on-ubuntu-710/

Especially the second part is important, blacklisting the bluetooth module is not mandatory.

Plumtree (redptc) said : #7

I have run the 'nousb' parameter with inconsistant results. However, I have concentrated my time on the hardware aspect to ensure all is correct. The USB ethernet connector appears to be not completely secure and may be responsible for the questionable and changing results suggesting 'overheating????'.

I installed an old ethernet card found in a box of spare parts and can now boot more consistantly than earlier. The connection avoids the extra connection associated with the USB fitting and is a solid, locked connection. Fortunately, Ubuntu will use it but Windows needs a driver so I am in the unusual situation of finding a driver for windows and not Linux!

Despite these changes, I still get 'hub 1-1:1.0 connect-debounce failed' over and over, until it does finally connect. When I sort my ethernet driver problem, I will pursue using the Hardy kernel as you suggested.

Disabling Bluetooth seemed to have no effect.

With all the help you have provided I am confident that we will soon be running smoothly again but, for the moment, I am a bit wary of saying my problem is solved.

Plumtree (redptc) said : #8

Many thanks Andreas, I have enabled the Hardy Kernel and things seem to almost back to normal. During all of this Gutsy has decided that it can no longer see the printer it has been printing to for months!

I do appreciate your help and especially the clear precise solutions you provided. I have enjoyed the learning aspect but hope life with Linux/Ubuntu is less eventful in the future.

I'll count this as solved and hope I get over the habit of closing my eyes every time I boot Ubuntu.

Plumtree (redptc) said : #9

Thanks Andreas Bauer, that solved my question.