why can't I play two or more sounds at the same time ?

Asked by Wladston Viana on 2006-11-22

How can I hear my new email notification sound while listening to music ?

How can I view some flash sites with sound effects while listening to a music ?

Is there a bug or a specification on this ? Should I fill one ?

Question information

Alan Pope ㋛ (popey) said : #1

I believe this depends on the sound daemon being used and how the audio applications are accessing the sound card. What music playing application are you using?

Wladston Viana (wladston) said : #2

I play music with rhythmbox, and the sound notication wav is launched from aplay.

My sound car is a Silicon Integrated Systems [SiS] AC'97 Sound Controller

Alan Pope ㋛ (popey) said : #3

Ok, can you try this:-

Press ALT+F2, and run gstreamer-properties. Change the default audio output plugin to ESD - Enlightenment Sound Daemon. See if that fixes it.

Wladston Viana (wladston) said : #4

It won'r work :(

some updates - I now realize aplay doesn't work anymore :

wladston@wlad:~$ aplay /home/wladston/localresources/WinXPNotify.wav
ALSA lib confmisc.c:1105:(snd_func_refer) Unable to find definition 'defaults.pcm.ipc_key'
ALSA lib conf.c:3479:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3947:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2146:(snd_pcm_open_noupdate) Unknown PCM dmix:SI7012
aplay: main:547: audio open error: No such file or directory
wladston@wlad:~$

And that setting doesn't work for me :

ESD - Enlightenment Sound Daemon: Could not establish connection to sound server

The ones that work are OSS and Custom. Neither will allow rythmbox and totem to play at the same time... :(

A question that would help me debbuging - how can I play wav files from the command line ?

Alright.
Close all applications that use sound.
Type "esd" in a terminal.
configure gstreamer and other apps to use esd.
[done]

Best Chris Wagner (chris-wagner) said : #6

I had a similar (probably the same) problem: trying to run "esd" would yield a message like you (Wladston) were getting when trying to run aplay. Here's how I fixed it:
  chris@chris-desktop:~$ asoundconf list
  Names of available sound cards:
  M5455
  M44
  chris@chris-desktop:~$ asoundconf set-default-card M5455
  chris@chris-desktop:~$ esd &

Of course, I don't know if esd is going to be running after I reboot again...

Wladston Viana (wladston) said : #7

User confirmed that the request is solved.

Wladston Viana (wladston) said : #8

WOW!! That was it !!! THANKS!! :)

Now my desktop is much better. I wonder why some users are having this issue. A bug should be reported. Like me, there may be others with this issue thinking stuff just "don't work" in linux.

The true is that it doesn't (yet) work out of box...

Chris Wagner (chris-wagner) said : #9

Wladston - Which version of Ubuntu are you using? Did you upgrade from Dapper to Edgy?

I lost my capability to play multiple sounds at once (i.e., a running esd) when upgrading from Dapper to Edgy - *I think*.

Yes, sadly, there probably are many other users troubled by this issue. The relevant bug report - or at least a related bug report - is bug 67988.

Wladston Viana (wladston) said : #10

Chris,

Yeah, that was my case! :)

I've tested, now with your instruction, I was able to play multiple sounds.

I've looked at the bug, it's not really related to sound :) Please check the bug number, I wanna say that I confirm the bug :)

Chris Wagner (chris-wagner) said : #11

Oh, shit. Sorry - wrong bug. How about bug 67998?

Wladston Viana (wladston) said : #12

that's it. Thanks! Posted there and linked this ticket.