Slow internet (download OK but "looking up" is slow)

Asked by yannick on 2006-11-18

I have trouble with my dsl connection. Not the speed itself (I checked it via some test-websites) but the time needed by firefox to "look-up" for a site is long reeeeeaaaaly long! I just moved today to linux to say that the modem is OK ans connection as well... call the hotline of my provider to hear that i have to install window oncve more :(((
would enjoy some help;))

thanks for reading


Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Caroline Ford (secretlondon) said : #1

Check to see what your DNS settings are (System->Administration->Network settings) Make sure they are the same as they were in windows (check your isp's web site if you are not sure what they should be)

Terence Simpson (tsimpson) said : #2

It's probably because the system is looking up an IPv6 address first, timing out then looking up the IPv4 address.
Take a look at: for how to disable IPv6

Roger Moll (roger68) said : #3

Changing the order of the DNS adresses changes the lookup speed as well, it seems. (System->Administration->Network settings)
On my machine, the IP adress of my router was the first IP adress shown, when this was moved to the bottom of the list, and the DNS adresses of my ISP to the top, this enhanced the speed quite a bit.

SvennaS (svenforum) said : #4

I have a similar problem, but even my download is slow.

I have a D-link 624+ Wireless Router.
The computers with wireless connection are fast enough.
The "server" with a cable connection is very slow (max. 13,5 Kb/s, most of the time 2 Kb/s)

The router has the configuration of the ADSL connection.
In system->admin->network the DNS is set to the IP of the router (
Is this the problem?

I already disabled ipv6, but it's not getting any faster. Changing the firefox value for network.dns connection via ipv6 to false, made a little difference for the browsing speed, but again nothing for overall speed.

I run Ubuntu Dapper, here are some specs:
0000:00:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:00:00, model 0 rev 0
  basic mode: autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control

SvennaS (svenforum) said : #5

Sorry, forgot the important spec ... They belong with the previous post:

Linux riche 2.6.15-27-386 #1 PREEMPT Sat Sep 16 01:51:59 UTC 2006 i686 GNU/Linux
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 32
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000007 (7)
        Link detected: yes

SvennaS (svenforum) said : #6

Found the problem ... It was the cable between router and "server".

Damn! Lost some hours on this one. :D

Thanks anyway.

Panchof (panchofrodriguez) said : #7

I have a dlink router connected to another router which connects through the internet.

i did the oposite of roger, my first dns server was my gateway and the second the router, my look up last forever then i swap the dns and bang i get internet full speed its amazing

good luck

MikeM (uk2002mike) said : #8

When I installed Ubuntu 7.04 on my office computer, it automatically installed as DHCP. No problem except Comcast recently changed the DNS ip's in my area and the new ip's are SOOOOO SLOW!

I went to System>Administration>Network, clicked on the HOST tab and force the old DNS ip's. Suddenly, everything was normal (and fast).

Davy Cielen (dcielen) said : #9

Changing the DNS to the default DNS of your IPS improved the speed of the internet dramaticaly.

cicciobello (sergio-severin) said : #10

I had the same problem. I use OpenDNS followed these simple instructions and not it is super fast!

bad_lopix (redpoint-mk) said : #11

I had the same problem in 8.10 - lookup took forever, afterwards was fast. What worked for me is editing /etc/resolv.conf and manually reordering the nameserver IP addresses there. Once that was done, Firefox was instantly back to full speed.

Can you help with this problem?

Provide an answer of your own, or ask yannick for more information if necessary.

To post a message you must log in.