Ubuntu 14.04 can't access certain https sites (facebook, login.live.com) over wireless

Asked by Mark on 2014-06-14

Edit - I've upgraded to Ubuntu 14.04 and the problem remains the same.

I've been running Ubuntu 12.04 on a Sony Viao VGN-NS10E for a couple of years.

With wireless to my home router, it's never once been able to access either hotmail through either Firefox or Chrome. It hangs at the connection to login.live.com until the browser times out.

Facebook is also problematic. It works sometimes, but then hangs.

Everything is fine on a wired ethernet connection to the same router, just wireless has the problem.

Wireless does work for http on most sites (e.g. mail.google.com), but hotmail and facebook have problems. There may be other sites with wireless problems as well, I can't remember.

I've searched the Internet, and I think other people have similar problems, but there was no definitive solution.

One thing I did try was to disable ipv6 (System Settings, Network, choose the wirless connection, ipv6 settings, and set it to ignored, save). This didn't help, although I am unsure if I needed to reboot after doing this.

Can anyone help - I'd like to install Ubuntu for a friend on their old similar laptop, but I'm holding off until I find a solution to this.

Thanks, Mark

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Mark (mark-reddin) said : #1

Testing this forum over wireless https


echo "nameserver" | sudo tee /etc/resolv.conf > /dev/null

Then try the pages. Is it ok?

Mark (mark-reddin) said : #3

Thanks, I will try that later, although I need to figure out what that command does.

Actually, I am now at a friend's house, with a different wireless router, and everything is fine. So I think it might be just a case of replacing my basic Netgear router at home with something else. It's probably some combination of the router settings and network settings in Ubuntu. All other devices at home (Windows laptop, iPad, various phones) work fine.

Why do you 'need' to know what it does? There is a world of difference between 'need' and 'would like'

The command changes your DNS servers to

If this works, we can make it stick. Your router is fine as the web works, just some pages don't.

Mark (mark-reddin) said : #6

I wanted to figure out what your command did before I changed my system. Didn't mean to cause offence.

Thanks. I tried this. It didn't work - no change in behaviour

Maybe interestingly, when I got home, I'd put the computer to sleep, and when I woke it up, hotmail was working fine over the wireless on my router. I guess that might be because the DNS lookup was cached, if your nameserver idea is along the right lines. Or maybe the computer had maintained a setting from being connected to my friend's network or router. I don't know.

Anyway, to reproduce the problem, I did sudo service network-manager restart and now it is the same as before, with the nameserver set to or the default of (which is what /etc/resolv.conf says on my machine)

Thanks again

Have you tried rebooting your router?

Mark (mark-reddin) said : #8

You mean as part of changing to DNS server, or just generally?

No I didn't try it as part of the experiment.
If the latter, I've had the problem for a couple of years, during which time my router has been rebooted many times.

Mark (mark-reddin) said : #9

Just to add that I've upgraded to Ubuntu 14.04 and the problem remains the same.

Mark (mark-reddin) said : #10

OK, I think I have a solution

From http://ubuntuforums.org/showthread.php?t=1593587, quoting here in case that links breaks. The below worked for me also, and has survived a reboot of my computer, a forget network and reconnect, and a couple of disconnects of the networking (disable wifi, reenable wifi).

Only thing is, I think I tried this a couple of years ago to no avail. Maybe the upgrade to 14.04 also helped.

"This is an mtu problem, in system-network-network conections select your connection type from the tabs;

Mine was wireless,

Now select your actual connection from the list ....
select Edit button at the side.
At the bottom you will see a field marked MTU: _____ it will likely be set to automatic, clearly the automated aspect of this is not being set - this could be a setting somewhere else that is incorrectly set but by choosing the correct number for this entry you should solve the problem.
For wireless the number will be 1492 then click apply and close.
if not try these consecutively; 1492,1454,1452,1460

You should be able to access that troublesome site with at least one of them."

thanh (thanh-nghiem101) said : #11

I've been struggling for a while being a newcomer to ubuntu. I tried all sorts of commands /etc/resolv.conf, ufw, etc

Checking many sites I found that while travelling in some countries (here for instance in Vietnam) there are issues with the DNS that may not accept to connect to all sites. So the solution is to set manually your DHCP and enter a public, open server like Google's, I couldn't find how to do thaton Ubuntu until I found this page http://doc.ubuntu-fr.org/network-manager

All you need to do is go to Network Manager, select your Wifi network and click on "modify connection". Then under ipv4, method, click "Manual".
Then click "add" adress and recopy your IP adress (details can be found in "Information on connection").
Then in DNS server enter, (careful of the points / coma between the numbers)
See how it should look http://doc.ubuntu-fr.org/_detail/networkmanager-ipfixe.png?id=network-manager

Now I can access all sites as usual

Unfortunately #11 didn't work for me but #10 did

In my case the problem was the MTU configuration, in my case using the value 1454 made it work.

Hope it helps!!!

gary fong (gwfong) said : #13

Making the MTU change worked for me. Thanks.